Photon Voice: Package Functions

Photon Voice v2.30

Here is a list of all documented namespace members with links to the namespaces they belong to:
  • AudioSampleType : Photon.Voice
  • AudioSessionCategory : Photon.Voice.IOS
  • AudioSessionCategoryOption : Photon.Voice.IOS
  • AudioSessionMode : Photon.Voice.IOS
  • Bandwidth : POpusCodec.Enums
  • Channels : POpusCodec.Enums
  • Codec : Photon.Voice
  • Delay : POpusCodec.Enums
  • OpusApplicationType : POpusCodec.Enums
  • SignalHint : POpusCodec.Enums
© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Package Functions

Photon Voice v2.30

  • AudioSampleType : Photon.Voice
  • AudioSessionCategory : Photon.Voice.IOS
  • AudioSessionCategoryOption : Photon.Voice.IOS
  • AudioSessionMode : Photon.Voice.IOS
  • Bandwidth : POpusCodec.Enums
  • Channels : POpusCodec.Enums
  • Codec : Photon.Voice
  • Delay : POpusCodec.Enums
  • OpusApplicationType : POpusCodec.Enums
  • SignalHint : POpusCodec.Enums


Photon Voice: Class List

Photon Voice v2.30

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345]
▼N Photon |
▼N Voice |
►N IOS |
C AudioSessionParameters |
C AudioSessionParametersPresets |
►N PUN |
►N UtilityScripts |
C VoiceDebugScript | Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player
C PhotonVoiceNetwork | This class can be used to automatically sync client states between PUN and Voice. It also sets a custom PUN Speaker factory to find the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab
C PhotonVoiceView | Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars
►N Unity |
►N UtilityScripts |
C ConnectAndJoin |
C MicAmplifier |
C MicAmplifierFloat |
C MicAmplifierShort |
C MicrophonePermission | Helper to request Microphone permission on Android or iOS
C PhotonVoiceLagSimulationGui |
C PhotonVoiceStatsGui | Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab
C SaveIncomingStreamToFile |
C SaveOutgoingStreamToFile |
C TestTone |
C ToneAudioReader |
C AndroidAudioInAEC |
C AndroidAudioInParameters |
C AudioChangesHandler | This component is useful to handle audio device and config changes
C AudioClipWrapper |
C AudioInEnumerator |
C AudioInEnumeratorEx |
C AudioOutCapture |
C ILoggable |
C ILoggableDependent |
C Logger |
C MicWrapper |
C MicWrapperPusher |
C NativeAndroidMicrophoneSettings |
C PhotonVoiceCreatedParams |
C PlaybackDelaySettings | Playback delay configuration container
►C Recorder | Component representing outgoing audio stream in scene
C PhotonVoiceCreatedParams |
C RemoteVoiceLink |
C Speaker | Component representing remote audio stream in local scene
C UnityAudioOut |
C UnityMicrophone | A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL
C VoiceComponent |
C VoiceConnection | Component that represents a client voice connection to Photon Servers
C VoiceLogger |
C WebRtcAudioDsp |
C AudioDesc |
C AudioInChangeNotifierNotSupported |
►C AudioOutDelayControl |
C PlayDelayConfig |
C AudioSyncBuffer |
►C AudioUtil | Collection of Audio Utility functions and classes
C ILevelMeter | Audio Level Metering interface
C IVoiceDetector | Voice Activity Detector interface
C LevelMeter | Audio Level Meter
C LevelMeterDummy | Dummy Audio Level Meter that doesn't actually do anything
C LevelMeterFloat | LevelMeter specialization for float audio
C LevelMeterShort | LevelMeter specialization for short audio
C Resampler | Sample-rate conversion Audio Processor
C TempoUp |
C ToneAudioPusher | IAudioPusher that provides a constant tone signal
C ToneAudioReader | IAudioReader that provides a constant tone signal
C VoiceDetector | Simple voice activity detector triggered by signal level
C VoiceDetectorCalibration | Calibration Utility for Voice Detector
C VoiceDetectorDummy | Dummy VoiceDetector that doesn't actually do anything
C VoiceDetectorFloat | VoiceDetector specialization for float audio
C VoiceDetectorShort | VoiceDetector specialization for float audio
C VoiceLevelDetectCalibrate | Utility Audio Processor Voice Detection Calibration
C BufferReaderPushAdapter | Simple BufferReaderPushAdapterBase<T> implementation using a single buffer and synchronous LocalVoiceFramed<T>.PushData
C BufferReaderPushAdapterAsyncPool | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync
C BufferReaderPushAdapterAsyncPoolCopy | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync(T[]) and data copy
C BufferReaderPushAdapterAsyncPoolFloatToShort | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short
C BufferReaderPushAdapterAsyncPoolShortToFloat | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float
C BufferReaderPushAdapterBase | Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice
C DeviceEnumeratorBase |
C DeviceInfo |
C FactoryPrimitiveArrayPool | PrimitiveArrayPool<T> as wrapped in object factory interface
C FactoryReusableArray | Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created
C Flip |
C FrameBuffer |
C FrameOut |
C Framer | Utility class to re-frame audio packets
C IAudioDesc | Audio Source interface
C IAudioInChangeNotifier |
C IAudioOut |
C IAudioPusher | Audio Pusher interface
C IAudioReader | Audio Reader interface
C IDataReader | Interface for pulling data, in case this is more appropriate than pushing it
C IDecoder | Generic decoder interface
C IDecoderDirect | Interface for an decoder which outputs data via explicit call
C IDeviceEnumerator |
C IEncoder | Generic encoder interface
C IEncoderDirect | Interface for an encoder which consumes input data via explicit call
C IEncoderDirectImage | Interface for an encoder which consumes images via explicit call
C ILocalVoiceAudio | Interface for an outgoing audio stream
C ILogger |
►C ImageBufferInfo |
C StrideSet |
►C ImageBufferNative |
C PlaneSet |
C ImageBufferNativeAlloc |
C ImageBufferNativeGCHandleSinglePlane |
C ImageBufferNativePool |
C IProcessor | Audio Processor interface
C IResettable |
C IServiceable | Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice
C IVoiceTransport |
C LoadBalancingFrontend |
C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
C LoadBalancingTransport2 | Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients
C LocalVoice | Represents outgoing data stream
C LocalVoiceAudio | Outgoing audio stream
C LocalVoiceAudioDummy | Dummy LocalVoiceAudio
C LocalVoiceAudioFloat | Specialization of LocalVoiceAudio<T> for float audio
C LocalVoiceAudioShort | Specialization of LocalVoiceAudio<T> for short audio
C LocalVoiceFramed | Typed re-framing LocalVoice
C LocalVoiceFramedBase | Typed re-framing LocalVoice
C ObjectFactory | Uniform interface to ObjectPool<TType, TInfo> and single reusable object
C ObjectPool | Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo)
►C OpusCodec |
C Decoder |
C DecoderFactory |
C Encoder |
C EncoderFloat |
C EncoderShort |
C Factory |
C Util |
C Platform |
C PrimitiveArrayPool | Pool of Arrays with components of type T, with ObjectPool info being the array's size
►C RawCodec |
C Decoder |
C Encoder |
C ShortToFloat |
C RemoteVoiceInfo | Information about a remote voice (incoming stream)
C RemoteVoiceOptions | Event Actions and other options for a remote voice (incoming stream)
C UnsupportedCodecException | Exception thrown if an unsupported codec is encountered
C UnsupportedPlatformException | Exception thrown if an unsupported platform is encountered
C UnsupportedSampleTypeException | Exception thrown if an unsupported audio sample type is encountered
►C VoiceClient | Voice client interact with other clients on network via IVoiceTransport
C CreateOptions |
C VoiceEvent |
C VoiceInfo | Describes stream properties
C WebRTCAudioLib |
C WebRTCAudioProcessor |
▼N POpusCodec |
C OpusDecoder |
C OpusEncoder |
C OpusException |
C OpusLib |


Photon Voice: Photon Namespace Reference

Photon Voice v2.30

Namespaces
Photon Namespace Reference


Photon Voice: Photon.Voice Namespace Reference

Photon Voice v2.30

  • Photon
  • Voice
Namespaces | Classes | Enumerations
Photon.Voice Namespace Reference

Classes

class | AudioDesc
class | AudioInChangeNotifierNotSupported
class | AudioInEnumeratorNotSupported
class | AudioOutDelayControl
class | AudioSyncBuffer
class | AudioUtil
Collection of Audio Utility functions and classes. More...
class | BufferReaderPushAdapter
Simple BufferReaderPushAdapterBase<T> implementation using a single buffer and synchronous LocalVoiceFramed<T>.PushData More...
class | BufferReaderPushAdapterAsyncPool
BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync. More...
class | BufferReaderPushAdapterAsyncPoolCopy
BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync(T[]) and data copy. More...
class | BufferReaderPushAdapterAsyncPoolFloatToShort
BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short. More...
class | BufferReaderPushAdapterAsyncPoolShortToFloat
BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float. More...
class | BufferReaderPushAdapterBase
Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice. More...
class | DeviceEnumeratorBase
class | DeviceEnumeratorNotSupported
struct | DeviceInfo
class | FactoryPrimitiveArrayPool
PrimitiveArrayPool<T> as wrapped in object factory interface. More...
class | FactoryReusableArray
Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created. More...
struct | Flip
struct | FrameBuffer
class | FrameOut
class | Framer
Utility class to re-frame audio packets. More...
interface | IAudioDesc
Audio Source interface. More...
interface | IAudioInChangeNotifier
interface | IAudioOut
interface | IAudioPusher
Audio Pusher interface. More...
interface | IAudioReader
Audio Reader interface. More...
interface | IDataReader
Interface for pulling data, in case this is more appropriate than pushing it. More...
interface | IDecoder
Generic decoder interface. More...
interface | IDecoderDirect
Interface for an decoder which outputs data via explicit call. More...
interface | IDeviceEnumerator
interface | IEncoder
Generic encoder interface. More...
interface | IEncoderDirect
Interface for an encoder which consumes input data via explicit call. More...
interface | IEncoderDirectImage
Interface for an encoder which consumes images via explicit call. More...
interface | ILocalVoiceAudio
Interface for an outgoing audio stream. More...
interface | ILogger
struct | ImageBufferInfo
class | ImageBufferNative
class | ImageBufferNativeAlloc
class | ImageBufferNativeGCHandleSinglePlane
class | ImageBufferNativePool
interface | IProcessor
Audio Processor interface. More...
interface | IResettable
interface | IServiceable
Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice. More...
interface | IVoiceTransport
class | LoadBalancingFrontend
class | LoadBalancingTransport
Extends LoadBalancingClient with media streaming functionality. More...
class | LoadBalancingTransport2
Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients. More...
class | LocalVoice
Represents outgoing data stream. More...
class | LocalVoiceAudio
Outgoing audio stream. More...
class | LocalVoiceAudioDummy
Dummy LocalVoiceAudio More...
class | LocalVoiceAudioFloat
Specialization of LocalVoiceAudio<T> for float audio More...
class | LocalVoiceAudioShort
Specialization of LocalVoiceAudio<T> for short audio More...
class | LocalVoiceFramed
Typed re-framing LocalVoice More...
class | LocalVoiceFramedBase
Typed re-framing LocalVoice More...
interface | ObjectFactory
Uniform interface to ObjectPool<TType, TInfo> and single reusable object. More...
class | ObjectPool
Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo). More...
class | OpusCodec
class | PhotonTransportProtocol
class | Platform
class | PrimitiveArrayPool
Pool of Arrays with components of type T, with ObjectPool info being the array's size. More...
class | RawCodec
class | RemoteVoice
class | RemoteVoiceInfo
Information about a remote voice (incoming stream). More...
struct | RemoteVoiceOptions
Event Actions and other options for a remote voice (incoming stream). More...
class | SpacingProfile
class | UnsupportedCodecException
Exception thrown if an unsupported codec is encountered. More...
class | UnsupportedPlatformException
Exception thrown if an unsupported platform is encountered. More...
class | UnsupportedSampleTypeException
Exception thrown if an unsupported audio sample type is encountered. More...
class | Util
class | VideoInEnumeratorNotSupported
class | VoiceClient
Voice client interact with other clients on network via IVoiceTransport. More...
class | VoiceEvent
struct | VoiceInfo
Describes stream properties. More...
class | WebRTCAudioLib
class | WebRTCAudioProcessor

Enumerations

enum | AudioSampleType
The type of samples used for audio processing. More...
enum | FrameFlags : byte
enum | Codec
Enum for Media Codecs supported by PhotonVoice. More...
enum | ImageFormat
enum | Rotation

Enumeration Type Documentation

◆ AudioSampleType

enum AudioSampleType
strong

The type of samples used for audio processing.

◆ Codec

enum Codec
strong

Enum for Media Codecs supported by PhotonVoice.

Transmitted in VoiceInfo. Do not change the values of this Enum!

Enumerator
AudioOpus

OPUS audio


Photon Voice: Photon.Voice.IOS Namespace Reference

Photon Voice v2.30

  • IOS
Classes | Enumerations
Photon.Voice.IOS Namespace Reference

Classes

struct | AudioSessionParameters
class | AudioSessionParametersPresets

Enumerations

enum | AudioSessionCategory
enum | AudioSessionMode
enum | AudioSessionCategoryOption

Enumeration Type Documentation

◆ AudioSessionCategory

enum AudioSessionCategory
strong
Enumerator
Ambient

Use this category for background sounds such as rain, car engine noise, etc.
Mixes with other music.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

SoloAmbient

Use this category for background sounds. Other music will stop playing.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

Playback

Use this category for music tracks.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

Record

Use this category when recording audio.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

PlayAndRecord

Use this category when recording and playing back audio.

API_AVAILABLE(ios(3.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

AudioProcessing

Use this category when using a hardware codec or signal processor while not playing or recording audio.

API_DEPRECATED("No longer supported", ios(3.0, 10.0)) API_UNAVAILABLE(watchos, tvos) API_UNAVAILABLE(macos);

MultiRoute

Use this category to customize the usage of available audio accessories and built-in audio hardware. For example, this category provides an application with the ability to use an available USB output and headphone output simultaneously for separate, distinct streams of audio data. Use of this category by an application requires a more detailed knowledge of, and interaction with, the capabilities of the available audio routes. May be used for input, output, or both. Note that not all output types and output combinations are eligible for multi-route. Input is limited to the last-in input port. Eligible inputs consist of the following: AVAudioSessionPortUSBAudio, AVAudioSessionPortHeadsetMic, and AVAudioSessionPortBuiltInMic.
Eligible outputs consist of the following: AVAudioSessionPortUSBAudio, AVAudioSessionPortLineOut, AVAudioSessionPortHeadphones, AVAudioSessionPortHDMI, and AVAudioSessionPortBuiltInSpeaker.
Note that AVAudioSessionPortBuiltInSpeaker is only allowed to be used when there are no other eligible outputs connected.

API_AVAILABLE(ios(6.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);

◆ AudioSessionCategoryOption

enum AudioSessionCategoryOption
strong
Enumerator
MixWithOthers

This allows an application to set whether or not other active audio apps will be interrupted or mixed with when your app's audio session goes active. The typical cases are: (1) AVAudioSessionCategoryPlayAndRecord or AVAudioSessionCategoryMultiRoute this will default to false, but can be set to true. This would allow other applications to play in the background while an app had both audio input and output enabled (2) AVAudioSessionCategoryPlayback this will default to false, but can be set to true. This would allow other applications to play in the background, but an app will still be able to play regardless of the setting of the ringer switch (3) Other categories this defaults to false and cannot be changed (that is, the mix with others setting of these categories cannot be overridden. An application must be prepared for setting this property to fail as behaviour may change in future releases. If an application changes their category, they should reassert the option (it is not sticky across category changes). MixWithOthers is only valid with AVAudioSessionCategoryPlayAndRecord, AVAudioSessionCategoryPlayback, and AVAudioSessionCategoryMultiRoute

DuckOthers

This allows an application to set whether or not other active audio apps will be ducked when when your app's audio session goes active. An example of this is the Nike app, which provides periodic updates to its user (it reduces the volume of any music currently being played while it provides its status). This defaults to off. Note that the other audio will be ducked for as long as the current session is active. You will need to deactivate your audio session when you want full volume playback of the other audio. If your category is AVAudioSessionCategoryPlayback, AVAudioSessionCategoryPlayAndRecord, or AVAudioSessionCategoryMultiRoute, by default the audio session will be non-mixable and non-ducking. Setting this option will also make your category mixable with others (AVAudioSessionCategoryOptionMixWithOthers will be set). DuckOthers is only valid with AVAudioSessionCategoryAmbient, AVAudioSessionCategoryPlayAndRecord, AVAudioSessionCategoryPlayback, and AVAudioSessionCategoryMultiRoute

AllowBluetooth

This allows an application to change the default behaviour of some audio session categories with regards to showing bluetooth Hands-Free Profile (HFP) devices as available routes. The current category behavior is: (1) AVAudioSessionCategoryPlayAndRecord this will default to false, but can be set to true. This will allow a paired bluetooth HFP device to show up as an available route for input, while playing through the category-appropriate output (2) AVAudioSessionCategoryRecord this will default to false, but can be set to true. This will allow a paired bluetooth HFP device to show up as an available route for input (3) Other categories this defaults to false and cannot be changed (that is, enabling bluetooth for input in these categories is not allowed) An application must be prepared for setting this option to fail as behaviour may change in future releases. If an application changes their category or mode, they should reassert the override (it is not sticky across category and mode changes). AllowBluetooth is only valid with AVAudioSessionCategoryRecord and AVAudioSessionCategoryPlayAndRecord

DefaultToSpeaker

This allows an application to change the default behaviour of some audio session categories with regards to the audio route. The current category behavior is: (1) AVAudioSessionCategoryPlayAndRecord category this will default to false, but can be set to true. this will route to Speaker (instead of Receiver) when no other audio route is connected. (2) Other categories this defaults to false and cannot be changed (that is, the default to speaker setting of these categories cannot be overridden An application must be prepared for setting this property to fail as behaviour may change in future releases. If an application changes their category, they should reassert the override (it is not sticky across category and mode changes). DefaultToSpeaker is only valid with AVAudioSessionCategoryPlayAndRecord

◆ AudioSessionMode

enum AudioSessionMode
strong
Enumerator
Default | Modes modify the audio category in order to introduce behavior that is tailored to the specific use of audio within an application. Available in iOS 5.0 and greater. The default mode API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
VoiceChat | Only valid with AVAudioSessionCategoryPlayAndRecord. Appropriate for Voice over IP (VoIP) applications. Reduces the number of allowable audio routes to be only those that are appropriate for VoIP applications and may engage appropriate system-supplied signal processing. Has the side effect of setting AVAudioSessionCategoryOptionAllowBluetooth API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
VideoRecording | Only valid with AVAudioSessionCategoryPlayAndRecord or AVAudioSessionCategoryRecord. Modifies the audio routing options and may engage appropriate system-supplied signal processing. API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
Measurement | Appropriate for applications that wish to minimize the effect of system-supplied signal processing for input and/or output audio signals. API_AVAILABLE(ios(5.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
MoviePlayback | Engages appropriate output signal processing for movie playback scenarios. Currently only applied during playback over built-in speaker. API_AVAILABLE(ios(6.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);
VideoChat | Only valid with kAudioSessionCategory_PlayAndRecord. Reduces the number of allowable audio routes to be only those that are appropriate for video chat applications. May engage appropriate system-supplied signal processing. Has the side effect of setting AVAudioSessionCategoryOptionAllowBluetooth and AVAudioSessionCategoryOptionDefaultToSpeaker. API_AVAILABLE(ios(7.0), watchos(2.0), tvos(9.0)) API_UNAVAILABLE(macos);


Photon Voice: AudioSessionParameters Struct Reference

Photon Voice v2.30

  • IOS
  • AudioSessionParameters
Public Member Functions | Public Attributes | List of all members
AudioSessionParameters Struct Reference

Public Member Functions

int | CategoryOptionsToInt ()
override string | ToString ()

Public Attributes

AudioSessionCategory | Category
AudioSessionMode | Mode
AudioSessionCategoryOption[] | CategoryOptions


Photon Voice: Member List

Photon Voice v2.30

  • IOS
  • AudioSessionParameters
AudioSessionParameters Member List

This is the complete list of members for AudioSessionParameters, including all inherited members.

Category (defined in AudioSessionParameters) | AudioSessionParameters
CategoryOptions (defined in AudioSessionParameters) | AudioSessionParameters
CategoryOptionsToInt() (defined in AudioSessionParameters) | AudioSessionParameters
Mode (defined in AudioSessionParameters) | AudioSessionParameters
ToString() (defined in AudioSessionParameters) | AudioSessionParameters


Photon Voice: AudioSessionParametersPresets Class Reference

Photon Voice v2.30

  • IOS
  • AudioSessionParametersPresets
Static Public Attributes | List of all members
AudioSessionParametersPresets Class Reference

Static Public Attributes

static AudioSessionParameters | Game
static AudioSessionParameters | VoIP

Member Data Documentation

◆ Game

AudioSessionParameters Game
static
Initial value:
= new AudioSessionParameters()
{
Category = AudioSessionCategory.PlayAndRecord,
Mode = AudioSessionMode.Default,
CategoryOptions = new AudioSessionCategoryOption[] { AudioSessionCategoryOption.DefaultToSpeaker, AudioSessionCategoryOption.AllowBluetooth }
}

◆ VoIP

AudioSessionParameters VoIP
static
Initial value:
= new AudioSessionParameters()
{
Category = AudioSessionCategory.PlayAndRecord,
Mode = AudioSessionMode.VoiceChat,
CategoryOptions = new AudioSessionCategoryOption[] { AudioSessionCategoryOption.AllowBluetooth }
}
Photon.Voice.IOS.AudioSessionCategoryOption
AudioSessionCategoryOption
Definition: iOSAudioSession.cs:129
Photon.Voice.IOS.AudioSessionCategory
AudioSessionCategory
Definition: iOSAudioSession.cs:3
Photon.Voice.IOS.AudioSessionMode
AudioSessionMode
Definition: iOSAudioSession.cs:50


Photon Voice: Member List

Photon Voice v2.30

  • IOS
  • AudioSessionParametersPresets
AudioSessionParametersPresets Member List

This is the complete list of members for AudioSessionParametersPresets, including all inherited members.

Game (defined in AudioSessionParametersPresets) | AudioSessionParametersPresets | static
VoIP (defined in AudioSessionParametersPresets) | AudioSessionParametersPresets | static


Photon Voice: Photon.Voice.PUN Namespace Reference

Photon Voice v2.30

  • PUN
Namespaces | Classes
Photon.Voice.PUN Namespace Reference

Classes

class | PhotonVoiceNetwork
This class can be used to automatically sync client states between PUN and Voice. It also sets a custom PUN Speaker factory to find the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab. More...
class | PhotonVoiceView
Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars. More...


Photon Voice: Photon.Voice.PUN.UtilityScripts Namespace Reference

Photon Voice v2.30

  • PUN
  • UtilityScripts
Classes
Photon.Voice.PUN.UtilityScripts Namespace Reference

Classes

class VoiceDebugScript
Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player. More...


Photon Voice: VoiceDebugScript Class Reference

Photon Voice v2.30

  • PUN
  • UtilityScripts
  • VoiceDebugScript
Public Member Functions | Public Attributes | List of all members
VoiceDebugScript Class Reference

Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player. More...

Inherits MonoBehaviourPun.

Public Member Functions

void CantHearYou ()

Public Attributes

bool | ForceRecordingAndTransmission
Make sure recorder.TransmitEnabled and recorder.IsRecording are true. More...
AudioClip | TestAudioClip
Audio file to be broadcast when TestUsingAudioClip is enabled. More...
bool | TestUsingAudioClip
Broadcast Audio file to make sure transmission over network works if microphone (audio input device/hardware) is not reliable. Requires setting AudioClip in TestAudioClip. More...
bool | DisableVad
Disable recorder.VoiceDetection for easier testing. More...
bool | IncreaseLogLevels
Set main voice component's log level to ALL (max). More...
bool | LocalDebug
Debug DebugEcho mode (Can't Hear My Self?!). More...

Detailed Description

Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player.

Member Data Documentation

◆ DisableVad

bool DisableVad

Disable recorder.VoiceDetection for easier testing.

◆ ForceRecordingAndTransmission

bool ForceRecordingAndTransmission

Make sure recorder.TransmitEnabled and recorder.IsRecording are true.

◆ IncreaseLogLevels

bool IncreaseLogLevels

Set main voice component's log level to ALL (max).

◆ LocalDebug

bool LocalDebug

Debug DebugEcho mode (Can't Hear My Self?!).

◆ TestAudioClip

AudioClip TestAudioClip

Audio file to be broadcast when TestUsingAudioClip is enabled.

◆ TestUsingAudioClip

bool TestUsingAudioClip

Broadcast Audio file to make sure transmission over network works if microphone (audio input device/hardware) is not reliable. Requires setting AudioClip in TestAudioClip.


Photon Voice: Member List

Photon Voice v2.30

  • PUN
  • UtilityScripts
  • VoiceDebugScript
VoiceDebugScript Member List

This is the complete list of members for VoiceDebugScript, including all inherited members.

CantHearYou() (defined in VoiceDebugScript) | VoiceDebugScript
DisableVad | VoiceDebugScript
ForceRecordingAndTransmission | VoiceDebugScript
IncreaseLogLevels | VoiceDebugScript
LocalDebug | VoiceDebugScript
TestAudioClip | VoiceDebugScript
TestUsingAudioClip | VoiceDebugScript


Photon Voice: PhotonVoiceNetwork Class Reference

Photon Voice v2.30

  • PUN
  • PhotonVoiceNetwork
Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Properties | List of all members
PhotonVoiceNetwork Class Reference

This class can be used to automatically sync client states between PUN and Voice. It also sets a custom PUN Speaker factory to find the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab. More...

Inherits VoiceConnection.

Public Member Functions

bool | ConnectAndJoinRoom ()
Connect voice client to Photon servers and join a Voice room More...
void | Disconnect ()
Disconnect voice client from all Photon servers More...
- Public Member Functions inherited from VoiceConnection
bool | ConnectUsingSettings (AppSettings overwriteSettings=null)
Connect to Photon server using Settings More...
void | InitRecorder (Recorder rec)
Initializes the Recorder component to be able to transmit audio. More...
void | SetPlaybackDelaySettings (PlaybackDelaySettings gpds)
Sets the global configuration for the playback behaviour in case of delays. More...
void | SetGlobalPlaybackDelaySettings (int low, int high, int max)
Sets the global configuration for the playback behaviour in case of delays. More...
virtual bool | TryLateLinkingUsingUserData (Speaker speaker, object userData)
Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started. More...

Public Attributes

bool | AutoConnectAndJoin = true
Auto connect voice client and join a voice room when PUN client is joined to a PUN room More...
bool | AutoLeaveAndDisconnect = true
Auto disconnect voice client when PUN client is not joined to a PUN room More...
bool | WorkInOfflineMode = true
Whether or not Photon Voice client should follow PUN client if the latter is in offline mode. More...
- Public Attributes inherited from VoiceConnection
AppSettings | Settings
Settings to be used by this voice connection More...
Func< int, byte, object, Speaker > | SpeakerFactory
Special factory to link Speaker components with incoming remote audio streams More...
float | MinimalTimeScaleToDispatchInFixedUpdate = -1f
Configures the minimal Time.timeScale at which Voice client will dispatch incoming messages within LateUpdate. More...
bool | AutoCreateSpeakerIfNotFound = true
Auto instantiate a GameObject and attach a Speaker component to link to a remote audio stream if no candidate could be found More...
int | MaxDatagrams = 3
Limits the number of datagrams that are created in each LateUpdate. More...
bool | SendAsap
Signals that outgoing messages should be sent in the next LateUpdate call. More...

Static Public Attributes

const string VoiceRoomNameSuffix = "_voice_"
Suffix for voice room names appended to PUN room names. More...

Protected Member Functions

override void | Awake ()
override void | OnDisable ()
override void | OnDestroy ()
override void | OnVoiceStateChanged (ClientState fromState, ClientState toState)
override Speaker | SimpleSpeakerFactory (int playerId, byte voiceId, object userData)
- Protected Member Functions inherited from VoiceConnection
override void | Awake ()
virtual void | Update ()
virtual void | FixedUpdate ()
void | Dispatch ()
Dispatches incoming network messages for Voice client. Called in FixedUpdate or LateUpdate. More...
override void | OnDisable ()
void | CalcStatistics ()
void | LinkSpeaker (Speaker speaker, RemoteVoiceLink remoteVoice)
virtual void | OnOperationResponseReceived (OperationResponse operationResponse)

Properties

static PhotonVoiceNetwork | Instance [get, set]
Singleton instance for PhotonVoiceNetwork More...
bool | UsePunAuthValues [get, set]
Whether or not to use the same PhotonNetwork.AuthValues in PhotonVoiceNetwork.Instance.Client.AuthValues. This means that the same UserID will be used in both clients. If custom authentication is used and setup in PUN app, the same configuration should be done for the Voice app. More...
- Properties inherited from VoiceConnection
VoiceLogger | Logger [get, protected set]
Logger used by this component More...
DebugLevel | LogLevel [get, set]
Log level for this component More...
new LoadBalancingTransport | Client [get]
VoiceClient | VoiceClient [get]
Returns underlying Photon Voice client. More...
ClientState | ClientState [get]
Returns Photon Voice client state. More...
float | FramesReceivedPerSecond [get]
Number of frames received per second. More...
float | FramesLostPerSecond [get]
Number of frames lost per second. More...
float | FramesLostPercent [get]
Percentage of lost frames. More...
GameObject | SpeakerPrefab [get, set]
Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info More...
Recorder | PrimaryRecorder [get, set]
Main Recorder to be used for transmission by default More...
DebugLevel | GlobalRecordersLogLevel [get, set]
DebugLevel | GlobalSpeakersLogLevel [get, set]
int | GlobalPlaybackDelay [get, set]
string | BestRegionSummaryInPreferences [get, set]
Used to store and access the "Best Region Summary" in the Player Preferences. More...
int | GlobalPlaybackDelayMinSoft [get]
Gets the global value in ms above which the audio player tries to keep the delay. More...
int | GlobalPlaybackDelayMaxSoft [get]
Gets the global value in ms below which the audio player tries to keep the delay. More...
int | GlobalPlaybackDelayMaxHard [get]
Gets the global value in ms that audio play delay will not exceed. More...
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Additional Inherited Members

- Protected Attributes inherited from VoiceConnection
List< RemoteVoiceLink > | cachedRemoteVoices = new List<RemoteVoiceLink>()
- Events inherited from VoiceConnection
Action< Speaker > | SpeakerLinked
Fires when a speaker has been linked to a remote audio stream More...
Action< RemoteVoiceLink > | RemoteVoiceAdded
Fires when a remote voice stream is added More...

Detailed Description

This class can be used to automatically sync client states between PUN and Voice. It also sets a custom PUN Speaker factory to find the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab.

Member Function Documentation

◆ ConnectAndJoinRoom()

bool ConnectAndJoinRoom ( )

Connect voice client to Photon servers and join a Voice room

Returns
If true, connection command send from client

◆ Disconnect()

void Disconnect ( )

Disconnect voice client from all Photon servers

Member Data Documentation

◆ AutoConnectAndJoin

bool AutoConnectAndJoin = true

Auto connect voice client and join a voice room when PUN client is joined to a PUN room

◆ AutoLeaveAndDisconnect

bool AutoLeaveAndDisconnect = true

Auto disconnect voice client when PUN client is not joined to a PUN room

◆ VoiceRoomNameSuffix

const string VoiceRoomNameSuffix = "_voice_"
static

Suffix for voice room names appended to PUN room names.

◆ WorkInOfflineMode

bool WorkInOfflineMode = true

Whether or not Photon Voice client should follow PUN client if the latter is in offline mode.

Property Documentation

◆ Instance

PhotonVoiceNetwork Instance
staticgetset

Singleton instance for PhotonVoiceNetwork

◆ UsePunAuthValues

bool UsePunAuthValues
getset

Whether or not to use the same PhotonNetwork.AuthValues in PhotonVoiceNetwork.Instance.Client.AuthValues. This means that the same UserID will be used in both clients. If custom authentication is used and setup in PUN app, the same configuration should be done for the Voice app.


Photon Voice: Member List

Photon Voice v2.30

  • PUN
  • PhotonVoiceNetwork
PhotonVoiceNetwork Member List

This is the complete list of members for PhotonVoiceNetwork, including all inherited members.

AutoConnectAndJoin | PhotonVoiceNetwork |
AutoCreateSpeakerIfNotFound | VoiceConnection |
AutoLeaveAndDisconnect | PhotonVoiceNetwork |
Awake() (defined in PhotonVoiceNetwork) | PhotonVoiceNetwork | protected
BestRegionSummaryInPreferences | VoiceConnection |
cachedRemoteVoices (defined in VoiceConnection) | VoiceConnection | protected
CalcStatistics() (defined in VoiceConnection) | VoiceConnection | protected
Client (defined in VoiceConnection) | VoiceConnection |
ClientState | VoiceConnection |
ConnectAndJoinRoom() | PhotonVoiceNetwork |
ConnectUsingSettings(AppSettings overwriteSettings=null) | VoiceConnection |
Disconnect() | PhotonVoiceNetwork |
Dispatch() | VoiceConnection | protected
FixedUpdate() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
FramesLostPercent | VoiceConnection |
FramesLostPerSecond | VoiceConnection |
FramesReceivedPerSecond | VoiceConnection |
GlobalPlaybackDelay (defined in VoiceConnection) | VoiceConnection |
GlobalPlaybackDelayMaxHard | VoiceConnection |
GlobalPlaybackDelayMaxSoft | VoiceConnection |
GlobalPlaybackDelayMinSoft | VoiceConnection |
GlobalRecordersLogLevel (defined in VoiceConnection) | VoiceConnection |
GlobalSpeakersLogLevel (defined in VoiceConnection) | VoiceConnection |
InitRecorder(Recorder rec) | VoiceConnection |
Instance | PhotonVoiceNetwork | static
LinkSpeaker(Speaker speaker, RemoteVoiceLink remoteVoice) (defined in VoiceConnection) | VoiceConnection | protected
Logger | VoiceConnection |
LogLevel | VoiceConnection |
MaxDatagrams | VoiceConnection |
MinimalTimeScaleToDispatchInFixedUpdate | VoiceConnection |
OnDestroy() (defined in PhotonVoiceNetwork) | PhotonVoiceNetwork | protectedvirtual
OnDisable() (defined in PhotonVoiceNetwork) | PhotonVoiceNetwork | protected
OnOperationResponseReceived(OperationResponse operationResponse) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
OnVoiceStateChanged(ClientState fromState, ClientState toState) (defined in PhotonVoiceNetwork) | PhotonVoiceNetwork | protectedvirtual
PrimaryRecorder | VoiceConnection |
RemoteVoiceAdded | VoiceConnection |
SendAsap | VoiceConnection |
SetGlobalPlaybackDelaySettings(int low, int high, int max) | VoiceConnection |
SetPlaybackDelaySettings(PlaybackDelaySettings gpds) | VoiceConnection |
Settings | VoiceConnection |
SimpleSpeakerFactory(int playerId, byte voiceId, object userData) (defined in PhotonVoiceNetwork) | PhotonVoiceNetwork | protectedvirtual
SpeakerFactory | VoiceConnection |
SpeakerLinked | VoiceConnection |
SpeakerPrefab | VoiceConnection |
TryLateLinkingUsingUserData(Speaker speaker, object userData) | VoiceConnection | virtual
Update() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
UsePunAuthValues | PhotonVoiceNetwork |
VoiceClient | VoiceConnection |
VoiceRoomNameSuffix | PhotonVoiceNetwork | static
WorkInOfflineMode | PhotonVoiceNetwork |


Photon Voice: PhotonVoiceView Class Reference

Photon Voice v2.30

  • PUN
  • PhotonVoiceView
Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
PhotonVoiceView Class Reference

Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars. More...

Inherits VoiceComponent.

Public Member Functions

void Init ()
Initializes this PhotonVoiceView for Voice usage based on the PhotonView, Recorder and Speaker components. More...

Public Attributes

bool | AutoCreateRecorderIfNotFound
If true, a Recorder component will be added to the same GameObject if not found already. More...
bool | UsePrimaryRecorder
If true, PhotonVoiceNetwork.PrimaryRecorder will be used by this PhotonVoiceView More...
bool | SetupDebugSpeaker
If true, a Speaker component will be setup to be used for the DebugEcho mode More...

Protected Member Functions

override void Awake ()

Properties

Recorder | RecorderInUse [get, set]
The Recorder component currently used by this PhotonVoiceView More...
Speaker | SpeakerInUse [get, set]
The Speaker component currently used by this PhotonVoiceView More...
bool | IsSetup [get]
If true, this PhotonVoiceView is setup and ready to be used More...
bool | IsSpeaker [get]
If true, this PhotonVoiceView has a Speaker setup for playback of received audio frames from remote audio source More...
bool | IsSpeaking [get]
If true, this PhotonVoiceView has a Speaker that is currently playing received audio frames from remote audio source More...
bool | IsRecorder [get]
If true, this PhotonVoiceView has a Recorder setup for transmission of audio stream from local audio source More...
bool | IsRecording [get]
If true, this PhotonVoiceView has a Recorder that is currently transmitting audio stream from local audio source More...
bool | IsSpeakerLinked [get]
If true, the SpeakerInUse is linked to the remote voice stream More...
bool | IsPhotonViewReady [get]
If true, the PhotonView attached to the same GameObject has a valid ViewID > 0 More...
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
DebugLevel logLevel = DebugLevel.WARNING

Detailed Description

Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars.

Member Function Documentation

◆ Init()

void Init ( )

Initializes this PhotonVoiceView for Voice usage based on the PhotonView, Recorder and Speaker components.

The initialization should happen automatically. Call this method explicitly if this does not succeed. The initialization is a two steps operation: step one is the setup of Recorder and Speaker to be used. Step two is the late-linking -if needed- of the SpeakerInUse and corresponding remote voice info -if any- via ViewID.

Member Data Documentation

◆ AutoCreateRecorderIfNotFound

bool AutoCreateRecorderIfNotFound

If true, a Recorder component will be added to the same GameObject if not found already.

◆ SetupDebugSpeaker

bool SetupDebugSpeaker

If true, a Speaker component will be setup to be used for the DebugEcho mode

◆ UsePrimaryRecorder

bool UsePrimaryRecorder

If true, PhotonVoiceNetwork.PrimaryRecorder will be used by this PhotonVoiceView

Property Documentation

◆ IsPhotonViewReady

bool IsPhotonViewReady
get

If true, the PhotonView attached to the same GameObject has a valid ViewID > 0

◆ IsRecorder

bool IsRecorder
get

If true, this PhotonVoiceView has a Recorder setup for transmission of audio stream from local audio source

◆ IsRecording

bool IsRecording
get

If true, this PhotonVoiceView has a Recorder that is currently transmitting audio stream from local audio source

◆ IsSetup

bool IsSetup
get

If true, this PhotonVoiceView is setup and ready to be used

◆ IsSpeaker

bool IsSpeaker
get

If true, this PhotonVoiceView has a Speaker setup for playback of received audio frames from remote audio source

◆ IsSpeakerLinked

bool IsSpeakerLinked
get

If true, the SpeakerInUse is linked to the remote voice stream

◆ IsSpeaking

bool IsSpeaking
get

If true, this PhotonVoiceView has a Speaker that is currently playing received audio frames from remote audio source

◆ RecorderInUse

Recorder RecorderInUse
getset

The Recorder component currently used by this PhotonVoiceView

◆ SpeakerInUse

Speaker SpeakerInUse
getset

The Speaker component currently used by this PhotonVoiceView


Photon Voice: Member List

Photon Voice v2.30

  • PUN
  • PhotonVoiceView
PhotonVoiceView Member List

This is the complete list of members for PhotonVoiceView, including all inherited members.

AutoCreateRecorderIfNotFound | PhotonVoiceView |
Awake() (defined in PhotonVoiceView) | PhotonVoiceView | protectedvirtual
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
Init() | PhotonVoiceView |
IsPhotonViewReady | PhotonVoiceView |
IsRecorder | PhotonVoiceView |
IsRecording | PhotonVoiceView |
IsSetup | PhotonVoiceView |
IsSpeaker | PhotonVoiceView |
IsSpeakerLinked | PhotonVoiceView |
IsSpeaking | PhotonVoiceView |
Logger (defined in VoiceComponent) | VoiceComponent |
LogLevel (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
RecorderInUse | PhotonVoiceView |
SetupDebugSpeaker | PhotonVoiceView |
SpeakerInUse | PhotonVoiceView |
UsePrimaryRecorder | PhotonVoiceView |


Photon Voice: Photon.Voice.Unity Namespace Reference

Photon Voice v2.30

  • Unity
Namespaces | Classes
Photon.Voice.Unity Namespace Reference

Classes

class | AndroidAudioInAEC
class | AndroidAudioInParameters
class | AudioChangesHandler
This component is useful to handle audio device and config changes. More...
class | AudioClipWrapper
class | AudioInEnumerator
class | AudioInEnumeratorEx
class | AudioOutCapture
interface | ILoggable
interface | ILoggableDependent
class | Logger
class | MicWrapper
class | MicWrapperPusher
struct | NativeAndroidMicrophoneSettings
class | PhotonVoiceCreatedParams
struct | PlaybackDelaySettings
Playback delay configuration container. More...
class | Recorder
Component representing outgoing audio stream in scene. More...
class | RemoteVoiceLink
class | Speaker
Component representing remote audio stream in local scene. More...
class | UnityAudioOut
class | UnityMicrophone
A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL. More...
class | VoiceComponent
class | VoiceConnection
Component that represents a client voice connection to Photon Servers. More...
class | VoiceLogger
class | WebRtcAudioDsp


Photon Voice: Photon.Voice.Unity.UtilityScripts Namespace Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
Classes
Photon.Voice.Unity.UtilityScripts Namespace Reference

Classes

class | ConnectAndJoin
class | MicAmplifier
class | MicAmplifierFloat
class | MicAmplifierShort
class | MicrophonePermission
Helper to request Microphone permission on Android or iOS. More...
class | PhotonVoiceLagSimulationGui
class | PhotonVoiceStatsGui
Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab. More...
class | SaveIncomingStreamToFile
class | SaveOutgoingStreamToFile
class | TestTone
class | ToneAudioReader


Photon Voice: ConnectAndJoin Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • ConnectAndJoin
Public Member Functions | Public Attributes | Properties | List of all members
ConnectAndJoin Class Reference

Inherits MonoBehaviour, IConnectionCallbacks, and IMatchmakingCallbacks.

Public Member Functions

void | ConnectNow ()
void | OnCreatedRoom ()
void | OnCreateRoomFailed (short returnCode, string message)
void | OnFriendListUpdate (List< FriendInfo > friendList)
void | OnJoinedRoom ()
void | OnJoinRandomFailed (short returnCode, string message)
void | OnJoinRoomFailed (short returnCode, string message)
void | OnLeftRoom ()
void | OnConnected ()
void | OnConnectedToMaster ()
void | OnDisconnected (DisconnectCause cause)
void | OnRegionListReceived (RegionHandler regionHandler)
void | OnCustomAuthenticationResponse (Dictionary< string, object > data)
void | OnCustomAuthenticationFailed (string debugMessage)

Public Attributes

bool | RandomRoom = true
string | RoomName

Properties

bool IsConnected [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • ConnectAndJoin
ConnectAndJoin Member List

This is the complete list of members for ConnectAndJoin, including all inherited members.

ConnectNow() (defined in ConnectAndJoin) | ConnectAndJoin
IsConnected (defined in ConnectAndJoin) | ConnectAndJoin
OnConnected() (defined in ConnectAndJoin) | ConnectAndJoin
OnConnectedToMaster() (defined in ConnectAndJoin) | ConnectAndJoin
OnCreatedRoom() (defined in ConnectAndJoin) | ConnectAndJoin
OnCreateRoomFailed(short returnCode, string message) (defined in ConnectAndJoin) | ConnectAndJoin
OnCustomAuthenticationFailed(string debugMessage) (defined in ConnectAndJoin) | ConnectAndJoin
OnCustomAuthenticationResponse(Dictionary< string, object > data) (defined in ConnectAndJoin) | ConnectAndJoin
OnDisconnected(DisconnectCause cause) (defined in ConnectAndJoin) | ConnectAndJoin
OnFriendListUpdate(List< FriendInfo > friendList) (defined in ConnectAndJoin) | ConnectAndJoin
OnJoinedRoom() (defined in ConnectAndJoin) | ConnectAndJoin
OnJoinRandomFailed(short returnCode, string message) (defined in ConnectAndJoin) | ConnectAndJoin
OnJoinRoomFailed(short returnCode, string message) (defined in ConnectAndJoin) | ConnectAndJoin
OnLeftRoom() (defined in ConnectAndJoin) | ConnectAndJoin
OnRegionListReceived(RegionHandler regionHandler) (defined in ConnectAndJoin) | ConnectAndJoin
RandomRoom (defined in ConnectAndJoin) | ConnectAndJoin
RoomName (defined in ConnectAndJoin) | ConnectAndJoin


Photon Voice: MicAmplifier Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicAmplifier
Properties | List of all members
MicAmplifier Class Reference

Inherits VoiceComponent.

Properties

float | AmplificationFactor [get, set]
float | BoostValue [get, set]
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Additional Inherited Members

- Protected Member Functions inherited from VoiceComponent
virtual void | Awake ()
- Protected Attributes inherited from VoiceComponent
DebugLevel | logLevel = DebugLevel.WARNING


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicAmplifier
MicAmplifier Member List

This is the complete list of members for MicAmplifier, including all inherited members.

AmplificationFactor (defined in MicAmplifier) | MicAmplifier |
Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
BoostValue (defined in MicAmplifier) | MicAmplifier |
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
Logger (defined in VoiceComponent) | VoiceComponent |
LogLevel (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected


Photon Voice: MicAmplifierFloat Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicAmplifierFloat
Public Member Functions | Properties | List of all members
MicAmplifierFloat Class Reference

Inherits IProcessor< float >.

Public Member Functions

MicAmplifierFloat (float amplificationFactor, float boostValue)
float[] | Process (float[] buf)
void | Dispose ()
- Public Member Functions inherited from IProcessor< float >
T[] | Process (T[] buf)
Process a frame of audio data. More...

Properties

float | AmplificationFactor [get, set]
float | BoostValue [get, set]
float | MaxBefore [get]
float | MaxAfter [get]
bool | Disabled [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicAmplifierFloat
MicAmplifierFloat Member List

This is the complete list of members for MicAmplifierFloat, including all inherited members.

AmplificationFactor (defined in MicAmplifierFloat) | MicAmplifierFloat
BoostValue (defined in MicAmplifierFloat) | MicAmplifierFloat
Disabled (defined in MicAmplifierFloat) | MicAmplifierFloat
Dispose() (defined in MicAmplifierFloat) | MicAmplifierFloat
MaxAfter (defined in MicAmplifierFloat) | MicAmplifierFloat
MaxBefore (defined in MicAmplifierFloat) | MicAmplifierFloat
MicAmplifierFloat(float amplificationFactor, float boostValue) (defined in MicAmplifierFloat) | MicAmplifierFloat
Process(float[] buf) (defined in MicAmplifierFloat) | MicAmplifierFloat
IProcessor< float >.Process(T[] buf) | IProcessor< float >


Photon Voice: MicAmplifierShort Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicAmplifierShort
Public Member Functions | Properties | List of all members
MicAmplifierShort Class Reference

Inherits IProcessor< short >.

Public Member Functions

MicAmplifierShort (short amplificationFactor, short boostValue)
short[] | Process (short[] buf)
void | Dispose ()
- Public Member Functions inherited from IProcessor< short >
T[] | Process (T[] buf)
Process a frame of audio data. More...

Properties

short | AmplificationFactor [get, set]
short | BoostValue [get, set]
short | MaxBefore [get]
short | MaxAfter [get]
bool | Disabled [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicAmplifierShort
MicAmplifierShort Member List

This is the complete list of members for MicAmplifierShort, including all inherited members.

AmplificationFactor (defined in MicAmplifierShort) | MicAmplifierShort
BoostValue (defined in MicAmplifierShort) | MicAmplifierShort
Disabled (defined in MicAmplifierShort) | MicAmplifierShort
Dispose() (defined in MicAmplifierShort) | MicAmplifierShort
MaxAfter (defined in MicAmplifierShort) | MicAmplifierShort
MaxBefore (defined in MicAmplifierShort) | MicAmplifierShort
MicAmplifierShort(short amplificationFactor, short boostValue) (defined in MicAmplifierShort) | MicAmplifierShort
Process(short[] buf) (defined in MicAmplifierShort) | MicAmplifierShort
IProcessor< short >.Process(T[] buf) | IProcessor< short >


Photon Voice: MicrophonePermission Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicrophonePermission
Public Member Functions | Protected Member Functions | Properties | Events | List of all members
MicrophonePermission Class Reference

Helper to request Microphone permission on Android or iOS. More...

Inherits VoiceComponent.

Public Member Functions

void InitVoice ()

Protected Member Functions

override void Awake ()

Properties

bool? | HasPermission [get]
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Events

static Action< bool > MicrophonePermissionCallback

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
DebugLevel logLevel = DebugLevel.WARNING

Detailed Description

Helper to request Microphone permission on Android or iOS.


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • MicrophonePermission
MicrophonePermission Member List

This is the complete list of members for MicrophonePermission, including all inherited members.

Awake() (defined in MicrophonePermission) | MicrophonePermission | protectedvirtual
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
HasPermission (defined in MicrophonePermission) | MicrophonePermission |
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
InitVoice() (defined in MicrophonePermission) | MicrophonePermission |
Logger (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
LogLevel (defined in VoiceComponent) | VoiceComponent |
MicrophonePermissionCallback (defined in MicrophonePermission) | MicrophonePermission | static


Photon Voice: PhotonVoiceLagSimulationGui Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • PhotonVoiceLagSimulationGui
Public Member Functions | List of all members
PhotonVoiceLagSimulationGui Class Reference

Inherits MonoBehaviour.

Public Member Functions

void OnEnable ()


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • PhotonVoiceLagSimulationGui
PhotonVoiceLagSimulationGui Member List

This is the complete list of members for PhotonVoiceLagSimulationGui, including all inherited members.

OnEnable() (defined in PhotonVoiceLagSimulationGui) PhotonVoiceLagSimulationGui


Photon Voice: PhotonVoiceStatsGui Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • PhotonVoiceStatsGui
List of all members
PhotonVoiceStatsGui Class Reference

Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab. More...

Inherits MonoBehaviour.

Detailed Description

Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab.

The shown health values can help identify problems with connection losses or performance. Example: If the time delta between two consecutive SendOutgoingCommands calls is a second or more, chances rise for a disconnect being caused by this (because acknowledgments to the server need to be sent in due time).


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • PhotonVoiceStatsGui
PhotonVoiceStatsGui Member List

This is the complete list of members for PhotonVoiceStatsGui, including all inherited members.


Photon Voice: SaveIncomingStreamToFile Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • SaveIncomingStreamToFile
Protected Member Functions | List of all members
SaveIncomingStreamToFile Class Reference

Inherits VoiceComponent.

Protected Member Functions

override void Awake ()

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
DebugLevel | logLevel = DebugLevel.WARNING
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • SaveIncomingStreamToFile
SaveIncomingStreamToFile Member List

This is the complete list of members for SaveIncomingStreamToFile, including all inherited members.

Awake() (defined in SaveIncomingStreamToFile) | SaveIncomingStreamToFile | protectedvirtual
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
Logger (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
LogLevel (defined in VoiceComponent) | VoiceComponent |


Photon Voice: SaveOutgoingStreamToFile Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • SaveOutgoingStreamToFile
Classes | List of all members
SaveOutgoingStreamToFile Class Reference

Inherits VoiceComponent.

Additional Inherited Members

- Protected Member Functions inherited from VoiceComponent
virtual void | Awake ()
- Protected Attributes inherited from VoiceComponent
DebugLevel | logLevel = DebugLevel.WARNING
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • SaveOutgoingStreamToFile
SaveOutgoingStreamToFile Member List

This is the complete list of members for SaveOutgoingStreamToFile, including all inherited members.

Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
Logger (defined in VoiceComponent) | VoiceComponent |
LogLevel (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected


Photon Voice: TestTone Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • TestTone
List of all members
TestTone Class Reference

Inherits MonoBehaviour.


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • TestTone
TestTone Member List

This is the complete list of members for TestTone, including all inherited members.


Photon Voice: ToneAudioReader Class Reference

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • ToneAudioReader
Public Member Functions | Properties | List of all members
ToneAudioReader Class Reference

Inherits IAudioReader< float >.

Public Member Functions

void | Dispose ()
bool | Read (float[] buf)

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UtilityScripts
  • ToneAudioReader
ToneAudioReader Member List

This is the complete list of members for ToneAudioReader, including all inherited members.

Channels (defined in ToneAudioReader) | ToneAudioReader
Dispose() (defined in ToneAudioReader) | ToneAudioReader
Error (defined in ToneAudioReader) | ToneAudioReader
Read(float[] buf) (defined in ToneAudioReader) | ToneAudioReader
SamplingRate (defined in ToneAudioReader) | ToneAudioReader
ToneAudioReader() (defined in ToneAudioReader) | ToneAudioReader


Photon Voice: AndroidAudioInAEC Class Reference

Photon Voice v2.30

  • Unity
  • AndroidAudioInAEC
Classes | Public Member Functions | Properties | List of all members
AndroidAudioInAEC Class Reference

Inherits IAudioPusher< short >, and IResettable.

Public Member Functions

AndroidAudioInAEC (Voice.ILogger logger, bool enableAEC=false, bool enableAGC=false, bool enableNS=false)
void | SetCallback (Action< short[]> callback, ObjectFactory< short[], int > bufferFactory)
void | Reset ()
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< short >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • AndroidAudioInAEC
AndroidAudioInAEC Member List

This is the complete list of members for AndroidAudioInAEC, including all inherited members.

AndroidAudioInAEC(Voice.ILogger logger, bool enableAEC=false, bool enableAGC=false, bool enableNS=false) (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Channels (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Dispose() (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Error (defined in AndroidAudioInAEC) | AndroidAudioInAEC
Reset() (defined in AndroidAudioInAEC) | AndroidAudioInAEC
SamplingRate (defined in AndroidAudioInAEC) | AndroidAudioInAEC
SetCallback(Action< short[]> callback, ObjectFactory< short[], int > bufferFactory) (defined in AndroidAudioInAEC) | AndroidAudioInAEC
IAudioPusher< short >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< short >


Photon Voice: AndroidAudioInParameters Class Reference

Photon Voice v2.30

  • Unity
  • AndroidAudioInParameters
Public Attributes | List of all members
AndroidAudioInParameters Class Reference

Public Attributes

bool | EnableAEC = false
bool | EnableAGC = false
bool | EnableNS = false


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • AndroidAudioInParameters
AndroidAudioInParameters Member List

This is the complete list of members for AndroidAudioInParameters, including all inherited members.

EnableAEC (defined in AndroidAudioInParameters) | AndroidAudioInParameters
EnableAGC (defined in AndroidAudioInParameters) | AndroidAudioInParameters
EnableNS (defined in AndroidAudioInParameters) | AndroidAudioInParameters


Photon Voice: AudioChangesHandler Class Reference

Photon Voice v2.30

  • Unity
  • AudioChangesHandler
Public Attributes | Protected Member Functions | List of all members
AudioChangesHandler Class Reference

This component is useful to handle audio device and config changes. More...

Inherits VoiceComponent.

Public Attributes

bool | StartWhenDeviceChange = true
Try to start recording when we get devices change notification and recording is not started. More...
bool | HandleDeviceChange = true
Try to react to device change notification when Recorder is started. More...
bool | HandleConfigChange = true
Try to react to audio config change notification when Recorder is started. More...
bool | UseNativePluginChangeNotifier = true
Whether or not to make use of Photon's AudioInChangeNotifier native plugin. More...
bool | UseOnAudioConfigurationChanged = true
Whether or not to make use of Unity's OnAudioConfigurationChanged. More...

Protected Member Functions

override void Awake ()

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
DebugLevel | logLevel = DebugLevel.WARNING
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Detailed Description

This component is useful to handle audio device and config changes.

Member Data Documentation

◆ HandleConfigChange

bool HandleConfigChange = true

Try to react to audio config change notification when Recorder is started.

This requires UseOnAudioConfigurationChanged to be true.

◆ HandleDeviceChange

bool HandleDeviceChange = true

Try to react to device change notification when Recorder is started.

This requires UseNativePluginChangeNotifier or UseOnAudioConfigurationChanged to be true.

◆ StartWhenDeviceChange

bool StartWhenDeviceChange = true

Try to start recording when we get devices change notification and recording is not started.

On some platforms we can't make sure that a device change notification could mean that at least a microphone device is now available. Besides, the auto start of the recording might not happen if other necessary conditions set in Recorder are not met: e.g. Recorder.RecordOnlyWhenEnabled or Recorder.RecordOnlyWhenJoined etc. or if the Recorder has been stopped explicitly via Recorder.StopRecording call or Recorder.IsRecording set to false.

◆ UseNativePluginChangeNotifier

bool UseNativePluginChangeNotifier = true

Whether or not to make use of Photon's AudioInChangeNotifier native plugin.

This may disable HandleDeviceChange if this and UseOnAudioConfigurationChanged are both false.

◆ UseOnAudioConfigurationChanged

bool UseOnAudioConfigurationChanged = true

Whether or not to make use of Unity's OnAudioConfigurationChanged.

This is needed for HandleConfigChange and may also disable HandleDeviceChange if this and UseNativePluginChangeNotifier are both false.


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • AudioChangesHandler
AudioChangesHandler Member List

This is the complete list of members for AudioChangesHandler, including all inherited members.

Awake() (defined in AudioChangesHandler) | AudioChangesHandler | protectedvirtual
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
HandleConfigChange | AudioChangesHandler |
HandleDeviceChange | AudioChangesHandler |
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
Logger (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
LogLevel (defined in VoiceComponent) | VoiceComponent |
StartWhenDeviceChange | AudioChangesHandler |
UseNativePluginChangeNotifier | AudioChangesHandler |
UseOnAudioConfigurationChanged | AudioChangesHandler |


Photon Voice: AudioClipWrapper Class Reference

Photon Voice v2.30

  • Unity
  • AudioClipWrapper
Public Member Functions | Properties | List of all members
AudioClipWrapper Class Reference

Inherits IAudioReader< float >.

Public Member Functions

AudioClipWrapper (AudioClip audioClip)
bool | Read (float[] buffer)
void | Dispose ()

Properties

bool | Loop [get, set]
int | SamplingRate [get]
int | Channels [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • AudioClipWrapper
AudioClipWrapper Member List

This is the complete list of members for AudioClipWrapper, including all inherited members.

AudioClipWrapper(AudioClip audioClip) (defined in AudioClipWrapper) | AudioClipWrapper
Channels (defined in AudioClipWrapper) | AudioClipWrapper
Dispose() (defined in AudioClipWrapper) | AudioClipWrapper
Error (defined in AudioClipWrapper) | AudioClipWrapper
Loop (defined in AudioClipWrapper) | AudioClipWrapper
Read(float[] buffer) (defined in AudioClipWrapper) | AudioClipWrapper
SamplingRate (defined in AudioClipWrapper) | AudioClipWrapper


Photon Voice: AudioInEnumerator Class Reference

Photon Voice v2.30

  • Unity
  • AudioInEnumerator
Public Member Functions | Properties | List of all members
AudioInEnumerator Class Reference

Inherits DeviceEnumeratorBase.

Public Member Functions

AudioInEnumerator (ILogger logger)
override void | Refresh ()
override void | Dispose ()
- Public Member Functions inherited from DeviceEnumeratorBase
DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()

Properties

override string | Error [get]
- Properties inherited from DeviceEnumeratorBase
virtual string | Error [get, protected set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
string | Error [get]

Additional Inherited Members

- Public Attributes inherited from DeviceEnumeratorBase
virtual bool | IsSupported => true
- Protected Attributes inherited from DeviceEnumeratorBase
List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • AudioInEnumerator
AudioInEnumerator Member List

This is the complete list of members for AudioInEnumerator, including all inherited members.

AudioInEnumerator(ILogger logger) (defined in AudioInEnumerator) | AudioInEnumerator |
DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in AudioInEnumerator) | AudioInEnumerator | virtual
Error (defined in AudioInEnumerator) | AudioInEnumerator |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Refresh() (defined in AudioInEnumerator) | AudioInEnumerator | virtual


Photon Voice: AudioInEnumeratorEx Class Reference

Photon Voice v2.30

  • Unity
  • AudioInEnumeratorEx
Static Public Member Functions | List of all members
AudioInEnumeratorEx Class Reference

Static Public Member Functions

static bool | IDIsValid (this IDeviceEnumerator en, int id)
static string | NameAtIndex (this IDeviceEnumerator en, int index)
static int | IDAtIndex (this IDeviceEnumerator en, int index)


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • AudioInEnumeratorEx
AudioInEnumeratorEx Member List

This is the complete list of members for AudioInEnumeratorEx, including all inherited members.

IDAtIndex(this IDeviceEnumerator en, int index) (defined in AudioInEnumeratorEx) | AudioInEnumeratorEx | static
IDIsValid(this IDeviceEnumerator en, int id) (defined in AudioInEnumeratorEx) | AudioInEnumeratorEx | static
NameAtIndex(this IDeviceEnumerator en, int index) (defined in AudioInEnumeratorEx) | AudioInEnumeratorEx | static


Photon Voice: AudioOutCapture Class Reference

Photon Voice v2.30

  • Unity
  • AudioOutCapture
Events | List of all members
AudioOutCapture Class Reference

Inherits MonoBehaviour.

Events

Action< float[], int > OnAudioFrame


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • AudioOutCapture
AudioOutCapture Member List

This is the complete list of members for AudioOutCapture, including all inherited members.

OnAudioFrame (defined in AudioOutCapture) AudioOutCapture


Photon Voice: ILoggable Interface Reference

Photon Voice v2.30

  • Unity
  • ILoggable
Properties | List of all members
ILoggable Interface Reference

Inherited by ILoggableDependent, and VoiceConnection.

Properties

DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • ILoggable
ILoggable Member List

This is the complete list of members for ILoggable, including all inherited members.

Logger (defined in ILoggable) | ILoggable
LogLevel (defined in ILoggable) | ILoggable


Photon Voice: ILoggableDependent Interface Reference

Photon Voice v2.30

  • Unity
  • ILoggableDependent
Properties | List of all members
ILoggableDependent Interface Reference

Inherits ILoggable.

Inherited by VoiceComponent.

Properties

bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • ILoggableDependent
ILoggableDependent Member List

This is the complete list of members for ILoggableDependent, including all inherited members.

IgnoreGlobalLogLevel (defined in ILoggableDependent) | ILoggableDependent
Logger (defined in ILoggable) | ILoggable
LogLevel (defined in ILoggable) | ILoggable


Photon Voice: Logger Class Reference

Photon Voice v2.30

  • Unity
  • Logger
Public Member Functions | List of all members
Logger Class Reference

Inherits ILogger.

Public Member Functions

void | LogError (string fmt, params object[] args)
void | LogWarning (string fmt, params object[] args)
void | LogInfo (string fmt, params object[] args)
void | LogDebug (string fmt, params object[] args)


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • Logger
Logger Member List

This is the complete list of members for Logger, including all inherited members.

LogDebug(string fmt, params object[] args) (defined in Logger) | Logger
LogError(string fmt, params object[] args) (defined in Logger) | Logger
LogInfo(string fmt, params object[] args) (defined in Logger) | Logger
LogWarning(string fmt, params object[] args) (defined in Logger) | Logger


Photon Voice: MicWrapper Class Reference

Photon Voice v2.30

  • Unity
  • MicWrapper
Public Member Functions | Properties | List of all members
MicWrapper Class Reference

Inherits IAudioReader< float >.

Public Member Functions

MicWrapper (string device, int suggestedFrequency, ILogger logger)
void | Dispose ()
bool | Read (float[] buffer)

Properties

int? | SamplingRate [get]
int? | Channels [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • MicWrapper
MicWrapper Member List

This is the complete list of members for MicWrapper, including all inherited members.

Channels (defined in MicWrapper) | MicWrapper
Dispose() (defined in MicWrapper) | MicWrapper
Error (defined in MicWrapper) | MicWrapper
MicWrapper(string device, int suggestedFrequency, ILogger logger) (defined in MicWrapper) | MicWrapper
Read(float[] buffer) (defined in MicWrapper) | MicWrapper
SamplingRate (defined in MicWrapper) | MicWrapper


Photon Voice: MicWrapperPusher Class Reference

Photon Voice v2.30

  • Unity
  • MicWrapperPusher
Public Member Functions | Properties | List of all members
MicWrapperPusher Class Reference

Inherits IAudioPusher< float >.

Public Member Functions

MicWrapperPusher (string device, AudioSource aS, int suggestedFrequency, ILogger lg, bool destroyOnStop=true)
MicWrapperPusher (string device, GameObject gO, int suggestedFrequency, ILogger lg, bool destroyOnStop=true)
MicWrapperPusher (string device, Transform parentTransform, int suggestedFrequency, ILogger lg, bool destroyOnStop=true)
void | SetCallback (Action< float[]> callback, ObjectFactory< float[], int > bufferFactory)
void | Dispose ()
- Public Member Functions inherited from IAudioPusher< float >
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Properties

int? | SamplingRate [get]
int? | Channels [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • MicWrapperPusher
MicWrapperPusher Member List

This is the complete list of members for MicWrapperPusher, including all inherited members.

Channels (defined in MicWrapperPusher) | MicWrapperPusher
Dispose() (defined in MicWrapperPusher) | MicWrapperPusher
Error (defined in MicWrapperPusher) | MicWrapperPusher
MicWrapperPusher(string device, AudioSource aS, int suggestedFrequency, ILogger lg, bool destroyOnStop=true) (defined in MicWrapperPusher) | MicWrapperPusher
MicWrapperPusher(string device, GameObject gO, int suggestedFrequency, ILogger lg, bool destroyOnStop=true) (defined in MicWrapperPusher) | MicWrapperPusher
MicWrapperPusher(string device, Transform parentTransform, int suggestedFrequency, ILogger lg, bool destroyOnStop=true) (defined in MicWrapperPusher) | MicWrapperPusher
SamplingRate (defined in MicWrapperPusher) | MicWrapperPusher
SetCallback(Action< float[]> callback, ObjectFactory< float[], int > bufferFactory) (defined in MicWrapperPusher) | MicWrapperPusher
IAudioPusher< float >.SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< float >


Photon Voice: NativeAndroidMicrophoneSettings Struct Reference

Photon Voice v2.30

  • Unity
  • NativeAndroidMicrophoneSettings
Public Attributes | List of all members
NativeAndroidMicrophoneSettings Struct Reference

Public Attributes

bool | AcousticEchoCancellation
bool | AutomaticGainControl
bool | NoiseSuppression


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • NativeAndroidMicrophoneSettings
NativeAndroidMicrophoneSettings Member List

This is the complete list of members for NativeAndroidMicrophoneSettings, including all inherited members.

AcousticEchoCancellation (defined in NativeAndroidMicrophoneSettings) | NativeAndroidMicrophoneSettings
AutomaticGainControl (defined in NativeAndroidMicrophoneSettings) | NativeAndroidMicrophoneSettings
NoiseSuppression (defined in NativeAndroidMicrophoneSettings) | NativeAndroidMicrophoneSettings


Photon Voice: PhotonVoiceCreatedParams Class Reference

Photon Voice v2.30

  • Unity
  • PhotonVoiceCreatedParams
Properties | List of all members
PhotonVoiceCreatedParams Class Reference

Inherited by Recorder.PhotonVoiceCreatedParams.

Properties

Voice.LocalVoice | Voice [get, set]
Voice.IAudioDesc | AudioDesc [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • PhotonVoiceCreatedParams
PhotonVoiceCreatedParams Member List

This is the complete list of members for PhotonVoiceCreatedParams, including all inherited members.

AudioDesc (defined in PhotonVoiceCreatedParams) | PhotonVoiceCreatedParams
Voice (defined in PhotonVoiceCreatedParams) | PhotonVoiceCreatedParams


Photon Voice: PlaybackDelaySettings Struct Reference

Photon Voice v2.30

  • Unity
  • PlaybackDelaySettings
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
PlaybackDelaySettings Struct Reference

Playback delay configuration container. More...

Public Member Functions

override string ToString ()

Public Attributes

int | MinDelaySoft
ms: Audio player tries to keep the delay above this value. More...
int | MaxDelaySoft
ms: Audio player tries to keep the delay below this value. More...
int | MaxDelayHard
ms: Audio player guarantees that the delay never exceeds this value. More...

Static Public Attributes

const int | DEFAULT_LOW = 200
const int | DEFAULT_HIGH = 400
const int | DEFAULT_MAX = 1000

Detailed Description

Playback delay configuration container.

Member Data Documentation

◆ MaxDelayHard

int MaxDelayHard

ms: Audio player guarantees that the delay never exceeds this value.

◆ MaxDelaySoft

int MaxDelaySoft

ms: Audio player tries to keep the delay below this value.

◆ MinDelaySoft

int MinDelaySoft

ms: Audio player tries to keep the delay above this value.


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • PlaybackDelaySettings
PlaybackDelaySettings Member List

This is the complete list of members for PlaybackDelaySettings, including all inherited members.

DEFAULT_HIGH (defined in PlaybackDelaySettings) | PlaybackDelaySettings | static
DEFAULT_LOW (defined in PlaybackDelaySettings) | PlaybackDelaySettings | static
DEFAULT_MAX (defined in PlaybackDelaySettings) | PlaybackDelaySettings | static
MaxDelayHard | PlaybackDelaySettings |
MaxDelaySoft | PlaybackDelaySettings |
MinDelaySoft | PlaybackDelaySettings |
ToString() (defined in PlaybackDelaySettings) | PlaybackDelaySettings |


Photon Voice: Recorder Class Reference

Photon Voice v2.30

  • Unity
  • Recorder
Classes | Public Types | Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Member Functions | Properties | List of all members
Recorder Class Reference

Component representing outgoing audio stream in scene. More...

Inherits VoiceComponent.

Classes

class PhotonVoiceCreatedParams

Public Types

enum | InputSourceType
enum | MicType
enum | SampleTypeConv

Public Member Functions

void | Init (VoiceConnection connection)
Initializes the Recorder component to be able to transmit audio. More...
void | ReInit ()
void | RestartRecording (bool force=false)
Restarts recording if something has changed that requires this. More...
void | VoiceDetectorCalibrate (int durationMs, Action< float > detectionEndedCallback=null)
Trigger voice detector calibration process. While calibrating, keep silence. Voice detector sets threshold basing on measured background noise level. More...
void | StartRecording ()
Starts recording. More...
void | StopRecording ()
Stops recording. More...
bool | ResetLocalAudio ()
Resets audio session and parameters locally to fix broken recording due to system configuration modifications or audio interruptions or audio routing changes. More...

Static Public Member Functions

static bool | CompareUnityMicNames (string mic1, string mic2)
static bool | IsDefaultUnityMic (string mic)

Static Public Attributes

const int | MIN_OPUS_BITRATE = 6000
const int | MAX_OPUS_BITRATE = 510000

Protected Member Functions

virtual void | SendPhotonVoiceCreatedMessage ()
- Protected Member Functions inherited from VoiceComponent
virtual void | Awake ()

Properties

static IDeviceEnumerator | PhotonMicrophoneEnumerator [get]
Enumerator for the available microphone devices gathered by the Photon plugin. More...
bool | IsInitialized [get]
If true, this Recorder has been initialized and is ready to transmit to remote clients. Otherwise call Init(VoiceConnection). More...
bool | RequiresInit [get]
bool | RequiresRestart [get, protected set]
Returns true if something has changed in the Recorder while recording that won't take effect unless recording is restarted using RestartRecording. More...
bool | TransmitEnabled [get, set]
If true, audio transmission is enabled. More...
bool | Encrypt [get, set]
If true, voice stream is sent encrypted. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. More...
bool | ReliableMode [get, set]
If true, stream data sent in reliable mode. More...
bool | VoiceDetection [get, set]
If true, voice detection enabled. More...
float | VoiceDetectionThreshold [get, set]
Voice detection threshold (0..1, where 1 is full amplitude). More...
int | VoiceDetectionDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. Default is 500ms More...
object | UserData [get, set]
Custom user object to be sent in the voice stream info event. More...
Func< IAudioDesc > | InputFactory [get, set]
Set the method returning new Voice.IAudioDesc instance to be assigned to a new voice created with Source set to Factory More...
AudioUtil.IVoiceDetector? | VoiceDetector [get]
Returns voice activity detector for recorder's audio stream. More...
string | UnityMicrophoneDevice [get, set]
Set or get Unity microphone device used for streaming. More...
int | PhotonMicrophoneDeviceId [get, set]
Set or get photon microphone device used for streaming. More...
byte | AudioGroup [get, set]
Target interest group that will receive transmitted audio. More...
byte | InterestGroup [get, set]
Target interest group that will receive transmitted audio. More...
bool | IsCurrentlyTransmitting [get]
Returns true if audio stream broadcasts. More...
AudioUtil.ILevelMeter? | LevelMeter [get]
Level meter utility. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...
ILocalVoiceAudio | voiceAudio [get]
InputSourceType | SourceType [get, set]
Audio data source. More...
MicType | MicrophoneType [get, set]
Which microphone API to use when the Source is set to Microphone. More...
SampleTypeConv | TypeConvert [get, set]
Force creation of 'short' pipeline and convert audio data to short for 'float' audio sources. More...
AudioClip | AudioClip [get, set]
Source audio clip. More...
bool | LoopAudioClip [get, set]
Loop playback for audio clip sources. More...
SamplingRate | SamplingRate [get, set]
Outgoing audio stream sampling rate. More...
OpusCodec.FrameDuration | FrameDuration [get, set]
Outgoing audio stream encoder delay. More...
int | Bitrate [get, set]
Outgoing audio stream bitrate. More...
bool | IsRecording [get, set]
Gets or sets whether this Recorder is actively recording audio to be transmitted. More...
bool | ReactOnSystemChanges [get, set]
If true, the Recorder will automatically restart recording to recover from audio device changes. More...
bool | AutoStart [get, set]
If true, automatically start recording when initialized. More...
bool | RecordOnlyWhenEnabled [get, set]
If true, component will work only when enabled and active in hierarchy. More...
bool | SkipDeviceChangeChecks [get, set]
If true, restarts recording without checking if audio config/device changes affected recording. More...
bool | StopRecordingWhenPaused [get, set]
If true, stop recording when paused resume/restart when un-paused. More...
bool | UseOnAudioFilterRead [get, set]
If true, recording will make use of Unity's OnAudioFitlerRead callback from a muted local AudioSource. More...
bool | TrySamplingRateMatch [get, set]
If true, Recorder will try to match sampling rates of microphone device and Opus encoder to avoid re sampling of audio input. More...
bool | UseMicrophoneTypeFallback [get, set]
If true, if recording fails to start with Unity microphone type, Photon microphone type is used -if available- as a fallback and vice versa. More...
bool | RecordOnlyWhenJoined [get, set]
If true, recording can start only when client is joined to a room. Auto start is also delayed until client is joined to a room. More...
IDeviceEnumerator | MicrophonesEnumerator [get]
DeviceInfo | MicrophoneDevice [get, set]
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
DebugLevel logLevel = DebugLevel.WARNING

Detailed Description

Component representing outgoing audio stream in scene.

Member Function Documentation

◆ Init()

void Init ( VoiceConnection connection )

Initializes the Recorder component to be able to transmit audio.

Parameters
connection The VoiceConnection to be used with this Recorder.

◆ ResetLocalAudio()

bool ResetLocalAudio ( )

Resets audio session and parameters locally to fix broken recording due to system configuration modifications or audio interruptions or audio routing changes.

Returns
If reset is done.

◆ RestartRecording()

void RestartRecording ( bool force = false )

Restarts recording if something has changed that requires this.

Parameters
force Set to true if you want to restart even if this is not required (RequiresRestart = false)

◆ StartRecording()

void StartRecording ( )

Starts recording.

◆ StopRecording()

void StopRecording ( )

Stops recording.

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | detectionEndedCallback = null
 | ) |  |

Trigger voice detector calibration process. While calibrating, keep silence. Voice detector sets threshold basing on measured background noise level.

Parameters
durationMs | Duration of calibration in milliseconds.
detectionEndedCallback | Callback when VAD calibration ends.

Property Documentation

◆ AudioClip

AudioClip AudioClip
getset

Source audio clip.

◆ AudioGroup

byte AudioGroup
getset

Target interest group that will receive transmitted audio.

If AudioGroup != 0, recorder's audio data is sent only to clients listening to this group.

◆ AutoStart

bool AutoStart
getset

If true, automatically start recording when initialized.

◆ Bitrate

int Bitrate
getset

Outgoing audio stream bitrate.

◆ DebugEchoMode

bool DebugEchoMode
getset

If true, outgoing stream routed back to client via server same way as for remote client's streams.

◆ Encrypt

bool Encrypt
getset

If true, voice stream is sent encrypted.

◆ FrameDuration

OpusCodec.FrameDuration FrameDuration
getset

Outgoing audio stream encoder delay.

◆ InputFactory

Func<IAudioDesc> InputFactory
getset

Set the method returning new Voice.IAudioDesc instance to be assigned to a new voice created with Source set to Factory

◆ InterestGroup

byte InterestGroup
getset

Target interest group that will receive transmitted audio.

If InterestGroup != 0, recorder's audio data is sent only to clients listening to this group.

◆ IsCurrentlyTransmitting

bool IsCurrentlyTransmitting
get

Returns true if audio stream broadcasts.

◆ IsInitialized

bool IsInitialized
get

If true, this Recorder has been initialized and is ready to transmit to remote clients. Otherwise call Init(VoiceConnection).

◆ IsRecording

bool IsRecording
getset

Gets or sets whether this Recorder is actively recording audio to be transmitted.

◆ LevelMeter

AudioUtil.ILevelMeter? LevelMeter
get

Level meter utility.

◆ LoopAudioClip

bool LoopAudioClip
getset

Loop playback for audio clip sources.

◆ MicrophoneType

MicType MicrophoneType
getset

Which microphone API to use when the Source is set to Microphone.

◆ PhotonMicrophoneDeviceId

int PhotonMicrophoneDeviceId
getset

Set or get photon microphone device used for streaming.

◆ PhotonMicrophoneEnumerator

IDeviceEnumerator PhotonMicrophoneEnumerator
staticget

Enumerator for the available microphone devices gathered by the Photon plugin.

◆ ReactOnSystemChanges

bool ReactOnSystemChanges
getset

If true, the Recorder will automatically restart recording to recover from audio device changes.

By default, the Recorder will restart recording only when the Recorder.SourceType is InputSourceType.Microphone and the device being used is no longer available or valid, in some cases you may need to force restarts even if the device in use did not change. To enable this set Recorder.SkipDeviceChangeChecks to true.

◆ RecordOnlyWhenEnabled

bool RecordOnlyWhenEnabled
getset

If true, component will work only when enabled and active in hierarchy.

◆ RecordOnlyWhenJoined

bool RecordOnlyWhenJoined
getset

If true, recording can start only when client is joined to a room. Auto start is also delayed until client is joined to a room.

◆ ReliableMode

bool ReliableMode
getset

If true, stream data sent in reliable mode.

◆ RequiresRestart

bool RequiresRestart
getprotected set

Returns true if something has changed in the Recorder while recording that won't take effect unless recording is restarted using RestartRecording.

Think of this as a "isDirty" flag.

◆ SamplingRate

SamplingRate SamplingRate
getset

Outgoing audio stream sampling rate.

◆ SkipDeviceChangeChecks

bool SkipDeviceChangeChecks
getset

If true, restarts recording without checking if audio config/device changes affected recording.

To be used when Recorder.ReactOnSystemChanges is true.

◆ SourceType

InputSourceType SourceType
getset

Audio data source.

◆ StopRecordingWhenPaused

bool StopRecordingWhenPaused
getset

If true, stop recording when paused resume/restart when un-paused.

◆ TransmitEnabled

bool TransmitEnabled
getset

If true, audio transmission is enabled.

◆ TrySamplingRateMatch

bool TrySamplingRateMatch
getset

If true, Recorder will try to match sampling rates of microphone device and Opus encoder to avoid re sampling of audio input.

◆ TypeConvert

SampleTypeConv TypeConvert
getset

Force creation of 'short' pipeline and convert audio data to short for 'float' audio sources.

◆ UnityMicrophoneDevice

string UnityMicrophoneDevice
getset

Set or get Unity microphone device used for streaming.

◆ UseMicrophoneTypeFallback

bool UseMicrophoneTypeFallback
getset

If true, if recording fails to start with Unity microphone type, Photon microphone type is used -if available- as a fallback and vice versa.

◆ UseOnAudioFilterRead

bool UseOnAudioFilterRead
getset

If true, recording will make use of Unity's OnAudioFitlerRead callback from a muted local AudioSource.

If enabled, 3D sounds and voice positioning can be lost.

◆ UserData

object UserData
getset

Custom user object to be sent in the voice stream info event.

◆ VoiceDetection

bool VoiceDetection
getset

If true, voice detection enabled.

◆ VoiceDetectionDelayMs

int VoiceDetectionDelayMs
getset

Keep detected state during this time after signal level dropped below threshold. Default is 500ms

◆ VoiceDetectionThreshold

float VoiceDetectionThreshold
getset

Voice detection threshold (0..1, where 1 is full amplitude).

◆ VoiceDetector

AudioUtil.IVoiceDetector? VoiceDetector
get

Returns voice activity detector for recorder's audio stream.

◆ VoiceDetectorCalibrating

bool VoiceDetectorCalibrating
get

If true, voice detector calibration is in progress.


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • Recorder
Recorder Member List

This is the complete list of members for Recorder, including all inherited members.

AudioClip | Recorder |
AudioGroup | Recorder |
AutoStart | Recorder |
Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
Bitrate | Recorder |
CompareUnityMicNames(string mic1, string mic2) (defined in Recorder) | Recorder | static
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
DebugEchoMode | Recorder |
Encrypt | Recorder |
FrameDuration | Recorder |
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
Init(VoiceConnection connection) | Recorder |
InputFactory | Recorder |
InputSourceType enum name (defined in Recorder) | Recorder |
InterestGroup | Recorder |
IsCurrentlyTransmitting | Recorder |
IsDefaultUnityMic(string mic) (defined in Recorder) | Recorder | static
IsInitialized | Recorder |
IsRecording | Recorder |
LevelMeter | Recorder |
Logger (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
LogLevel (defined in VoiceComponent) | VoiceComponent |
LoopAudioClip | Recorder |
MAX_OPUS_BITRATE (defined in Recorder) | Recorder | static
MicrophoneDevice (defined in Recorder) | Recorder |
MicrophonesEnumerator (defined in Recorder) | Recorder |
MicrophoneType | Recorder |
MicType enum name (defined in Recorder) | Recorder |
MIN_OPUS_BITRATE (defined in Recorder) | Recorder | static
PhotonMicrophoneDeviceId | Recorder |
PhotonMicrophoneEnumerator | Recorder | static
ReactOnSystemChanges | Recorder |
RecordOnlyWhenEnabled | Recorder |
RecordOnlyWhenJoined | Recorder |
ReInit() (defined in Recorder) | Recorder |
ReliableMode | Recorder |
RequiresInit (defined in Recorder) | Recorder |
RequiresRestart | Recorder |
ResetLocalAudio() | Recorder |
RestartRecording(bool force=false) | Recorder |
SampleTypeConv enum name (defined in Recorder) | Recorder |
SamplingRate | Recorder |
SendPhotonVoiceCreatedMessage() (defined in Recorder) | Recorder | protectedvirtual
SkipDeviceChangeChecks | Recorder |
SourceType | Recorder |
StartRecording() | Recorder |
StopRecording() | Recorder |
StopRecordingWhenPaused | Recorder |
TransmitEnabled | Recorder |
TrySamplingRateMatch | Recorder |
TypeConvert | Recorder |
UnityMicrophoneDevice | Recorder |
UseMicrophoneTypeFallback | Recorder |
UseOnAudioFilterRead | Recorder |
UserData | Recorder |
voiceAudio (defined in Recorder) | Recorder | protected
VoiceDetection | Recorder |
VoiceDetectionDelayMs | Recorder |
VoiceDetectionThreshold | Recorder |
VoiceDetector | Recorder |
VoiceDetectorCalibrate(int durationMs, Action< float > detectionEndedCallback=null) | Recorder |
VoiceDetectorCalibrating | Recorder |


Photon Voice: Recorder.PhotonVoiceCreatedParams Class Reference

Photon Voice v2.30

  • Unity
  • Recorder
  • PhotonVoiceCreatedParams
List of all members
Recorder.PhotonVoiceCreatedParams Class Reference

Inherits PhotonVoiceCreatedParams.

Additional Inherited Members

- Properties inherited from PhotonVoiceCreatedParams
Voice.LocalVoice | Voice [get, set]
Voice.IAudioDesc | AudioDesc [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • Recorder
  • PhotonVoiceCreatedParams
Recorder.PhotonVoiceCreatedParams Member List

This is the complete list of members for Recorder.PhotonVoiceCreatedParams, including all inherited members.

AudioDesc (defined in PhotonVoiceCreatedParams) | PhotonVoiceCreatedParams
Voice (defined in PhotonVoiceCreatedParams) | PhotonVoiceCreatedParams


Photon Voice: RemoteVoiceLink Class Reference

Photon Voice v2.30

  • Unity
  • RemoteVoiceLink
Public Member Functions | Public Attributes | Events | List of all members
RemoteVoiceLink Class Reference

Inherits IEquatable< RemoteVoiceLink >.

Public Member Functions

RemoteVoiceLink (VoiceInfo info, int playerId, int voiceId, int channelId)
void | Init (ref RemoteVoiceOptions options)
override string | ToString ()
bool | Equals (RemoteVoiceLink other)

Public Attributes

readonly VoiceInfo | Info
readonly int | PlayerId
readonly int | VoiceId
readonly int | ChannelId

Events

Action< FrameOut< float > > | FloatFrameDecoded
Action | RemoteVoiceRemoved


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • RemoteVoiceLink
RemoteVoiceLink Member List

This is the complete list of members for RemoteVoiceLink, including all inherited members.

ChannelId (defined in RemoteVoiceLink) | RemoteVoiceLink
Equals(RemoteVoiceLink other) (defined in RemoteVoiceLink) | RemoteVoiceLink
FloatFrameDecoded (defined in RemoteVoiceLink) | RemoteVoiceLink
Info (defined in RemoteVoiceLink) | RemoteVoiceLink
Init(ref RemoteVoiceOptions options) (defined in RemoteVoiceLink) | RemoteVoiceLink
PlayerId (defined in RemoteVoiceLink) | RemoteVoiceLink
RemoteVoiceLink(VoiceInfo info, int playerId, int voiceId, int channelId) (defined in RemoteVoiceLink) | RemoteVoiceLink
RemoteVoiceRemoved (defined in RemoteVoiceLink) | RemoteVoiceLink
ToString() (defined in RemoteVoiceLink) | RemoteVoiceLink
VoiceId (defined in RemoteVoiceLink) | RemoteVoiceLink


Photon Voice: Speaker Class Reference

Photon Voice v2.30

  • Unity
  • Speaker
Public Member Functions | Public Attributes | Properties | List of all members
Speaker Class Reference

Component representing remote audio stream in local scene. More...

Inherits VoiceComponent.

Public Member Functions

bool | StartPlayback ()
Starts the audio playback of the linked incoming remote audio stream via AudioSource component. More...
bool | StopPlayback ()
Stops the audio playback of the linked incoming remote audio stream via AudioSource component. More...
bool | RestartPlayback (bool reinit=false)
Restarts the audio playback of the linked incoming remote audio stream via AudioSource component. More...
bool | SetPlaybackDelaySettings (PlaybackDelaySettings pdc)
Sets the settings for the playback behaviour in case of delays. More...
bool | SetPlaybackDelaySettings (int low, int high, int max)
Sets the settings for the playback behaviour in case of delays. More...

Public Attributes

Func< IAudioOut< float > > CustomAudioOutFactory
A custom factory method to return IAudioOut<float> implementation used for the playback. More...

Properties

int | PlayDelayMs [get, set]
bool | IsPlaying [get]
Is the speaker playing right now. More...
int? | Lag [get]
Smoothed difference between (jittering) stream and (clock-driven) audioOutput. More...
Action< Speaker > | OnRemoteVoiceRemoveAction [get, set]
Register a method to be called when remote voice removed. More...
Realtime.Player | Actor [get, set]
Per room, the connected users/players are represented with a Realtime.Player, also known as Actor. More...
bool | IsLinked [get]
Whether or not this Speaker has been linked to a remote voice stream. More...
bool | PlaybackOnlyWhenEnabled [get, set]
If true, component will work only when enabled and active in hierarchy. More...
bool | PlaybackStarted [get]
Returns if the playback is on. More...
int | PlaybackDelayMinSoft [get]
Gets the value in ms above which the audio player tries to keep the delay. More...
int | PlaybackDelayMaxSoft [get]
Gets the value in ms below which the audio player tries to keep the delay. More...
int | PlaybackDelayMaxHard [get]
Gets the value in ms that audio play delay will not exceed. More...
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Additional Inherited Members

- Protected Member Functions inherited from VoiceComponent
virtual void | Awake ()
- Protected Attributes inherited from VoiceComponent
DebugLevel | logLevel = DebugLevel.WARNING

Detailed Description

Component representing remote audio stream in local scene.

Member Function Documentation

◆ RestartPlayback()

bool RestartPlayback ( bool reinit = false )

Restarts the audio playback of the linked incoming remote audio stream via AudioSource component.

Parameters
reinit If true, player will be reinitialized.
Returns
True if playback is successfully restarted.

◆ SetPlaybackDelaySettings() [1/2]

bool SetPlaybackDelaySettings | ( | int | low,
 |  | int | high,
 |  | int | max
 | ) |  |

Sets the settings for the playback behaviour in case of delays.

Parameters
low | In milliseconds, audio player tries to keep the playback delay above this value.
high | In milliseconds, audio player tries to keep the playback below above this value.
max | In milliseconds, audio player guarantees that the playback delay never exceeds this value.
Returns
If a change has been made.

◆ SetPlaybackDelaySettings() [2/2]

bool SetPlaybackDelaySettings ( PlaybackDelaySettings pdc )

Sets the settings for the playback behaviour in case of delays.

Parameters
pdc Playback delay configuration struct.
Returns
If a change has been made.

◆ StartPlayback()

bool StartPlayback ( )

Starts the audio playback of the linked incoming remote audio stream via AudioSource component.

Returns
True if playback is successfully started.

◆ StopPlayback()

bool StopPlayback ( )

Stops the audio playback of the linked incoming remote audio stream via AudioSource component.

Returns
True if playback is successfully stopped.

Member Data Documentation

◆ CustomAudioOutFactory

Func<IAudioOut<float> > CustomAudioOutFactory

A custom factory method to return IAudioOut<float> implementation used for the playback.

Property Documentation

◆ Actor

Realtime.Player Actor
getset

Per room, the connected users/players are represented with a Realtime.Player, also known as Actor.

Photon Voice calls this Actor, to avoid a name-clash with the Player class in Voice.

◆ IsLinked

bool IsLinked
get

Whether or not this Speaker has been linked to a remote voice stream.

◆ IsPlaying

bool IsPlaying
get

Is the speaker playing right now.

◆ Lag

int? Lag
get

Smoothed difference between (jittering) stream and (clock-driven) audioOutput.

◆ OnRemoteVoiceRemoveAction

Action<Speaker> OnRemoteVoiceRemoveAction
getset

Register a method to be called when remote voice removed.

◆ PlaybackDelayMaxHard

int PlaybackDelayMaxHard
get

Gets the value in ms that audio play delay will not exceed.

◆ PlaybackDelayMaxSoft

int PlaybackDelayMaxSoft
get

Gets the value in ms below which the audio player tries to keep the delay.

◆ PlaybackDelayMinSoft

int PlaybackDelayMinSoft
get

Gets the value in ms above which the audio player tries to keep the delay.

◆ PlaybackOnlyWhenEnabled

bool PlaybackOnlyWhenEnabled
getset

If true, component will work only when enabled and active in hierarchy.

◆ PlaybackStarted

bool PlaybackStarted
get

Returns if the playback is on.


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • Speaker
Speaker Member List

This is the complete list of members for Speaker, including all inherited members.

Actor | Speaker |
Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
CustomAudioOutFactory | Speaker |
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
IsLinked | Speaker |
IsPlaying | Speaker |
Lag | Speaker |
Logger (defined in VoiceComponent) | VoiceComponent |
LogLevel (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
OnRemoteVoiceRemoveAction | Speaker |
PlaybackDelayMaxHard | Speaker |
PlaybackDelayMaxSoft | Speaker |
PlaybackDelayMinSoft | Speaker |
PlaybackOnlyWhenEnabled | Speaker |
PlaybackStarted | Speaker |
PlayDelayMs (defined in Speaker) | Speaker |
RestartPlayback(bool reinit=false) | Speaker |
SetPlaybackDelaySettings(PlaybackDelaySettings pdc) | Speaker |
SetPlaybackDelaySettings(int low, int high, int max) | Speaker |
StartPlayback() | Speaker |
StopPlayback() | Speaker |


Photon Voice: UnityAudioOut Class Reference

Photon Voice v2.30

  • Unity
  • UnityAudioOut
Public Member Functions | Protected Attributes | Properties | List of all members
UnityAudioOut Class Reference

Inherits AudioOutDelayControl< float >.

Public Member Functions

UnityAudioOut (AudioSource audioSource, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo)
override void | OutCreate (int frequency, int channels, int bufferSamples)
override void | OutStart ()
override void | OutWrite (float[] data, int offsetSamples)
override void | Stop ()

Protected Attributes

readonly AudioSource | source
AudioClip | clip

Properties

override int OutPos [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UnityAudioOut
UnityAudioOut Member List

This is the complete list of members for UnityAudioOut, including all inherited members.

clip (defined in UnityAudioOut) | UnityAudioOut | protected
OutCreate(int frequency, int channels, int bufferSamples) (defined in UnityAudioOut) | UnityAudioOut |
OutPos (defined in UnityAudioOut) | UnityAudioOut |
OutStart() (defined in UnityAudioOut) | UnityAudioOut |
OutWrite(float[] data, int offsetSamples) (defined in UnityAudioOut) | UnityAudioOut |
source (defined in UnityAudioOut) | UnityAudioOut | protected
Stop() (defined in UnityAudioOut) | UnityAudioOut |
UnityAudioOut(AudioSource audioSource, PlayDelayConfig playDelayConfig, ILogger logger, string logPrefix, bool debugInfo) (defined in UnityAudioOut) | UnityAudioOut |


Photon Voice: UnityMicrophone Class Reference

Photon Voice v2.30

  • Unity
  • UnityMicrophone
Static Public Member Functions | Properties | List of all members
UnityMicrophone Class Reference

A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL. More...

Static Public Member Functions

static void | End (string deviceName)
static void | GetDeviceCaps (string deviceName, out int minFreq, out int maxFreq)
static int | GetPosition (string deviceName)
static bool | IsRecording (string deviceName)
static AudioClip | Start (string deviceName, bool loop, int lengthSec, int frequency)

Properties

static string[] devices [get]

Detailed Description

A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL.


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • UnityMicrophone
UnityMicrophone Member List

This is the complete list of members for UnityMicrophone, including all inherited members.

devices (defined in UnityMicrophone) | UnityMicrophone | static
End(string deviceName) (defined in UnityMicrophone) | UnityMicrophone | static
GetDeviceCaps(string deviceName, out int minFreq, out int maxFreq) (defined in UnityMicrophone) | UnityMicrophone | static
GetPosition(string deviceName) (defined in UnityMicrophone) | UnityMicrophone | static
IsRecording(string deviceName) (defined in UnityMicrophone) | UnityMicrophone | static
Start(string deviceName, bool loop, int lengthSec, int frequency) (defined in UnityMicrophone) | UnityMicrophone | static


Photon Voice: VoiceComponent Class Reference

Photon Voice v2.30

  • Unity
  • VoiceComponent
Protected Member Functions | Protected Attributes | Properties | List of all members
VoiceComponent Class Reference

Inherits MonoBehaviour, and ILoggableDependent.

Inherited by PhotonVoiceView, AudioChangesHandler, Recorder, Speaker, MicAmplifier, MicrophonePermission, SaveIncomingStreamToFile, SaveOutgoingStreamToFile, and WebRtcAudioDsp.

Protected Member Functions

virtual void Awake ()

Protected Attributes

DebugLevel logLevel = DebugLevel.WARNING

Properties

VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • VoiceComponent
VoiceComponent Member List

This is the complete list of members for VoiceComponent, including all inherited members.

Awake() (defined in VoiceComponent) | VoiceComponent | protectedvirtual
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
Logger (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
LogLevel (defined in VoiceComponent) | VoiceComponent |


Photon Voice: VoiceConnection Class Reference

Photon Voice v2.30

  • Unity
  • VoiceConnection
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Properties | Events | List of all members
VoiceConnection Class Reference

Component that represents a client voice connection to Photon Servers. More...

Inherits ConnectionHandler, and ILoggable.

Inherited by PhotonVoiceNetwork.

Public Member Functions

bool | ConnectUsingSettings (AppSettings overwriteSettings=null)
Connect to Photon server using Settings More...
void | InitRecorder (Recorder rec)
Initializes the Recorder component to be able to transmit audio. More...
void | SetPlaybackDelaySettings (PlaybackDelaySettings gpds)
Sets the global configuration for the playback behaviour in case of delays. More...
void | SetGlobalPlaybackDelaySettings (int low, int high, int max)
Sets the global configuration for the playback behaviour in case of delays. More...
virtual bool | TryLateLinkingUsingUserData (Speaker speaker, object userData)
Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started. More...

Public Attributes

AppSettings | Settings
Settings to be used by this voice connection More...
Func< int, byte, object, Speaker > | SpeakerFactory
Special factory to link Speaker components with incoming remote audio streams More...
float | MinimalTimeScaleToDispatchInFixedUpdate = -1f
Configures the minimal Time.timeScale at which Voice client will dispatch incoming messages within LateUpdate. More...
bool | AutoCreateSpeakerIfNotFound = true
Auto instantiate a GameObject and attach a Speaker component to link to a remote audio stream if no candidate could be found More...
int | MaxDatagrams = 3
Limits the number of datagrams that are created in each LateUpdate. More...
bool | SendAsap
Signals that outgoing messages should be sent in the next LateUpdate call. More...

Protected Member Functions

override void | Awake ()
virtual void | Update ()
virtual void | FixedUpdate ()
void | Dispatch ()
Dispatches incoming network messages for Voice client. Called in FixedUpdate or LateUpdate. More...
override void | OnDisable ()
virtual void | OnDestroy ()
virtual Speaker | SimpleSpeakerFactory (int playerId, byte voiceId, object userData)
virtual void | OnVoiceStateChanged (ClientState fromState, ClientState toState)
void | CalcStatistics ()
void | LinkSpeaker (Speaker speaker, RemoteVoiceLink remoteVoice)
virtual void | OnOperationResponseReceived (OperationResponse operationResponse)

Protected Attributes

List< RemoteVoiceLink > cachedRemoteVoices = new List<RemoteVoiceLink>()

Properties

VoiceLogger | Logger [get, protected set]
Logger used by this component More...
DebugLevel | LogLevel [get, set]
Log level for this component More...
new LoadBalancingTransport | Client [get]
VoiceClient | VoiceClient [get]
Returns underlying Photon Voice client. More...
ClientState | ClientState [get]
Returns Photon Voice client state. More...
float | FramesReceivedPerSecond [get]
Number of frames received per second. More...
float | FramesLostPerSecond [get]
Number of frames lost per second. More...
float | FramesLostPercent [get]
Percentage of lost frames. More...
GameObject | SpeakerPrefab [get, set]
Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info More...
Recorder | PrimaryRecorder [get, set]
Main Recorder to be used for transmission by default More...
DebugLevel | GlobalRecordersLogLevel [get, set]
DebugLevel | GlobalSpeakersLogLevel [get, set]
int | GlobalPlaybackDelay [get, set]
string | BestRegionSummaryInPreferences [get, set]
Used to store and access the "Best Region Summary" in the Player Preferences. More...
int | GlobalPlaybackDelayMinSoft [get]
Gets the global value in ms above which the audio player tries to keep the delay. More...
int | GlobalPlaybackDelayMaxSoft [get]
Gets the global value in ms below which the audio player tries to keep the delay. More...
int | GlobalPlaybackDelayMaxHard [get]
Gets the global value in ms that audio play delay will not exceed. More...
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Events

Action< Speaker > | SpeakerLinked
Fires when a speaker has been linked to a remote audio stream More...
Action< RemoteVoiceLink > | RemoteVoiceAdded
Fires when a remote voice stream is added More...

Detailed Description

Component that represents a client voice connection to Photon Servers.

Member Function Documentation

◆ ConnectUsingSettings()

bool ConnectUsingSettings ( AppSettings overwriteSettings = null )

Connect to Photon server using Settings

Parameters
overwriteSettings Overwrites Settings before connecting
Returns
If true voice connection command was sent from client

◆ Dispatch()

void Dispatch ( )
protected

Dispatches incoming network messages for Voice client. Called in FixedUpdate or LateUpdate.

It may make sense to dispatch incoming messages, even if the timeScale is near 0. That can be configured with MinimalTimeScaleToDispatchInFixedUpdate.

Without dispatching messages, Voice client won't change state and does not handle updates.

◆ InitRecorder()

void InitRecorder ( Recorder rec )

Initializes the Recorder component to be able to transmit audio.

Parameters
rec The Recorder to be initialized.

◆ SetGlobalPlaybackDelaySettings()

void SetGlobalPlaybackDelaySettings | ( | int | low,
 |  | int | high,
 |  | int | max
 | ) |  |

Sets the global configuration for the playback behaviour in case of delays.

Parameters
low | In milliseconds, audio player tries to keep the playback delay above this value.
high | In milliseconds, audio player tries to keep the playback below above this value.
max | In milliseconds, audio player guarantees that the playback delay never exceeds this value.

◆ SetPlaybackDelaySettings()

void SetPlaybackDelaySettings ( PlaybackDelaySettings gpds )

Sets the global configuration for the playback behaviour in case of delays.

Parameters
gpds Playback delay configuration struct.

◆ TryLateLinkingUsingUserData()

virtual bool TryLateLinkingUsingUserData | ( | Speaker | speaker,
 |  | object | userData
 | ) |  |
virtual

Tries to link local Speaker with remote voice stream using UserData. Useful if Speaker created after stream is started.

Parameters
speaker | Speaker ot try linking.
userData | UserData object used to bind local Speaker with remote voice stream.
Returns

Member Data Documentation

◆ AutoCreateSpeakerIfNotFound

bool AutoCreateSpeakerIfNotFound = true

Auto instantiate a GameObject and attach a Speaker component to link to a remote audio stream if no candidate could be found

◆ MaxDatagrams

int MaxDatagrams = 3

Limits the number of datagrams that are created in each LateUpdate.

Helps spreading out sending of messages minimally.

◆ MinimalTimeScaleToDispatchInFixedUpdate

float MinimalTimeScaleToDispatchInFixedUpdate = -1f

Configures the minimal Time.timeScale at which Voice client will dispatch incoming messages within LateUpdate.

It may make sense to dispatch incoming messages, even if the timeScale is near 0. In some cases, stopping the game time makes sense, so this option defaults to -1f, which is "off". Without dispatching messages, Voice client won't change state and does not handle updates.

◆ SendAsap

bool SendAsap

Signals that outgoing messages should be sent in the next LateUpdate call.

Up to MaxDatagrams are created to send queued messages.

◆ Settings

AppSettings Settings

Settings to be used by this voice connection

◆ SpeakerFactory

Func<int, byte, object, Speaker> SpeakerFactory

Special factory to link Speaker components with incoming remote audio streams

Property Documentation

◆ BestRegionSummaryInPreferences

string BestRegionSummaryInPreferences
getset

Used to store and access the "Best Region Summary" in the Player Preferences.

◆ ClientState

ClientState ClientState
get

Returns Photon Voice client state.

◆ FramesLostPercent

float FramesLostPercent
get

Percentage of lost frames.

◆ FramesLostPerSecond

float FramesLostPerSecond
get

Number of frames lost per second.

◆ FramesReceivedPerSecond

float FramesReceivedPerSecond
get

Number of frames received per second.

◆ GlobalPlaybackDelayMaxHard

int GlobalPlaybackDelayMaxHard
get

Gets the global value in ms that audio play delay will not exceed.

◆ GlobalPlaybackDelayMaxSoft

int GlobalPlaybackDelayMaxSoft
get

Gets the global value in ms below which the audio player tries to keep the delay.

◆ GlobalPlaybackDelayMinSoft

int GlobalPlaybackDelayMinSoft
get

Gets the global value in ms above which the audio player tries to keep the delay.

◆ Logger

VoiceLogger Logger
getprotected set

Logger used by this component

◆ LogLevel

DebugLevel LogLevel
getset

Log level for this component

◆ PrimaryRecorder

Recorder PrimaryRecorder
getset

Main Recorder to be used for transmission by default

◆ SpeakerPrefab

GameObject SpeakerPrefab
getset

Prefab that contains Speaker component to be instantiated when receiving a new remote audio source info

◆ VoiceClient

VoiceClient VoiceClient
get

Returns underlying Photon Voice client.

Event Documentation

◆ RemoteVoiceAdded

Action<RemoteVoiceLink> RemoteVoiceAdded

Fires when a remote voice stream is added

◆ SpeakerLinked

Action<Speaker> SpeakerLinked

Fires when a speaker has been linked to a remote audio stream


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • VoiceConnection
VoiceConnection Member List

This is the complete list of members for VoiceConnection, including all inherited members.

AutoCreateSpeakerIfNotFound | VoiceConnection |
Awake() (defined in VoiceConnection) | VoiceConnection | protected
BestRegionSummaryInPreferences | VoiceConnection |
cachedRemoteVoices (defined in VoiceConnection) | VoiceConnection | protected
CalcStatistics() (defined in VoiceConnection) | VoiceConnection | protected
Client (defined in VoiceConnection) | VoiceConnection |
ClientState | VoiceConnection |
ConnectUsingSettings(AppSettings overwriteSettings=null) | VoiceConnection |
Dispatch() | VoiceConnection | protected
FixedUpdate() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
FramesLostPercent | VoiceConnection |
FramesLostPerSecond | VoiceConnection |
FramesReceivedPerSecond | VoiceConnection |
GlobalPlaybackDelay (defined in VoiceConnection) | VoiceConnection |
GlobalPlaybackDelayMaxHard | VoiceConnection |
GlobalPlaybackDelayMaxSoft | VoiceConnection |
GlobalPlaybackDelayMinSoft | VoiceConnection |
GlobalRecordersLogLevel (defined in VoiceConnection) | VoiceConnection |
GlobalSpeakersLogLevel (defined in VoiceConnection) | VoiceConnection |
InitRecorder(Recorder rec) | VoiceConnection |
LinkSpeaker(Speaker speaker, RemoteVoiceLink remoteVoice) (defined in VoiceConnection) | VoiceConnection | protected
Logger | VoiceConnection |
LogLevel | VoiceConnection |
MaxDatagrams | VoiceConnection |
MinimalTimeScaleToDispatchInFixedUpdate | VoiceConnection |
OnDestroy() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
OnDisable() (defined in VoiceConnection) | VoiceConnection | protected
OnOperationResponseReceived(OperationResponse operationResponse) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
OnVoiceStateChanged(ClientState fromState, ClientState toState) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
PrimaryRecorder | VoiceConnection |
RemoteVoiceAdded | VoiceConnection |
SendAsap | VoiceConnection |
SetGlobalPlaybackDelaySettings(int low, int high, int max) | VoiceConnection |
SetPlaybackDelaySettings(PlaybackDelaySettings gpds) | VoiceConnection |
Settings | VoiceConnection |
SimpleSpeakerFactory(int playerId, byte voiceId, object userData) (defined in VoiceConnection) | VoiceConnection | protectedvirtual
SpeakerFactory | VoiceConnection |
SpeakerLinked | VoiceConnection |
SpeakerPrefab | VoiceConnection |
TryLateLinkingUsingUserData(Speaker speaker, object userData) | VoiceConnection | virtual
Update() (defined in VoiceConnection) | VoiceConnection | protectedvirtual
VoiceClient | VoiceConnection |


Photon Voice: VoiceLogger Class Reference

Photon Voice v2.30

  • Unity
  • VoiceLogger
Public Member Functions | Properties | List of all members
VoiceLogger Class Reference

Inherits ILogger.

Public Member Functions

VoiceLogger (Object context, string tag, DebugLevel level=DebugLevel.ERROR)
VoiceLogger (string tag, DebugLevel level=DebugLevel.ERROR)
void | LogError (string fmt, params object[] args)
void | LogWarning (string fmt, params object[] args)
void | LogInfo (string fmt, params object[] args)
void | LogDebug (string fmt, params object[] args)

Properties

string | Tag [get, set]
DebugLevel | LogLevel [get, set]
bool | IsErrorEnabled [get]
bool | IsWarningEnabled [get]
bool | IsInfoEnabled [get]
bool | IsDebugEnabled [get]


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • VoiceLogger
VoiceLogger Member List

This is the complete list of members for VoiceLogger, including all inherited members.

IsDebugEnabled (defined in VoiceLogger) | VoiceLogger
IsErrorEnabled (defined in VoiceLogger) | VoiceLogger
IsInfoEnabled (defined in VoiceLogger) | VoiceLogger
IsWarningEnabled (defined in VoiceLogger) | VoiceLogger
LogDebug(string fmt, params object[] args) (defined in VoiceLogger) | VoiceLogger
LogError(string fmt, params object[] args) (defined in VoiceLogger) | VoiceLogger
LogInfo(string fmt, params object[] args) (defined in VoiceLogger) | VoiceLogger
LogLevel (defined in VoiceLogger) | VoiceLogger
LogWarning(string fmt, params object[] args) (defined in VoiceLogger) | VoiceLogger
Tag (defined in VoiceLogger) | VoiceLogger
VoiceLogger(Object context, string tag, DebugLevel level=DebugLevel.ERROR) (defined in VoiceLogger) | VoiceLogger
VoiceLogger(string tag, DebugLevel level=DebugLevel.ERROR) (defined in VoiceLogger) | VoiceLogger


Photon Voice: WebRtcAudioDsp Class Reference

Photon Voice v2.30

  • Unity
  • WebRtcAudioDsp
Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
WebRtcAudioDsp Class Reference

Inherits VoiceComponent.

Public Member Functions

bool | SetOrSwitchAudioListener (AudioListener listener)
Set the AudioListener to be used with this WebRtcAudioDsp. Needed for Acoustic Echo Cancellation. More...
bool | SetOrSwitchAudioOutCapture (AudioOutCapture capture)
Set the AudioOutCapture to be used with this WebRtcAudioDsp. Needed for Acoustic Echo Cancellation. More...

Public Attributes

bool | AutoRestartOnAudioChannelsMismatch = true
bool | AECMobileComfortNoise

Protected Member Functions

override void Awake ()

Properties

bool | AEC [get, set]
bool | AECMobile [get, set]
bool | AecHighPass [get, set]
int | ReverseStreamDelayMs [get, set]
bool | NoiseSuppression [get, set]
bool | HighPass [get, set]
bool | Bypass [get, set]
bool | AGC [get, set]
int | AgcCompressionGain [get, set]
bool | VAD [get, set]
bool | IsInitialized [get]
bool | AecOnlyWhenEnabled [get, set]
- Properties inherited from VoiceComponent
VoiceLogger | Logger [get, protected set]
DebugLevel | LogLevel [get, set]
bool | IgnoreGlobalLogLevel [get, set]
static string | CurrentPlatform [get]
- Properties inherited from ILoggableDependent
bool | IgnoreGlobalLogLevel [get, set]
- Properties inherited from ILoggable
DebugLevel | LogLevel [get, set]
VoiceLogger | Logger [get]

Additional Inherited Members

- Protected Attributes inherited from VoiceComponent
DebugLevel logLevel = DebugLevel.WARNING

Member Function Documentation

◆ SetOrSwitchAudioListener()

bool SetOrSwitchAudioListener ( AudioListener listener )

Set the AudioListener to be used with this WebRtcAudioDsp. Needed for Acoustic Echo Cancellation.

Parameters
listener The audioListener to be used
Returns
Success or failure

◆ SetOrSwitchAudioOutCapture()

bool SetOrSwitchAudioOutCapture ( AudioOutCapture capture )

Set the AudioOutCapture to be used with this WebRtcAudioDsp. Needed for Acoustic Echo Cancellation.

Parameters
capture The audioOutCapture to be used
Returns
Success or failure


Photon Voice: Member List

Photon Voice v2.30

  • Unity
  • WebRtcAudioDsp
WebRtcAudioDsp Member List

This is the complete list of members for WebRtcAudioDsp, including all inherited members.

AEC (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AecHighPass (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AECMobile (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AECMobileComfortNoise (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AecOnlyWhenEnabled (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AGC (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AgcCompressionGain (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
AutoRestartOnAudioChannelsMismatch (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
Awake() (defined in WebRtcAudioDsp) | WebRtcAudioDsp | protectedvirtual
Bypass (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
CurrentPlatform (defined in VoiceComponent) | VoiceComponent | static
HighPass (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
IgnoreGlobalLogLevel (defined in VoiceComponent) | VoiceComponent |
IsInitialized (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
Logger (defined in VoiceComponent) | VoiceComponent |
logLevel (defined in VoiceComponent) | VoiceComponent | protected
LogLevel (defined in VoiceComponent) | VoiceComponent |
NoiseSuppression (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
ReverseStreamDelayMs (defined in WebRtcAudioDsp) | WebRtcAudioDsp |
SetOrSwitchAudioListener(AudioListener listener) | WebRtcAudioDsp |
SetOrSwitchAudioOutCapture(AudioOutCapture capture) | WebRtcAudioDsp |
VAD (defined in WebRtcAudioDsp) | WebRtcAudioDsp |


Photon Voice: AudioDesc Class Reference

Photon Voice v2.30

  • AudioDesc
Public Member Functions | Properties | List of all members
AudioDesc Class Reference

Inherits IAudioDesc.

Public Member Functions

AudioDesc (int samplingRate, int channels, string error)
void Dispose ()

Properties

int | SamplingRate [get]
int | Channels [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...


Photon Voice: Member List

Photon Voice v2.30

  • AudioDesc
AudioDesc Member List

This is the complete list of members for AudioDesc, including all inherited members.

AudioDesc(int samplingRate, int channels, string error) (defined in AudioDesc) | AudioDesc
Channels (defined in AudioDesc) | AudioDesc
Dispose() (defined in AudioDesc) | AudioDesc
Error (defined in AudioDesc) | AudioDesc
SamplingRate (defined in AudioDesc) | AudioDesc


Photon Voice: AudioInChangeNotifierNotSupported Class Reference

Photon Voice v2.30

  • AudioInChangeNotifierNotSupported
Public Member Functions | Public Attributes | Properties | List of all members
AudioInChangeNotifierNotSupported Class Reference

Inherits IAudioInChangeNotifier.

Public Member Functions

AudioInChangeNotifierNotSupported (Action callback, ILogger logger)
void Dispose ()

Public Attributes

bool IsSupported => false

Properties

string | Error [get]
- Properties inherited from IAudioInChangeNotifier
bool | IsSupported [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • AudioInChangeNotifierNotSupported
AudioInChangeNotifierNotSupported Member List

This is the complete list of members for AudioInChangeNotifierNotSupported, including all inherited members.

AudioInChangeNotifierNotSupported(Action callback, ILogger logger) (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported
Dispose() (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported
Error (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported
IsSupported (defined in AudioInChangeNotifierNotSupported) | AudioInChangeNotifierNotSupported


Photon Voice: AudioOutDelayControl Class Reference

Photon Voice v2.30

  • AudioOutDelayControl
Classes
AudioOutDelayControl Class Reference

Inherited by AudioOutDelayControl< T >.

Classes

class PlayDelayConfig


Photon Voice: AudioOutDelayControl.PlayDelayConfig Class Reference

Photon Voice v2.30

  • AudioOutDelayControl
  • PlayDelayConfig
Public Member Functions | Properties | List of all members
AudioOutDelayControl.PlayDelayConfig Class Reference

Public Member Functions

PlayDelayConfig Clone ()

Properties

int | Low [get, set]
int | High [get, set]
int | Max [get, set]
int | SpeedUpPerc [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • AudioOutDelayControl
  • PlayDelayConfig
AudioOutDelayControl.PlayDelayConfig Member List

This is the complete list of members for AudioOutDelayControl.PlayDelayConfig, including all inherited members.

Clone() (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig
High (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig
Low (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig
Max (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig
PlayDelayConfig() (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig
SpeedUpPerc (defined in AudioOutDelayControl.PlayDelayConfig) | AudioOutDelayControl.PlayDelayConfig


Photon Voice: AudioSyncBuffer< T > Class Template Reference

Photon Voice v2.30

  • AudioSyncBuffer
Public Member Functions | Static Public Attributes | Properties | List of all members
AudioSyncBuffer< T > Class Template Reference

Inherits IAudioOut< T >.

Public Member Functions

AudioSyncBuffer (int playDelayMs, ILogger logger, string logPrefix, bool debugInfo)
void | Start (int sampleRate, int channels, int frameSamples)
void | Service ()
void | Read (T[] outBuf, int outChannels, int outSampleRate)
void | Push (T[] frame)
void | Flush ()
void | Stop ()

Static Public Attributes

const int FRAME_POOL_CAPACITY = 50

Properties

int | Lag [get]
bool | IsPlaying [get]
- Properties inherited from IAudioOut< T >
bool | IsPlaying [get]
int | Lag [get]


Photon Voice: Member List

Photon Voice v2.30

  • AudioSyncBuffer
AudioSyncBuffer< T > Member List

This is the complete list of members for AudioSyncBuffer< T >, including all inherited members.

AudioSyncBuffer(int playDelayMs, ILogger logger, string logPrefix, bool debugInfo) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
Flush() (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
FRAME_POOL_CAPACITY (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > | static
IsPlaying (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
Lag (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
Push(T[] frame) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
Read(T[] outBuf, int outChannels, int outSampleRate) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
Service() (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
Start(int sampleRate, int channels, int frameSamples) (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |
Stop() (defined in AudioSyncBuffer< T >) | AudioSyncBuffer< T > |


Photon Voice: AudioUtil Class Reference

Photon Voice v2.30

  • AudioUtil
Classes | Static Public Member Functions | List of all members
AudioUtil Class Reference

Collection of Audio Utility functions and classes. More...

Classes

interface | ILevelMeter
Audio Level Metering interface. More...
interface | IVoiceDetector
Voice Activity Detector interface. More...
class | LevelMeter
Audio Level Meter. More...
class | LevelMeterDummy
Dummy Audio Level Meter that doesn't actually do anything. More...
class | LevelMeterFloat
LevelMeter specialization for float audio. More...
class | LevelMeterShort
LevelMeter specialization for short audio. More...
class | Resampler
Sample-rate conversion Audio Processor. More...
class | TempoUp
class | ToneAudioPusher
IAudioPusher that provides a constant tone signal. More...
class | ToneAudioReader
IAudioReader that provides a constant tone signal. More...
class | VoiceDetector
Simple voice activity detector triggered by signal level. More...
class | VoiceDetectorCalibration
Calibration Utility for Voice Detector More...
class | VoiceDetectorDummy
Dummy VoiceDetector that doesn't actually do anything. More...
class | VoiceDetectorFloat
VoiceDetector specialization for float audio. More...
class | VoiceDetectorShort
VoiceDetector specialization for float audio. More...
class | VoiceLevelDetectCalibrate
Utility Audio Processor Voice Detection Calibration. More...

Static Public Member Functions

static void | Resample< T > (T[] src, T[] dst, int dstCount, int channels)
Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer. More...
static void | Resample< T > (T[] src, int srcOffset, int srcCount, T[] dst, int dstOffset, int dstCount, int channels)
static void | Resample< T > (T[] src, int srcOffset, int srcCount, int srcChannels, T[] dst, int dstOffset, int dstCount, int dstChannels)
static void | ResampleAndConvert (short[] src, float[] dst, int dstCount, int channels)
Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert short to float samples along the way. More...
static void | ResampleAndConvert (float[] src, short[] dst, int dstCount, int channels)
Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert float to short samples along the way. More...
static void | Convert (float[] src, short[] dst, int dstCount)
Convert audio buffer from float to short samples. More...
static void | Convert (short[] src, float[] dst, int dstCount)
Convert audio buffer from short to float samples. More...
static void | ForceToStereo< T > (T[] src, T[] dst, int srcChannels)
Convert audio buffer with arbitrary number of channels to stereo. More...

Detailed Description

Collection of Audio Utility functions and classes.

Member Function Documentation

◆ Convert() [1/2]

static void Convert | ( | float[] | src,
 |  | short[] | dst,
 |  | int | dstCount
 | ) |  |
static

Convert audio buffer from float to short samples.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Size of destination buffer (in total samples), source buffer must be of same length or longer.

◆ Convert() [2/2]

static void Convert | ( | short[] | src,
 |  | float[] | dst,
 |  | int | dstCount
 | ) |  |
static

Convert audio buffer from short to float samples.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Size of destination buffer (in total samples), source buffer must be of same length or longer.

◆ ForceToStereo< T >()

static void ForceToStereo< T > | ( | T[] | src,
 |  | T[] | dst,
 |  | int | srcChannels
 | ) |  |
static

Convert audio buffer with arbitrary number of channels to stereo.

For mono sources (srcChannels==1), the signal will be copied to both Left and Right stereo channels. For all others, the first two available channels will be used, any other channels will be discarded.

Parameters
src | Source buffer.
dst | Destination buffer.
srcChannels | Number of (interleaved) channels in src.

◆ Resample< T >()

static void Resample< T > | ( | T[] | src,
 |  | T[] | dst,
 |  | int | dstCount,
 |  | int | channels
 | ) |  |
static

Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer.

This implements a primitive nearest-neighbor resampling algorithm for an arbitrary number of channels.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Target size of destination buffer (in samples per channel).
channels | Number of channels in the signal (1=mono, 2=stereo). Must be > 0.

◆ ResampleAndConvert() [1/2]

static void ResampleAndConvert | ( | float[] | src,
 |  | short[] | dst,
 |  | int | dstCount,
 |  | int | channels
 | ) |  |
static

Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert float to short samples along the way.

This implements a primitive nearest-neighbor resampling algorithm for an arbitrary number of channels.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Target size of destination buffer (in samples per channel).
channels | Number of channels in the signal (1=mono, 2=stereo). Must be > 0.

◆ ResampleAndConvert() [2/2]

static void ResampleAndConvert | ( | short[] | src,
 |  | float[] | dst,
 |  | int | dstCount,
 |  | int | channels
 | ) |  |
static

Resample audio data so that the complete src buffer fits into dstCount samples in the dst buffer, and convert short to float samples along the way.

This implements a primitive nearest-neighbor resampling algorithm for an arbitrary number of channels.

Parameters
src | Source buffer.
dst | Destination buffer.
dstCount | Target size of destination buffer (in samples per channel).
channels | Number of channels in the signal (1=mono, 2=stereo). Must be > 0.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
AudioUtil Member List

This is the complete list of members for AudioUtil, including all inherited members.

Convert(float[] src, short[] dst, int dstCount) | AudioUtil | static
Convert(short[] src, float[] dst, int dstCount) | AudioUtil | static
ForceToStereo< T >(T[] src, T[] dst, int srcChannels) | AudioUtil | static
Resample< T >(T[] src, T[] dst, int dstCount, int channels) | AudioUtil | static
Resample< T >(T[] src, int srcOffset, int srcCount, T[] dst, int dstOffset, int dstCount, int channels) (defined in AudioUtil) | AudioUtil | static
Resample< T >(T[] src, int srcOffset, int srcCount, int srcChannels, T[] dst, int dstOffset, int dstCount, int dstChannels) (defined in AudioUtil) | AudioUtil | static
ResampleAndConvert(short[] src, float[] dst, int dstCount, int channels) | AudioUtil | static
ResampleAndConvert(float[] src, short[] dst, int dstCount, int channels) | AudioUtil | static


Photon Voice: AudioUtil.ILevelMeter Interface Reference

Photon Voice v2.30

  • AudioUtil
  • ILevelMeter
Public Member Functions | Properties | List of all members
AudioUtil.ILevelMeter Interface Reference

Audio Level Metering interface. More...

Inherited by AudioUtil.LevelMeter< T >, and AudioUtil.LevelMeterDummy.

Public Member Functions

void ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...

Properties

float | CurrentAvgAmp [get]
Average amplitude value over last half second. More...
float | CurrentPeakAmp [get]
Maximum amplitude value over last half second sec. More...
float | AccumAvgPeakAmp [get]
Average of CurrentPeakAmps since last reset. More...

Detailed Description

Audio Level Metering interface.

Member Function Documentation

◆ ResetAccumAvgPeakAmp()

void ResetAccumAvgPeakAmp ( )

Reset AccumAvgPeakAmp.

Implemented in AudioUtil.LevelMeter< T >, and AudioUtil.LevelMeterDummy.

Property Documentation

◆ AccumAvgPeakAmp

float AccumAvgPeakAmp
get

Average of CurrentPeakAmps since last reset.

◆ CurrentAvgAmp

float CurrentAvgAmp
get

Average amplitude value over last half second.

◆ CurrentPeakAmp

float CurrentPeakAmp
get

Maximum amplitude value over last half second sec.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • ILevelMeter
AudioUtil.ILevelMeter Member List

This is the complete list of members for AudioUtil.ILevelMeter, including all inherited members.

AccumAvgPeakAmp | AudioUtil.ILevelMeter
CurrentAvgAmp | AudioUtil.ILevelMeter
CurrentPeakAmp | AudioUtil.ILevelMeter
ResetAccumAvgPeakAmp() | AudioUtil.ILevelMeter


Photon Voice: AudioUtil.IVoiceDetector Interface Reference

Photon Voice v2.30

  • AudioUtil
  • IVoiceDetector
Properties | Events | List of all members
AudioUtil.IVoiceDetector Interface Reference

Voice Activity Detector interface. More...

Inherited by AudioUtil.VoiceDetector< T >, and AudioUtil.VoiceDetectorDummy.

Properties

bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...

Events

Action OnDetected
Called when switched to detected state. More...

Detailed Description

Voice Activity Detector interface.

Property Documentation

◆ ActivityDelayMs

int ActivityDelayMs
getset

Keep detected state during this time after signal level dropped below threshold.

◆ Detected

bool Detected
get

If true, voice detected.

◆ DetectedTime

DateTime DetectedTime
get

Last time when switched to detected state.

◆ On

bool On
getset

If true, voice detection enabled.

◆ Threshold

float Threshold
getset

Voice detected as soon as signal level exceeds threshold.

Event Documentation

◆ OnDetected

Action OnDetected

Called when switched to detected state.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • IVoiceDetector
AudioUtil.IVoiceDetector Member List

This is the complete list of members for AudioUtil.IVoiceDetector, including all inherited members.

ActivityDelayMs | AudioUtil.IVoiceDetector
Detected | AudioUtil.IVoiceDetector
DetectedTime | AudioUtil.IVoiceDetector
On | AudioUtil.IVoiceDetector
OnDetected | AudioUtil.IVoiceDetector
Threshold | AudioUtil.IVoiceDetector


Photon Voice: AudioUtil.LevelMeter< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • LevelMeter
Public Member Functions | Protected Attributes | Properties | List of all members
AudioUtil.LevelMeter< T > Class Template Referenceabstract

Audio Level Meter. More...

Inherits IProcessor< T >, and AudioUtil.ILevelMeter.

Public Member Functions

void | ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...
abstract T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Protected Attributes

float | ampSum
float | ampPeak
int | bufferSize
float[] | prevValues
int | prevValuesHead
float | accumAvgPeakAmpSum
int | accumAvgPeakAmpCount
float | currentPeakAmp
float | norm

Properties

float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get, protected set]
float? | AccumAvgPeakAmp [get]
- Properties inherited from AudioUtil.ILevelMeter
float | CurrentAvgAmp [get]
Average amplitude value over last half second. More...
float | CurrentPeakAmp [get]
Maximum amplitude value over last half second sec. More...
float | AccumAvgPeakAmp [get]
Average of CurrentPeakAmps since last reset. More...

Detailed Description

Audio Level Meter.

Member Function Documentation

◆ Process()

abstract T [] Process ( T[] buf )
pure virtual

Process a frame of audio data.

Parameters
buf Buffer containing input audio data
Returns
Buffer containing output audio data or null if frame has been discarded (VAD)

Implements IProcessor< T >.

◆ ResetAccumAvgPeakAmp()

void ResetAccumAvgPeakAmp ( )

Reset AccumAvgPeakAmp.

Implements AudioUtil.ILevelMeter.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • LevelMeter
AudioUtil.LevelMeter< T > Member List

This is the complete list of members for AudioUtil.LevelMeter< T >, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
accumAvgPeakAmpCount (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
accumAvgPeakAmpSum (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
ampPeak (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
ampSum (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
bufferSize (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
CurrentAvgAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
currentPeakAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
CurrentPeakAmp (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
Dispose() (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > |
norm (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
prevValues (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
prevValuesHead (defined in AudioUtil.LevelMeter< T >) | AudioUtil.LevelMeter< T > | protected
Process(T[] buf) | AudioUtil.LevelMeter< T > | pure virtual
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeter< T > |


Photon Voice: AudioUtil.LevelMeterDummy Class Reference

Photon Voice v2.30

  • AudioUtil
  • LevelMeterDummy
Public Member Functions | Properties | List of all members
AudioUtil.LevelMeterDummy Class Reference

Dummy Audio Level Meter that doesn't actually do anything. More...

Inherits AudioUtil.ILevelMeter.

Public Member Functions

void ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...

Properties

float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get]
float | AccumAvgPeakAmp [get]
- Properties inherited from AudioUtil.ILevelMeter
float | CurrentAvgAmp [get]
Average amplitude value over last half second. More...
float | CurrentPeakAmp [get]
Maximum amplitude value over last half second sec. More...
float | AccumAvgPeakAmp [get]
Average of CurrentPeakAmps since last reset. More...

Detailed Description

Dummy Audio Level Meter that doesn't actually do anything.

Member Function Documentation

◆ ResetAccumAvgPeakAmp()

void ResetAccumAvgPeakAmp ( )

Reset AccumAvgPeakAmp.

Implements AudioUtil.ILevelMeter.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • LevelMeterDummy
AudioUtil.LevelMeterDummy Member List

This is the complete list of members for AudioUtil.LevelMeterDummy, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeterDummy) | AudioUtil.LevelMeterDummy
CurrentAvgAmp (defined in AudioUtil.LevelMeterDummy) | AudioUtil.LevelMeterDummy
CurrentPeakAmp (defined in AudioUtil.LevelMeterDummy) | AudioUtil.LevelMeterDummy
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeterDummy


Photon Voice: AudioUtil.LevelMeterFloat Class Reference

Photon Voice v2.30

  • AudioUtil
  • LevelMeterFloat
Public Member Functions | List of all members
AudioUtil.LevelMeterFloat Class Reference

LevelMeter specialization for float audio. More...

Inherits AudioUtil.LevelMeter< float >.

Public Member Functions

LevelMeterFloat (int samplingRate, int numChannels)
Create new LevelMeterFloat instance. More...
override float[] | Process (float[] buf)
- Public Member Functions inherited from AudioUtil.LevelMeter< float >
void | ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...
abstract T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.LevelMeter< float >
float | ampSum
float | ampPeak
int | bufferSize
float[] | prevValues
int | prevValuesHead
float | accumAvgPeakAmpSum
int | accumAvgPeakAmpCount
float | currentPeakAmp
float | norm
- Properties inherited from AudioUtil.LevelMeter< float >
float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get, protected set]
float? | AccumAvgPeakAmp [get]

Detailed Description

LevelMeter specialization for float audio.

Constructor & Destructor Documentation

◆ LevelMeterFloat()

LevelMeterFloat | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create new LevelMeterFloat instance.

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • LevelMeterFloat
AudioUtil.LevelMeterFloat Member List

This is the complete list of members for AudioUtil.LevelMeterFloat, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
accumAvgPeakAmpCount (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
accumAvgPeakAmpSum (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
ampPeak (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
ampSum (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
bufferSize (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
CurrentAvgAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
currentPeakAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
CurrentPeakAmp (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
Dispose() (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > |
LevelMeterFloat(int samplingRate, int numChannels) | AudioUtil.LevelMeterFloat |
norm (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
prevValues (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
prevValuesHead (defined in AudioUtil.LevelMeter< float >) | AudioUtil.LevelMeter< float > | protected
Process(float[] buf) (defined in AudioUtil.LevelMeterFloat) | AudioUtil.LevelMeterFloat |
LevelMeter< float >.Process(T[] buf) | AudioUtil.LevelMeter< float > | pure virtual
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeter< float > |


Photon Voice: AudioUtil.LevelMeterShort Class Reference

Photon Voice v2.30

  • AudioUtil
  • LevelMeterShort
Public Member Functions | List of all members
AudioUtil.LevelMeterShort Class Reference

LevelMeter specialization for short audio. More...

Inherits AudioUtil.LevelMeter< short >.

Public Member Functions

LevelMeterShort (int samplingRate, int numChannels)
Create new LevelMeterShort instance. More...
override short[] | Process (short[] buf)
- Public Member Functions inherited from AudioUtil.LevelMeter< short >
void | ResetAccumAvgPeakAmp ()
Reset AccumAvgPeakAmp. More...
abstract T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.LevelMeter< short >
float | ampSum
float | ampPeak
int | bufferSize
float[] | prevValues
int | prevValuesHead
float | accumAvgPeakAmpSum
int | accumAvgPeakAmpCount
float | currentPeakAmp
float | norm
- Properties inherited from AudioUtil.LevelMeter< short >
float | CurrentAvgAmp [get]
float | CurrentPeakAmp [get, protected set]
float? | AccumAvgPeakAmp [get]

Detailed Description

LevelMeter specialization for short audio.

Constructor & Destructor Documentation

◆ LevelMeterShort()

LevelMeterShort | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create new LevelMeterShort instance.

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • LevelMeterShort
AudioUtil.LevelMeterShort Member List

This is the complete list of members for AudioUtil.LevelMeterShort, including all inherited members.

AccumAvgPeakAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
accumAvgPeakAmpCount (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
accumAvgPeakAmpSum (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
ampPeak (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
ampSum (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
bufferSize (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
CurrentAvgAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
currentPeakAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
CurrentPeakAmp (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
Dispose() (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > |
LevelMeterShort(int samplingRate, int numChannels) | AudioUtil.LevelMeterShort |
norm (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
prevValues (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
prevValuesHead (defined in AudioUtil.LevelMeter< short >) | AudioUtil.LevelMeter< short > | protected
Process(short[] buf) (defined in AudioUtil.LevelMeterShort) | AudioUtil.LevelMeterShort |
LevelMeter< short >.Process(T[] buf) | AudioUtil.LevelMeter< short > | pure virtual
ResetAccumAvgPeakAmp() | AudioUtil.LevelMeter< short > |


Photon Voice: AudioUtil.Resampler< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • Resampler
Public Member Functions | Protected Attributes | List of all members
AudioUtil.Resampler< T > Class Template Reference

Sample-rate conversion Audio Processor. More...

Inherits IProcessor< T >.

Public Member Functions

Resampler (int dstSize, int channels)
Create a new Resampler instance. More...
T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Protected Attributes

T[] frameResampled

Detailed Description

Sample-rate conversion Audio Processor.

This processor converts the sample-rate of the source stream. Internally, it uses AudioUtil.Resample<T>(T[], T[], int, int).

Constructor & Destructor Documentation

◆ Resampler()

Resampler | ( | int | dstSize,
 |  | int | channels
 | ) |  |

Create a new Resampler instance.

Parameters
dstSize | Frame size of a destination frame. Determins output rate.
channels | Number of audio channels expected in both in- and output.

Member Function Documentation

◆ Process()

T [] Process ( T[] buf )

Process a frame of audio data.

Parameters
buf Buffer containing input audio data
Returns
Buffer containing output audio data or null if frame has been discarded (VAD)

Implements IProcessor< T >.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • Resampler
AudioUtil.Resampler< T > Member List

This is the complete list of members for AudioUtil.Resampler< T >, including all inherited members.

Dispose() (defined in AudioUtil.Resampler< T >) | AudioUtil.Resampler< T > |
frameResampled (defined in AudioUtil.Resampler< T >) | AudioUtil.Resampler< T > | protected
Process(T[] buf) | AudioUtil.Resampler< T > |
Resampler(int dstSize, int channels) | AudioUtil.Resampler< T > |


Photon Voice: AudioUtil.TempoUp< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • TempoUp
Public Member Functions | List of all members
AudioUtil.TempoUp< T > Class Template Reference

Public Member Functions

void | Begin (int channels, int changePerc, int skipGroup)
int | Process (T[] s, T[] d)
int | End (T[] s)
int | endFloat (float[] s)
int | endShort (short[] s)


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • TempoUp
AudioUtil.TempoUp< T > Member List

This is the complete list of members for AudioUtil.TempoUp< T >, including all inherited members.

Begin(int channels, int changePerc, int skipGroup) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
End(T[] s) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
endFloat(float[] s) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
endShort(short[] s) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >
Process(T[] s, T[] d) (defined in AudioUtil.TempoUp< T >) | AudioUtil.TempoUp< T >


Photon Voice: AudioUtil.ToneAudioPusher< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • ToneAudioPusher
Public Member Functions | Properties | List of all members
AudioUtil.ToneAudioPusher< T > Class Template Reference

IAudioPusher that provides a constant tone signal. More...

Inherits IAudioPusher< T >.

Public Member Functions

ToneAudioPusher (int frequency=440, int bufSizeMs=100, int samplingRate=48000, int channels=2)
Create a new ToneAudioReader instance More...
void | SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data More...
void | Dispose ()

Properties

int | Channels [get]
int | SamplingRate [get]
string | Error [get]
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

IAudioPusher that provides a constant tone signal.

Constructor & Destructor Documentation

◆ ToneAudioPusher()

ToneAudioPusher | ( | int | frequency = 440,
 |  | int | bufSizeMs = 100,
 |  | int | samplingRate = 48000,
 |  | int | channels = 2
 | ) |  |

Create a new ToneAudioReader instance

Parameters
frequency | Frequency of the generated tone (in Hz).
bufSizeMs | Size of buffers to push (in milliseconds).
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.

Member Function Documentation

◆ SetCallback()

void SetCallback | ( | Action< T[]> | callback,
 |  | ObjectFactory< T[], int > | bufferFactory
 | ) |  |

Set the callback function used for pushing data

Parameters
callback | Callback function to use
bufferFactory | Buffer factory used to create the buffer that is pushed to the callback

Implements IAudioPusher< T >.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • ToneAudioPusher
AudioUtil.ToneAudioPusher< T > Member List

This is the complete list of members for AudioUtil.ToneAudioPusher< T >, including all inherited members.

Channels (defined in AudioUtil.ToneAudioPusher< T >) | AudioUtil.ToneAudioPusher< T >
Dispose() (defined in AudioUtil.ToneAudioPusher< T >) | AudioUtil.ToneAudioPusher< T >
Error (defined in AudioUtil.ToneAudioPusher< T >) | AudioUtil.ToneAudioPusher< T >
SamplingRate (defined in AudioUtil.ToneAudioPusher< T >) | AudioUtil.ToneAudioPusher< T >
SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | AudioUtil.ToneAudioPusher< T >
ToneAudioPusher(int frequency=440, int bufSizeMs=100, int samplingRate=48000, int channels=2) | AudioUtil.ToneAudioPusher< T >


Photon Voice: AudioUtil.ToneAudioReader< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • ToneAudioReader
Public Member Functions | Properties | List of all members
AudioUtil.ToneAudioReader< T > Class Template Reference

IAudioReader that provides a constant tone signal. More...

Inherits IAudioReader< T >.

Public Member Functions

ToneAudioReader (Func< double > clockSec=null, double frequency=440, int samplingRate=48000, int channels=2)
Create a new ToneAudioReader instance More...
void | Dispose ()
bool | Read (T[] buf)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...

Properties

int | Channels [get]
Number of channels in the audio signal. More...
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
string | Error [get]
If not null, audio object is in invalid state. More...
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

IAudioReader that provides a constant tone signal.

Because of current resampling algorithm, the tone is distorted if SamplingRate does not equal encoder sampling rate.

Constructor & Destructor Documentation

◆ ToneAudioReader()

ToneAudioReader | ( | Func< double > | clockSec = null,
 |  | double | frequency = 440,
 |  | int | samplingRate = 48000,
 |  | int | channels = 2
 | ) |  |

Create a new ToneAudioReader instance

Parameters
clockSec | Function to get current time in seconds. In Unity, pass in '() => AudioSettings.dspTime' for better results.
frequency | Frequency of the generated tone (in Hz).
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.

Member Function Documentation

◆ Read()

bool Read ( T[] buffer )

Fill full given frame buffer with source uncompressed data or return false if not enough such data.

Parameters
buffer Buffer to fill.
Returns
True if buffer was filled successfully, false otherwise.

Implements IDataReader< T >.

Property Documentation

◆ Channels

int Channels
get

Number of channels in the audio signal.

◆ Error

string Error
get

If not null, audio object is in invalid state.

◆ SamplingRate

int SamplingRate
get

Sampling rate of the audio signal (in Hz).


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • ToneAudioReader
AudioUtil.ToneAudioReader< T > Member List

This is the complete list of members for AudioUtil.ToneAudioReader< T >, including all inherited members.

Channels | AudioUtil.ToneAudioReader< T >
Dispose() (defined in AudioUtil.ToneAudioReader< T >) | AudioUtil.ToneAudioReader< T >
Error | AudioUtil.ToneAudioReader< T >
Read(T[] buf) | AudioUtil.ToneAudioReader< T >
SamplingRate | AudioUtil.ToneAudioReader< T >
ToneAudioReader(Func< double > clockSec=null, double frequency=440, int samplingRate=48000, int channels=2) | AudioUtil.ToneAudioReader< T >


Photon Voice: AudioUtil.VoiceDetector< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • VoiceDetector
Public Member Functions | Protected Attributes | Properties | Events | List of all members
AudioUtil.VoiceDetector< T > Class Template Referenceabstract

Simple voice activity detector triggered by signal level. More...

Inherits IProcessor< T >, and AudioUtil.IVoiceDetector.

Public Member Functions

abstract T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Protected Attributes

float | norm
float | threshold
int | activityDelay
int | autoSilenceCounter = 0
int | valuesCountPerSec
int | activityDelayValuesCount

Properties

bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get, protected set]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...
- Properties inherited from AudioUtil.IVoiceDetector
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...

Events

Action | OnDetected
Called when switched to detected state. More...
- Events inherited from AudioUtil.IVoiceDetector
Action | OnDetected
Called when switched to detected state. More...

Detailed Description

Simple voice activity detector triggered by signal level.

Member Function Documentation

◆ Process()

abstract T [] Process ( T[] buf )
pure virtual

Process a frame of audio data.

Parameters
buf Buffer containing input audio data
Returns
Buffer containing output audio data or null if frame has been discarded (VAD)

Implements IProcessor< T >.

Property Documentation

◆ ActivityDelayMs

int ActivityDelayMs
getset

Keep detected state during this time after signal level dropped below threshold.

◆ Detected

bool Detected
getprotected set

If true, voice detected.

◆ DetectedTime

DateTime DetectedTime
get

Last time when switched to detected state.

◆ On

bool On
getset

If true, voice detection enabled.

◆ Threshold

float Threshold
getset

Voice detected as soon as signal level exceeds threshold.

Event Documentation

◆ OnDetected

Action OnDetected

Called when switched to detected state.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • VoiceDetector
AudioUtil.VoiceDetector< T > Member List

This is the complete list of members for AudioUtil.VoiceDetector< T >, including all inherited members.

activityDelay (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
ActivityDelayMs | AudioUtil.VoiceDetector< T > |
activityDelayValuesCount (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
autoSilenceCounter (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
Detected | AudioUtil.VoiceDetector< T > |
DetectedTime | AudioUtil.VoiceDetector< T > |
Dispose() (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > |
norm (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
On | AudioUtil.VoiceDetector< T > |
OnDetected | AudioUtil.VoiceDetector< T > |
Process(T[] buf) | AudioUtil.VoiceDetector< T > | pure virtual
Threshold | AudioUtil.VoiceDetector< T > |
threshold (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected
valuesCountPerSec (defined in AudioUtil.VoiceDetector< T >) | AudioUtil.VoiceDetector< T > | protected


Photon Voice: AudioUtil.VoiceDetectorCalibration< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorCalibration
Public Member Functions | Protected Attributes | Properties | List of all members
AudioUtil.VoiceDetectorCalibration< T > Class Template Reference

Calibration Utility for Voice Detector More...

Inherits IProcessor< T >.

Public Member Functions

VoiceDetectorCalibration (IVoiceDetector voiceDetector, ILevelMeter levelMeter, int samplingRate, int channels)
Create new VoiceDetectorCalibration instance. More...
void | Calibrate (int durationMs, Action< float > onCalibrated=null)
Start calibration. More...
T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Protected Attributes

int calibrateCount

Properties

bool IsCalibrating [get]

Detailed Description

Calibration Utility for Voice Detector

. Using this audio processor, you can calibrate the IVoiceDetector.Threshold.

Constructor & Destructor Documentation

◆ VoiceDetectorCalibration()

VoiceDetectorCalibration | ( | IVoiceDetector | voiceDetector,
 |  | ILevelMeter | levelMeter,
 |  | int | samplingRate,
 |  | int | channels
 | ) |  |

Create new VoiceDetectorCalibration instance.

Parameters
voiceDetector | Voice Detector to calibrate.
levelMeter | Level Meter to look at for calibration.
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.

Member Function Documentation

◆ Calibrate()

void Calibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Start calibration.

Parameters
durationMs | Duration of the calibration procedure (in milliseconds).
onCalibrated | Optional callback that is called after calibration is complete.

This activates the Calibration process. It will reset the given LevelMeter's AccumAvgPeakAmp (accumulated average peak amplitude), and when the duration has passed, use it for the VoiceDetector's detection threshold.

◆ Process()

T [] Process ( T[] buf )

Process a frame of audio data.

Parameters
buf Buffer containing input audio data
Returns
Buffer containing output audio data or null if frame has been discarded (VAD)

Implements IProcessor< T >.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorCalibration
AudioUtil.VoiceDetectorCalibration< T > Member List

This is the complete list of members for AudioUtil.VoiceDetectorCalibration< T >, including all inherited members.

Calibrate(int durationMs, Action< float > onCalibrated=null) | AudioUtil.VoiceDetectorCalibration< T > |
calibrateCount (defined in AudioUtil.VoiceDetectorCalibration< T >) | AudioUtil.VoiceDetectorCalibration< T > | protected
Dispose() (defined in AudioUtil.VoiceDetectorCalibration< T >) | AudioUtil.VoiceDetectorCalibration< T > |
IsCalibrating (defined in AudioUtil.VoiceDetectorCalibration< T >) | AudioUtil.VoiceDetectorCalibration< T > |
Process(T[] buf) | AudioUtil.VoiceDetectorCalibration< T > |
VoiceDetectorCalibration(IVoiceDetector voiceDetector, ILevelMeter levelMeter, int samplingRate, int channels) | AudioUtil.VoiceDetectorCalibration< T > |


Photon Voice: AudioUtil.VoiceDetectorDummy Class Reference

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorDummy
Properties | List of all members
AudioUtil.VoiceDetectorDummy Class Reference

Dummy VoiceDetector that doesn't actually do anything. More...

Inherits AudioUtil.IVoiceDetector.

Properties

bool | On [get, set]
float | Threshold [get, set]
bool | Detected [get]
int | ActivityDelayMs [get, set]
DateTime | DetectedTime [get]
Action | OnDetected
- Properties inherited from AudioUtil.IVoiceDetector
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...

Additional Inherited Members

- Events inherited from AudioUtil.IVoiceDetector
Action OnDetected
Called when switched to detected state. More...

Detailed Description

Dummy VoiceDetector that doesn't actually do anything.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorDummy
AudioUtil.VoiceDetectorDummy Member List

This is the complete list of members for AudioUtil.VoiceDetectorDummy, including all inherited members.

ActivityDelayMs (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
Detected (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
DetectedTime (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
On (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
OnDetected (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy
Threshold (defined in AudioUtil.VoiceDetectorDummy) | AudioUtil.VoiceDetectorDummy


Photon Voice: AudioUtil.VoiceDetectorFloat Class Reference

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorFloat
Public Member Functions | List of all members
AudioUtil.VoiceDetectorFloat Class Reference

VoiceDetector specialization for float audio. More...

Inherits AudioUtil.VoiceDetector< float >.

Public Member Functions

VoiceDetectorFloat (int samplingRate, int numChannels)
Create a new VoiceDetectorFloat instance. More...
override float[] | Process (float[] buffer)
- Public Member Functions inherited from AudioUtil.VoiceDetector< float >
abstract T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.VoiceDetector< float >
float | norm
float | threshold
int | activityDelay
int | autoSilenceCounter
int | valuesCountPerSec
int | activityDelayValuesCount
- Properties inherited from AudioUtil.VoiceDetector< float >
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get, protected set]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...
- Events inherited from AudioUtil.VoiceDetector< float >
Action | OnDetected
Called when switched to detected state. More...

Detailed Description

VoiceDetector specialization for float audio.

Constructor & Destructor Documentation

◆ VoiceDetectorFloat()

VoiceDetectorFloat | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create a new VoiceDetectorFloat instance.

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorFloat
AudioUtil.VoiceDetectorFloat Member List

This is the complete list of members for AudioUtil.VoiceDetectorFloat, including all inherited members.

activityDelay (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
ActivityDelayMs | AudioUtil.VoiceDetector< float > |
activityDelayValuesCount (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
autoSilenceCounter (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
Detected | AudioUtil.VoiceDetector< float > |
DetectedTime | AudioUtil.VoiceDetector< float > |
Dispose() (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > |
norm (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
On | AudioUtil.VoiceDetector< float > |
OnDetected | AudioUtil.VoiceDetector< float > |
Process(float[] buffer) (defined in AudioUtil.VoiceDetectorFloat) | AudioUtil.VoiceDetectorFloat |
VoiceDetector< float >.Process(T[] buf) | AudioUtil.VoiceDetector< float > | pure virtual
threshold (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
Threshold | AudioUtil.VoiceDetector< float > |
valuesCountPerSec (defined in AudioUtil.VoiceDetector< float >) | AudioUtil.VoiceDetector< float > | protected
VoiceDetectorFloat(int samplingRate, int numChannels) | AudioUtil.VoiceDetectorFloat |


Photon Voice: AudioUtil.VoiceDetectorShort Class Reference

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorShort
Public Member Functions | List of all members
AudioUtil.VoiceDetectorShort Class Reference

VoiceDetector specialization for float audio. More...

Inherits AudioUtil.VoiceDetector< short >.

Public Member Functions

VoiceDetectorShort (int samplingRate, int numChannels)
Create a new VoiceDetectorFloat instance More...
override short[] | Process (short[] buffer)
- Public Member Functions inherited from AudioUtil.VoiceDetector< short >
abstract T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Additional Inherited Members

- Protected Attributes inherited from AudioUtil.VoiceDetector< short >
float | norm
float | threshold
int | activityDelay
int | autoSilenceCounter
int | valuesCountPerSec
int | activityDelayValuesCount
- Properties inherited from AudioUtil.VoiceDetector< short >
bool | On [get, set]
If true, voice detection enabled. More...
float | Threshold [get, set]
Voice detected as soon as signal level exceeds threshold. More...
bool | Detected [get, protected set]
If true, voice detected. More...
DateTime | DetectedTime [get]
Last time when switched to detected state. More...
int | ActivityDelayMs [get, set]
Keep detected state during this time after signal level dropped below threshold. More...
- Events inherited from AudioUtil.VoiceDetector< short >
Action | OnDetected
Called when switched to detected state. More...

Detailed Description

VoiceDetector specialization for float audio.

Constructor & Destructor Documentation

◆ VoiceDetectorShort()

VoiceDetectorShort | ( | int | samplingRate,
 |  | int | numChannels
 | ) |  |

Create a new VoiceDetectorFloat instance

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
numChannels | Number of channels in the audio signal.


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • VoiceDetectorShort
AudioUtil.VoiceDetectorShort Member List

This is the complete list of members for AudioUtil.VoiceDetectorShort, including all inherited members.

activityDelay (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
ActivityDelayMs | AudioUtil.VoiceDetector< short > |
activityDelayValuesCount (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
autoSilenceCounter (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
Detected | AudioUtil.VoiceDetector< short > |
DetectedTime | AudioUtil.VoiceDetector< short > |
Dispose() (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > |
norm (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
On | AudioUtil.VoiceDetector< short > |
OnDetected | AudioUtil.VoiceDetector< short > |
Process(short[] buffer) (defined in AudioUtil.VoiceDetectorShort) | AudioUtil.VoiceDetectorShort |
VoiceDetector< short >.Process(T[] buf) | AudioUtil.VoiceDetector< short > | pure virtual
threshold (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
Threshold | AudioUtil.VoiceDetector< short > |
valuesCountPerSec (defined in AudioUtil.VoiceDetector< short >) | AudioUtil.VoiceDetector< short > | protected
VoiceDetectorShort(int samplingRate, int numChannels) | AudioUtil.VoiceDetectorShort |


Photon Voice: AudioUtil.VoiceLevelDetectCalibrate< T > Class Template Reference

Photon Voice v2.30

  • AudioUtil
  • VoiceLevelDetectCalibrate
Public Member Functions | Properties | List of all members
AudioUtil.VoiceLevelDetectCalibrate< T > Class Template Reference

Utility Audio Processor Voice Detection Calibration. More...

Inherits IProcessor< T >.

Public Member Functions

VoiceLevelDetectCalibrate (int samplingRate, int channels)
Create new VoiceLevelDetectCalibrate instance More...
void | Calibrate (int durationMs, Action< float > onCalibrated=null)
Start calibration More...
T[] | Process (T[] buf)
Process a frame of audio data. More...
void | Dispose ()

Properties

ILevelMeter | LevelMeter [get]
The LevelMeter in use. More...
IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use More...
bool | IsCalibrating [get]

Detailed Description

Utility Audio Processor Voice Detection Calibration.

Encapsulates level meter, voice detector and voice detector calibrator in single instance.

Constructor & Destructor Documentation

◆ VoiceLevelDetectCalibrate()

VoiceLevelDetectCalibrate | ( | int | samplingRate,
 |  | int | channels
 | ) |  |

Create new VoiceLevelDetectCalibrate instance

Parameters
samplingRate | Sampling rate of the audio signal (in Hz).
channels | Number of channels in the audio signal.

Member Function Documentation

◆ Calibrate()

void Calibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Start calibration

Parameters
durationMs | Duration of the calibration procedure (in milliseconds).
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

This activates the Calibration process. It will reset the given LevelMeter's AccumAvgPeakAmp (accumulated average peak amplitude), and when the duration has passed, use it for the VoiceDetector's detection threshold.

◆ Process()

T [] Process ( T[] buf )

Process a frame of audio data.

Parameters
buf Buffer containing input audio data
Returns
Buffer containing output audio data or null if frame has been discarded (VAD)

Implements IProcessor< T >.

Property Documentation

◆ LevelMeter

ILevelMeter LevelMeter
get

The LevelMeter in use.

◆ VoiceDetector

IVoiceDetector VoiceDetector
get

The VoiceDetector in use


Photon Voice: Member List

Photon Voice v2.30

  • AudioUtil
  • VoiceLevelDetectCalibrate
AudioUtil.VoiceLevelDetectCalibrate< T > Member List

This is the complete list of members for AudioUtil.VoiceLevelDetectCalibrate< T >, including all inherited members.

Calibrate(int durationMs, Action< float > onCalibrated=null) | AudioUtil.VoiceLevelDetectCalibrate< T >
Dispose() (defined in AudioUtil.VoiceLevelDetectCalibrate< T >) | AudioUtil.VoiceLevelDetectCalibrate< T >
IsCalibrating (defined in AudioUtil.VoiceLevelDetectCalibrate< T >) | AudioUtil.VoiceLevelDetectCalibrate< T >
LevelMeter | AudioUtil.VoiceLevelDetectCalibrate< T >
Process(T[] buf) | AudioUtil.VoiceLevelDetectCalibrate< T >
VoiceDetector | AudioUtil.VoiceLevelDetectCalibrate< T >
VoiceLevelDetectCalibrate(int samplingRate, int channels) | AudioUtil.VoiceLevelDetectCalibrate< T >


Photon Voice: BufferReaderPushAdapter< T > Class Template Reference

Photon Voice v2.30

  • BufferReaderPushAdapter
Public Member Functions | Protected Attributes | List of all members
BufferReaderPushAdapter< T > Class Template Reference

Simple BufferReaderPushAdapterBase<T> implementation using a single buffer and synchronous LocalVoiceFramed<T>.PushData More...

Inherits BufferReaderPushAdapterBase< T >.

Public Member Functions

BufferReaderPushAdapter (LocalVoice localVoice, IDataReader< T > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< T >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Protected Attributes

T[] | buffer
- Protected Attributes inherited from BufferReaderPushAdapterBase< T >
IDataReader< T > | reader

Detailed Description

Simple BufferReaderPushAdapterBase<T> implementation using a single buffer and synchronous LocalVoiceFramed<T>.PushData

Constructor & Destructor Documentation

◆ BufferReaderPushAdapter()

BufferReaderPushAdapter | ( | LocalVoice | localVoice,
 |  | IDataReader< T > | reader
 | ) |  |

Create a new BufferReaderPushAdapter instance

Parameters
localVoice | LocalVoice instance to push data to.
reader | DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to.

Implements BufferReaderPushAdapterBase< T >.


Photon Voice: Member List

Photon Voice v2.30

  • BufferReaderPushAdapter
BufferReaderPushAdapter< T > Member List

This is the complete list of members for BufferReaderPushAdapter< T >, including all inherited members.

buffer (defined in BufferReaderPushAdapter< T >) | BufferReaderPushAdapter< T > | protected
BufferReaderPushAdapter(LocalVoice localVoice, IDataReader< T > reader) | BufferReaderPushAdapter< T > |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< T > |
Dispose() | BufferReaderPushAdapterBase< T > |
reader (defined in BufferReaderPushAdapterBase< T >) | BufferReaderPushAdapterBase< T > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapter< T > | virtual


Photon Voice: BufferReaderPushAdapterAsyncPool< T > Class Template Reference

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPool
Public Member Functions | List of all members
BufferReaderPushAdapterAsyncPool< T > Class Template Reference

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync. More...

Inherits BufferReaderPushAdapterBase< T >.

Public Member Functions

BufferReaderPushAdapterAsyncPool (LocalVoice localVoice, IDataReader< T > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< T >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Additional Inherited Members

- Protected Attributes inherited from BufferReaderPushAdapterBase< T >
IDataReader< T > reader

Detailed Description

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync.

Acquires a buffer from pool before each Read, releases buffer after last Read (brings Acquire/Release overhead). Expects localVoice to be a LocalVoiceFramed<T> of same T.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterAsyncPool()

BufferReaderPushAdapterAsyncPool | ( | LocalVoice | localVoice,
 |  | IDataReader< T > | reader
 | ) |  |

Create a new BufferReaderPushAdapter instance

Parameters
localVoice | LocalVoice instance to push data to.
reader | DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to. Must be a LocalVoiceFramed<T> of same T.

Implements BufferReaderPushAdapterBase< T >.


Photon Voice: Member List

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPool
BufferReaderPushAdapterAsyncPool< T > Member List

This is the complete list of members for BufferReaderPushAdapterAsyncPool< T >, including all inherited members.

BufferReaderPushAdapterAsyncPool(LocalVoice localVoice, IDataReader< T > reader) | BufferReaderPushAdapterAsyncPool< T > |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< T > |
Dispose() | BufferReaderPushAdapterBase< T > |
reader (defined in BufferReaderPushAdapterBase< T >) | BufferReaderPushAdapterBase< T > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterAsyncPool< T > | virtual


Photon Voice: BufferReaderPushAdapterAsyncPoolCopy< T > Class Template Reference

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPoolCopy
Public Member Functions | Protected Attributes | List of all members
BufferReaderPushAdapterAsyncPoolCopy< T > Class Template Reference

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync(T[]) and data copy. More...

Inherits BufferReaderPushAdapterBase< T >.

Public Member Functions

BufferReaderPushAdapterAsyncPoolCopy (LocalVoice localVoice, IDataReader< T > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< T >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Protected Attributes

T[] | buffer
- Protected Attributes inherited from BufferReaderPushAdapterBase< T >
IDataReader< T > | reader

Detailed Description

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync(T[]) and data copy.

Reads data to preallocated buffer, copies it to buffer from pool before pushing. Compared with BufferReaderPushAdapterAsyncPool<T>, this avoids one pool Acquire/Release cycle at the cost of a buffer copy. Expects localVoice to be a LocalVoiceFramed<T> of same T.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterAsyncPoolCopy()

BufferReaderPushAdapterAsyncPoolCopy | ( | LocalVoice | localVoice,
 |  | IDataReader< T > | reader
 | ) |  |

Create a new BufferReaderPushAdapter instance

Parameters
localVoice | LocalVoice instance to push data to.
reader | DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to. Must be a LocalVoiceFramed<T> of same T.

Implements BufferReaderPushAdapterBase< T >.


Photon Voice: Member List

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPoolCopy
BufferReaderPushAdapterAsyncPoolCopy< T > Member List

This is the complete list of members for BufferReaderPushAdapterAsyncPoolCopy< T >, including all inherited members.

buffer (defined in BufferReaderPushAdapterAsyncPoolCopy< T >) | BufferReaderPushAdapterAsyncPoolCopy< T > | protected
BufferReaderPushAdapterAsyncPoolCopy(LocalVoice localVoice, IDataReader< T > reader) | BufferReaderPushAdapterAsyncPoolCopy< T > |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< T > |
Dispose() | BufferReaderPushAdapterBase< T > |
reader (defined in BufferReaderPushAdapterBase< T >) | BufferReaderPushAdapterBase< T > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterAsyncPoolCopy< T > | virtual


Photon Voice: BufferReaderPushAdapterAsyncPoolFloatToShort Class Reference

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPoolFloatToShort
Public Member Functions | List of all members
BufferReaderPushAdapterAsyncPoolFloatToShort Class Reference

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short. More...

Inherits BufferReaderPushAdapterBase< float >.

Public Member Functions

BufferReaderPushAdapterAsyncPoolFloatToShort (LocalVoice localVoice, IDataReader< float > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< float >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Additional Inherited Members

- Protected Attributes inherited from BufferReaderPushAdapterBase< float >
IDataReader< T > reader

Detailed Description

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short.

This adapter works exactly like BufferReaderPushAdapterAsyncPool<T>, but it converts float samples to short. Acquires a buffer from pool before each Read, releases buffer after last Read.

Expects localVoice to be a LocalVoiceFramed<T> of same T.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterAsyncPoolFloatToShort()

BufferReaderPushAdapterAsyncPoolFloatToShort | ( | LocalVoice | localVoice,
 |  | IDataReader< float > | reader
 | ) |  |

Create a new BufferReaderPushAdapter instance

Parameters
localVoice | LocalVoice instance to push data to.
reader | DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to. Must be a LocalVoiceFramed<T> of same T.

Implements BufferReaderPushAdapterBase< float >.


Photon Voice: Member List

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPoolFloatToShort
BufferReaderPushAdapterAsyncPoolFloatToShort Member List

This is the complete list of members for BufferReaderPushAdapterAsyncPoolFloatToShort, including all inherited members.

BufferReaderPushAdapterAsyncPoolFloatToShort(LocalVoice localVoice, IDataReader< float > reader) | BufferReaderPushAdapterAsyncPoolFloatToShort |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< float > |
Dispose() | BufferReaderPushAdapterBase< float > |
reader (defined in BufferReaderPushAdapterBase< float >) | BufferReaderPushAdapterBase< float > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterAsyncPoolFloatToShort | virtual


Photon Voice: BufferReaderPushAdapterAsyncPoolShortToFloat Class Reference

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPoolShortToFloat
Public Member Functions | List of all members
BufferReaderPushAdapterAsyncPoolShortToFloat Class Reference

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float. More...

Inherits BufferReaderPushAdapterBase< short >.

Public Member Functions

BufferReaderPushAdapterAsyncPoolShortToFloat (LocalVoice localVoice, IDataReader< short > reader)
Create a new BufferReaderPushAdapter instance More...
override void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
- Public Member Functions inherited from BufferReaderPushAdapterBase< short >
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Additional Inherited Members

- Protected Attributes inherited from BufferReaderPushAdapterBase< short >
IDataReader< T > reader

Detailed Description

BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float.

This adapter works exactly like BufferReaderPushAdapterAsyncPool<T>, but it converts short samples to float. Acquires a buffer from pool before each Read, releases buffer after last Read.

Expects localVoice to be a LocalVoiceFramed<T> of same T.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterAsyncPoolShortToFloat()

BufferReaderPushAdapterAsyncPoolShortToFloat | ( | LocalVoice | localVoice,
 |  | IDataReader< short > | reader
 | ) |  |

Create a new BufferReaderPushAdapter instance

Parameters
localVoice | LocalVoice instance to push data to.
reader | DataReader to read from.

Member Function Documentation

◆ Service()

override void Service ( LocalVoice localVoice )
virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to. Must be a LocalVoiceFramed<T> of same T.

Implements BufferReaderPushAdapterBase< short >.


Photon Voice: Member List

Photon Voice v2.30

  • BufferReaderPushAdapterAsyncPoolShortToFloat
BufferReaderPushAdapterAsyncPoolShortToFloat Member List

This is the complete list of members for BufferReaderPushAdapterAsyncPoolShortToFloat, including all inherited members.

BufferReaderPushAdapterAsyncPoolShortToFloat(LocalVoice localVoice, IDataReader< short > reader) | BufferReaderPushAdapterAsyncPoolShortToFloat |
BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< short > |
Dispose() | BufferReaderPushAdapterBase< short > |
reader (defined in BufferReaderPushAdapterBase< short >) | BufferReaderPushAdapterBase< short > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterAsyncPoolShortToFloat | virtual


Photon Voice: BufferReaderPushAdapterBase< T > Class Template Reference

Photon Voice v2.30

  • BufferReaderPushAdapterBase
Public Member Functions | Protected Attributes | List of all members
BufferReaderPushAdapterBase< T > Class Template Referenceabstract

Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice. More...

Inherits IServiceable.

Inherited by BufferReaderPushAdapter< T >, BufferReaderPushAdapterAsyncPool< T >, and BufferReaderPushAdapterAsyncPoolCopy< T >.

Public Member Functions

abstract void | Service (LocalVoice localVoice)
Do the actual data read/push. More...
BufferReaderPushAdapterBase (IDataReader< T > reader)
Create a new BufferReaderPushAdapterBase instance More...
void | Dispose ()
Release resources associated with this instance. More...

Protected Attributes

IDataReader< T > reader

Detailed Description

Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice.

Use this with a LocalVoice of same T type.

Constructor & Destructor Documentation

◆ BufferReaderPushAdapterBase()

BufferReaderPushAdapterBase ( IDataReader< T > reader )

Create a new BufferReaderPushAdapterBase instance

Parameters
reader DataReader to read from.

Member Function Documentation

◆ Dispose()

void Dispose ( )

Release resources associated with this instance.

◆ Service()

abstract void Service ( LocalVoice localVoice )
pure virtual

Do the actual data read/push.

Parameters
localVoice LocalVoice instance to push data to.

Implements IServiceable.

Implemented in BufferReaderPushAdapterAsyncPoolShortToFloat, BufferReaderPushAdapterAsyncPoolFloatToShort, BufferReaderPushAdapterAsyncPoolCopy< T >, BufferReaderPushAdapterAsyncPool< T >, and BufferReaderPushAdapter< T >.


Photon Voice: Member List

Photon Voice v2.30

  • BufferReaderPushAdapterBase
BufferReaderPushAdapterBase< T > Member List

This is the complete list of members for BufferReaderPushAdapterBase< T >, including all inherited members.

BufferReaderPushAdapterBase(IDataReader< T > reader) | BufferReaderPushAdapterBase< T > |
Dispose() | BufferReaderPushAdapterBase< T > |
reader (defined in BufferReaderPushAdapterBase< T >) | BufferReaderPushAdapterBase< T > | protected
Service(LocalVoice localVoice) | BufferReaderPushAdapterBase< T > | pure virtual


Photon Voice: DeviceEnumeratorBase Class Reference

Photon Voice v2.30

  • DeviceEnumeratorBase
Public Member Functions | Public Attributes | Protected Attributes | Properties | List of all members
DeviceEnumeratorBase Class Referenceabstract

Inherits IDeviceEnumerator.

Inherited by DeviceEnumeratorNotSupported, and AudioInEnumerator.

Public Member Functions

DeviceEnumeratorBase (ILogger logger)
IEnumerator< DeviceInfo > | GetEnumerator ()
abstract void | Refresh ()
abstract void | Dispose ()

Public Attributes

virtual bool IsSupported => true

Protected Attributes

List< DeviceInfo > | devices = new List<DeviceInfo>()
ILogger | logger

Properties

virtual string | Error [get, protected set]
- Properties inherited from IDeviceEnumerator
bool | IsSupported [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • DeviceEnumeratorBase
DeviceEnumeratorBase Member List

This is the complete list of members for DeviceEnumeratorBase, including all inherited members.

DeviceEnumeratorBase(ILogger logger) (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
devices (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Dispose() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | pure virtual
Error (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
GetEnumerator() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
IsSupported (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase |
logger (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | protected
Refresh() (defined in DeviceEnumeratorBase) | DeviceEnumeratorBase | pure virtual


Photon Voice: DeviceInfo Struct Reference

Photon Voice v2.30

  • DeviceInfo
Public Member Functions | Static Public Member Functions | Static Public Attributes | Properties | List of all members
DeviceInfo Struct Reference

Public Member Functions

DeviceInfo (int id, string name)
DeviceInfo (string id, string name)
DeviceInfo (string name)
override bool | Equals (object obj)
override int | GetHashCode ()
override string | ToString ()

Static Public Member Functions

static bool | operator== (DeviceInfo d1, DeviceInfo d2)
static bool | operator!= (DeviceInfo d1, DeviceInfo d2)

Static Public Attributes

static readonly DeviceInfo Default = new DeviceInfo(true, -128, "", "[Default]")

Properties

bool | IsDefault [get]
int | IDInt [get]
string | IDString [get]
string | Name [get]


Photon Voice: Member List

Photon Voice v2.30

  • DeviceInfo
DeviceInfo Member List

This is the complete list of members for DeviceInfo, including all inherited members.

Default (defined in DeviceInfo) | DeviceInfo | static
DeviceInfo(int id, string name) (defined in DeviceInfo) | DeviceInfo |
DeviceInfo(string id, string name) (defined in DeviceInfo) | DeviceInfo |
DeviceInfo(string name) (defined in DeviceInfo) | DeviceInfo |
Equals(object obj) (defined in DeviceInfo) | DeviceInfo |
GetHashCode() (defined in DeviceInfo) | DeviceInfo |
IDInt (defined in DeviceInfo) | DeviceInfo |
IDString (defined in DeviceInfo) | DeviceInfo |
IsDefault (defined in DeviceInfo) | DeviceInfo |
Name (defined in DeviceInfo) | DeviceInfo |
operator!=(DeviceInfo d1, DeviceInfo d2) (defined in DeviceInfo) | DeviceInfo | static
operator==(DeviceInfo d1, DeviceInfo d2) (defined in DeviceInfo) | DeviceInfo | static
ToString() (defined in DeviceInfo) | DeviceInfo |


Photon Voice: FactoryPrimitiveArrayPool< T > Class Template Reference

Photon Voice v2.30

  • FactoryPrimitiveArrayPool
Public Member Functions | Properties | List of all members
FactoryPrimitiveArrayPool< T > Class Template Reference

PrimitiveArrayPool<T> as wrapped in object factory interface. More...

Inherits ObjectFactory< T[], int >.

Public Member Functions

FactoryPrimitiveArrayPool (int capacity, string name)
FactoryPrimitiveArrayPool (int capacity, string name, int info)
T[] | New ()
T[] | New (int size)
void | Free (T[] obj)
void | Free (T[] obj, int info)
void | Dispose ()
- Public Member Functions inherited from ObjectFactory< T[], int >
TType | New ()
TType | New (TInfo info)
void | Free (TType obj)
void | Free (TType obj, TInfo info)

Properties

int | Info [get]
- Properties inherited from ObjectFactory< T[], int >
TInfo | Info [get]

Detailed Description

PrimitiveArrayPool<T> as wrapped in object factory interface.

Template Parameters
T Array element type.


Photon Voice: Member List

Photon Voice v2.30

  • FactoryPrimitiveArrayPool
FactoryPrimitiveArrayPool< T > Member List

This is the complete list of members for FactoryPrimitiveArrayPool< T >, including all inherited members.

Dispose() (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
FactoryPrimitiveArrayPool(int capacity, string name) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
FactoryPrimitiveArrayPool(int capacity, string name, int info) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
Free(T[] obj) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
Free(T[] obj, int info) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
Free(TType obj) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Free(TType obj, TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Info (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
New() (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
New(int size) (defined in FactoryPrimitiveArrayPool< T >) | FactoryPrimitiveArrayPool< T >
New(TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >


Photon Voice: FactoryReusableArray< T > Class Template Reference

Photon Voice v2.30

  • FactoryReusableArray
Public Member Functions | Properties | List of all members
FactoryReusableArray< T > Class Template Reference

Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created. More...

Inherits ObjectFactory< T[], int >.

Public Member Functions

FactoryReusableArray (int size)
T[] | New ()
T[] | New (int size)
void | Free (T[] obj)
void | Free (T[] obj, int info)
void | Dispose ()
- Public Member Functions inherited from ObjectFactory< T[], int >
TType | New ()
TType | New (TInfo info)
void | Free (TType obj)
void | Free (TType obj, TInfo info)

Properties

int | Info [get]
- Properties inherited from ObjectFactory< T[], int >
TInfo | Info [get]

Detailed Description

Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created.

Template Parameters
T Array element type.


Photon Voice: Member List

Photon Voice v2.30

  • FactoryReusableArray
FactoryReusableArray< T > Member List

This is the complete list of members for FactoryReusableArray< T >, including all inherited members.

Dispose() (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
FactoryReusableArray(int size) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
Free(T[] obj) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
Free(T[] obj, int info) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
Free(TType obj) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Free(TType obj, TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >
Info (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
New() (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
New(int size) (defined in FactoryReusableArray< T >) | FactoryReusableArray< T >
New(TInfo info) (defined in ObjectFactory< T[], int >) | ObjectFactory< T[], int >


Photon Voice: Flip Struct Reference

Photon Voice v2.30

  • Flip
Public Member Functions | Static Public Member Functions | Static Public Attributes | Properties | List of all members
Flip Struct Reference

Public Member Functions

override bool | Equals (object obj)
override int | GetHashCode ()

Static Public Member Functions

static bool | operator== (Flip f1, Flip f2)
static bool | operator!= (Flip f1, Flip f2)
static Flip | operator* (Flip f1, Flip f2)

Static Public Attributes

static Flip | None
static Flip | Vertical = new Flip() { IsVertical = true }
static Flip | Horizontal = new Flip() { IsHorizontal = true }
static Flip | Both = Vertical * Horizontal

Properties

bool | IsVertical [get]
bool | IsHorizontal [get]


Photon Voice: Member List

Photon Voice v2.30

  • Flip
Flip Member List

This is the complete list of members for Flip, including all inherited members.

Both (defined in Flip) | Flip | static
Equals(object obj) (defined in Flip) | Flip |
GetHashCode() (defined in Flip) | Flip |
Horizontal (defined in Flip) | Flip | static
IsHorizontal (defined in Flip) | Flip |
IsVertical (defined in Flip) | Flip |
None (defined in Flip) | Flip | static
operator!=(Flip f1, Flip f2) (defined in Flip) | Flip | static
operator*(Flip f1, Flip f2) (defined in Flip) | Flip | static
operator==(Flip f1, Flip f2) (defined in Flip) | Flip | static
Vertical (defined in Flip) | Flip | static


Photon Voice: FrameBuffer Struct Reference

Photon Voice v2.30

  • FrameBuffer
Public Member Functions | Public Attributes | Properties | List of all members
FrameBuffer Struct Reference

Public Member Functions

FrameBuffer (byte[] array, int offset, int count, FrameFlags flags, IDisposable disposer)
FrameBuffer (byte[] array, FrameFlags flags)
void | Retain ()
void | Release ()

Public Attributes

readonly byte[] | array
readonly int | offset
readonly int | count
readonly IDisposable | disposer
bool | disposed
int | refCnt
GCHandle | gcHandle
IntPtr | ptr
bool | pinned

Properties

IntPtr | Ptr [get]
byte[] | Array [get]
int | Length [get]
int | Offset [get]
FrameFlags | Flags [get]


Photon Voice: Member List

Photon Voice v2.30

  • FrameBuffer
FrameBuffer Member List

This is the complete list of members for FrameBuffer, including all inherited members.

array (defined in FrameBuffer) | FrameBuffer
Array (defined in FrameBuffer) | FrameBuffer
count (defined in FrameBuffer) | FrameBuffer
disposed (defined in FrameBuffer) | FrameBuffer
disposer (defined in FrameBuffer) | FrameBuffer
Flags (defined in FrameBuffer) | FrameBuffer
FrameBuffer(byte[] array, int offset, int count, FrameFlags flags, IDisposable disposer) (defined in FrameBuffer) | FrameBuffer
FrameBuffer(byte[] array, FrameFlags flags) (defined in FrameBuffer) | FrameBuffer
gcHandle (defined in FrameBuffer) | FrameBuffer
Length (defined in FrameBuffer) | FrameBuffer
Offset (defined in FrameBuffer) | FrameBuffer
offset (defined in FrameBuffer) | FrameBuffer
pinned (defined in FrameBuffer) | FrameBuffer
ptr (defined in FrameBuffer) | FrameBuffer
Ptr (defined in FrameBuffer) | FrameBuffer
refCnt (defined in FrameBuffer) | FrameBuffer
Release() (defined in FrameBuffer) | FrameBuffer
Retain() (defined in FrameBuffer) | FrameBuffer


Photon Voice: FrameOut< T > Class Template Reference

Photon Voice v2.30

  • FrameOut
Public Member Functions | Properties | List of all members
FrameOut< T > Class Template Reference

Public Member Functions

FrameOut (T[] buf, bool endOfStream)
FrameOut< T > Set (T[] buf, bool endOfStream)

Properties

T[] | Buf [get]
bool | EndOfStream [get]


Photon Voice: Member List

Photon Voice v2.30

  • FrameOut
FrameOut< T > Member List

This is the complete list of members for FrameOut< T >, including all inherited members.

Buf (defined in FrameOut< T >) | FrameOut< T >
EndOfStream (defined in FrameOut< T >) | FrameOut< T >
FrameOut(T[] buf, bool endOfStream) (defined in FrameOut< T >) | FrameOut< T >
Set(T[] buf, bool endOfStream) (defined in FrameOut< T >) | FrameOut< T >


Photon Voice: Framer< T > Class Template Reference

Photon Voice v2.30

  • Framer
Public Member Functions | List of all members
Framer< T > Class Template Reference

Utility class to re-frame audio packets. More...

Public Member Functions

Framer (int frameSize)
Create new Framer instance. More...
int | Count (int bufLen)
Get the number of frames available after adding bufLen samples. More...
IEnumerable< T[]> | Frame (T[] buf)
Append arbitrary-sized buffer and return available full frames. More...

Detailed Description

Utility class to re-frame audio packets.

Constructor & Destructor Documentation

◆ Framer()

Framer ( int frameSize )

Create new Framer instance.

Member Function Documentation

◆ Count()

int Count ( int bufLen )

Get the number of frames available after adding bufLen samples.

Parameters
bufLen Number of samples that would be added.
Returns
Number of full frames available when adding bufLen samples.

◆ Frame()

IEnumerable<T[]> Frame ( T[] buf )

Append arbitrary-sized buffer and return available full frames.

Parameters
buf Array of samples to add.
Returns
Enumerator of full frames (might be none).


Photon Voice: Member List

Photon Voice v2.30

  • Framer
Framer< T > Member List

This is the complete list of members for Framer< T >, including all inherited members.

Count(int bufLen) | Framer< T >
Frame(T[] buf) | Framer< T >
Framer(int frameSize) | Framer< T >


Photon Voice: IAudioDesc Interface Reference

Photon Voice v2.30

  • IAudioDesc
Properties | List of all members
IAudioDesc Interface Reference

Audio Source interface. More...

Inherits IDisposable.

Inherited by AudioDesc, IAudioPusher< T >, and IAudioReader< T >.

Properties

int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

Audio Source interface.

Property Documentation

◆ Channels

int Channels
get

Number of channels in the audio signal.

◆ Error

string Error
get

If not null, audio object is in invalid state.

◆ SamplingRate

int SamplingRate
get

Sampling rate of the audio signal (in Hz).


Photon Voice: Member List

Photon Voice v2.30

  • IAudioDesc
IAudioDesc Member List

This is the complete list of members for IAudioDesc, including all inherited members.

Channels | IAudioDesc
Error | IAudioDesc
SamplingRate | IAudioDesc


Photon Voice: IAudioInChangeNotifier Interface Reference

Photon Voice v2.30

  • IAudioInChangeNotifier
Properties | List of all members
IAudioInChangeNotifier Interface Reference

Inherits IDisposable.

Inherited by AudioInChangeNotifierNotSupported.

Properties

bool | IsSupported [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • IAudioInChangeNotifier
IAudioInChangeNotifier Member List

This is the complete list of members for IAudioInChangeNotifier, including all inherited members.

Error (defined in IAudioInChangeNotifier) | IAudioInChangeNotifier
IsSupported (defined in IAudioInChangeNotifier) | IAudioInChangeNotifier


Photon Voice: IAudioOut< T > Interface Template Reference

Photon Voice v2.30

  • IAudioOut
Public Member Functions | Properties | List of all members
IAudioOut< T > Interface Template Reference

Inherited by AudioOutDelayControl< T >, and AudioSyncBuffer< T >.

Public Member Functions

void | Start (int frequency, int channels, int frameSamplesPerChannel)
void | Flush ()
void | Stop ()
void | Push (T[] frame)
void | Service ()

Properties

bool | IsPlaying [get]
int | Lag [get]


Photon Voice: Member List

Photon Voice v2.30

  • IAudioOut
IAudioOut< T > Member List

This is the complete list of members for IAudioOut< T >, including all inherited members.

Flush() (defined in IAudioOut< T >) | IAudioOut< T >
IsPlaying (defined in IAudioOut< T >) | IAudioOut< T >
Lag (defined in IAudioOut< T >) | IAudioOut< T >
Push(T[] frame) (defined in IAudioOut< T >) | IAudioOut< T >
Service() (defined in IAudioOut< T >) | IAudioOut< T >
Start(int frequency, int channels, int frameSamplesPerChannel) (defined in IAudioOut< T >) | IAudioOut< T >
Stop() (defined in IAudioOut< T >) | IAudioOut< T >


Photon Voice: IAudioPusher< T > Interface Template Reference

Photon Voice v2.30

  • IAudioPusher
Public Member Functions | List of all members
IAudioPusher< T > Interface Template Reference

Audio Pusher interface. More...

Inherits IAudioDesc.

Inherited by AudioUtil.ToneAudioPusher< T >.

Public Member Functions

void SetCallback (Action< T[]> callback, ObjectFactory< T[], int > bufferFactory)
Set the callback function used for pushing data. More...

Additional Inherited Members

- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

Audio Pusher interface.

Opposed to an IAudioReader (which will deliver audio data when it is "pulled"), an IAudioPusher will push its audio data whenever it is ready,

Member Function Documentation

◆ SetCallback()

void SetCallback | ( | Action< T[]> | callback,
 |  | ObjectFactory< T[], int > | bufferFactory
 | ) |  |

Set the callback function used for pushing data.

Parameters
callback | Callback function to use.
bufferFactory | Buffer factory used to create the buffer that is pushed to the callback

Implemented in AudioUtil.ToneAudioPusher< T >.


Photon Voice: Member List

Photon Voice v2.30

  • IAudioPusher
IAudioPusher< T > Member List

This is the complete list of members for IAudioPusher< T >, including all inherited members.

Channels | IAudioDesc
Error | IAudioDesc
SamplingRate | IAudioDesc
SetCallback(Action< T[]> callback, ObjectFactory< T[], int > bufferFactory) | IAudioPusher< T >


Photon Voice: IAudioReader< T > Interface Template Reference

Photon Voice v2.30

  • IAudioReader
List of all members
IAudioReader< T > Interface Template Reference

Audio Reader interface. More...

Inherits IDataReader< T >, and IAudioDesc.

Inherited by AudioUtil.ToneAudioReader< T >.

Additional Inherited Members

- Public Member Functions inherited from IDataReader< T >
bool | Read (T[] buffer)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...
- Properties inherited from IAudioDesc
int | SamplingRate [get]
Sampling rate of the audio signal (in Hz). More...
int | Channels [get]
Number of channels in the audio signal. More...
string | Error [get]
If not null, audio object is in invalid state. More...

Detailed Description

Audio Reader interface.

Opposed to an IAudioPusher (which will push its audio data whenever it is ready), an IAudioReader will deliver audio data when it is "pulled" (it's Read function is called).


Photon Voice: Member List

Photon Voice v2.30

  • IAudioReader
IAudioReader< T > Member List

This is the complete list of members for IAudioReader< T >, including all inherited members.

Channels | IAudioDesc
Error | IAudioDesc
Read(T[] buffer) | IDataReader< T >
SamplingRate | IAudioDesc


Photon Voice: IDataReader< T > Interface Template Reference

Photon Voice v2.30

  • IDataReader
Public Member Functions | List of all members
IDataReader< T > Interface Template Reference

Interface for pulling data, in case this is more appropriate than pushing it. More...

Inherits IDisposable.

Inherited by IAudioReader< T >.

Public Member Functions

bool Read (T[] buffer)
Fill full given frame buffer with source uncompressed data or return false if not enough such data. More...

Detailed Description

Interface for pulling data, in case this is more appropriate than pushing it.

Member Function Documentation

◆ Read()

bool Read ( T[] buffer )

Fill full given frame buffer with source uncompressed data or return false if not enough such data.

Parameters
buffer Buffer to fill.
Returns
True if buffer was filled successfully, false otherwise.

Implemented in AudioUtil.ToneAudioReader< T >.


Photon Voice: Member List

Photon Voice v2.30

  • IDataReader
IDataReader< T > Member List

This is the complete list of members for IDataReader< T >, including all inherited members.

Read(T[] buffer) IDataReader< T >


Photon Voice: IDecoder Interface Reference

Photon Voice v2.30

  • IDecoder
Public Member Functions | Properties | List of all members
IDecoder Interface Reference

Generic decoder interface. More...

Inherits IDisposable.

Inherited by IDecoderDirect< B >, OpusCodec.Decoder< T >, and RawCodec.Decoder< T >.

Public Member Functions

void | Open (VoiceInfo info)
Open (initialize) the decoder. More...
void | Input (ref FrameBuffer buf)
Consumes the given encoded data. More...

Properties

string Error [get]
If not null, the object is in invalid state. More...

Detailed Description

Generic decoder interface.

Member Function Documentation

◆ Input()

void Input ( ref FrameBuffer buf )

Consumes the given encoded data.

The callee can call buf.Retain() to prevent the caller from disposing the buffer. In this case, the callee should call buf.Release() when buffer is no longer needed.

Implemented in RawCodec.Decoder< T >, and OpusCodec.Decoder< T >.

◆ Open()

void Open ( VoiceInfo info )

Open (initialize) the decoder.

Parameters
info Properties of the data stream to decode.

Implemented in RawCodec.Decoder< T >, and OpusCodec.Decoder< T >.

Property Documentation

◆ Error

string Error
get

If not null, the object is in invalid state.


Photon Voice: Member List

Photon Voice v2.30

  • IDecoder
IDecoder Member List

This is the complete list of members for IDecoder, including all inherited members.

Error | IDecoder
Input(ref FrameBuffer buf) | IDecoder
Open(VoiceInfo info) | IDecoder


Photon Voice: IDecoderDirect< B > Interface Template Reference

Photon Voice v2.30

  • IDecoderDirect
Properties | List of all members
IDecoderDirect< B > Interface Template Reference

Interface for an decoder which outputs data via explicit call. More...

Inherits IDecoder.

Properties

Action< B > | Output [get, set]
Callback to call when a new decoded data buffer is available. More...
- Properties inherited from IDecoder
string | Error [get]
If not null, the object is in invalid state. More...

Additional Inherited Members

- Public Member Functions inherited from IDecoder
void | Open (VoiceInfo info)
Open (initialize) the decoder. More...
void | Input (ref FrameBuffer buf)
Consumes the given encoded data. More...

Detailed Description

Interface for an decoder which outputs data via explicit call.

Property Documentation

◆ Output

Action<B> Output
getset

Callback to call when a new decoded data buffer is available.


Photon Voice: Member List

Photon Voice v2.30

  • IDecoderDirect
IDecoderDirect< B > Member List

This is the complete list of members for IDecoderDirect< B >, including all inherited members.

Error | IDecoder
Input(ref FrameBuffer buf) | IDecoder
Open(VoiceInfo info) | IDecoder
Output | IDecoderDirect< B >


Photon Voice: IDeviceEnumerator Interface Reference

Photon Voice v2.30

  • IDeviceEnumerator
Public Member Functions | Properties | List of all members
IDeviceEnumerator Interface Reference

Inherits IDisposable, and IEnumerable< DeviceInfo >.

Inherited by DeviceEnumeratorBase.

Public Member Functions

void Refresh ()

Properties

bool | IsSupported [get]
string | Error [get]


Photon Voice: Member List

Photon Voice v2.30

  • IDeviceEnumerator
IDeviceEnumerator Member List

This is the complete list of members for IDeviceEnumerator, including all inherited members.

Error (defined in IDeviceEnumerator) | IDeviceEnumerator
IsSupported (defined in IDeviceEnumerator) | IDeviceEnumerator
Refresh() (defined in IDeviceEnumerator) | IDeviceEnumerator


Photon Voice: IEncoder Interface Reference

Photon Voice v2.30

  • IEncoder
Public Member Functions | Properties | List of all members
IEncoder Interface Reference

Generic encoder interface. More...

Inherits IDisposable.

Inherited by IEncoderDirect< B >.

Public Member Functions

ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
Returns next encoded data frame (if such output supported). More...
void | EndOfStream ()
Forces an encoder to flush and produce frame with EndOfStream flag (in output queue). More...
I | GetPlatformAPI< I > ()
Returns an platform-specific interface. More...

Properties

string | Error [get]
If not null, the object is in invalid state. More...
Action< ArraySegment< byte >, FrameFlags > | Output [set]
Set callback encoder calls on each encoded data frame (if such output supported). More...

Detailed Description

Generic encoder interface.

Depending on implementation, encoder should either call Output on eaach data frame or return next data frame in DequeueOutput() call.

Member Function Documentation

◆ DequeueOutput()

ArraySegment<byte> DequeueOutput ( out FrameFlags flags )

Returns next encoded data frame (if such output supported).

◆ EndOfStream()

void EndOfStream ( )

Forces an encoder to flush and produce frame with EndOfStream flag (in output queue).

◆ GetPlatformAPI< I >()

I GetPlatformAPI< I > ( )

Returns an platform-specific interface.

Type Constraints
I : class

Property Documentation

◆ Error

string Error
get

If not null, the object is in invalid state.

◆ Output

Action<ArraySegment<byte>, FrameFlags> Output
set

Set callback encoder calls on each encoded data frame (if such output supported).


Photon Voice: Member List

Photon Voice v2.30

  • IEncoder
IEncoder Member List

This is the complete list of members for IEncoder, including all inherited members.

DequeueOutput(out FrameFlags flags) | IEncoder
EndOfStream() | IEncoder
Error | IEncoder
GetPlatformAPI< I >() | IEncoder
Output | IEncoder


Photon Voice: IEncoderDirect< B > Interface Template Reference

Photon Voice v2.30

  • IEncoderDirect
Public Member Functions | List of all members
IEncoderDirect< B > Interface Template Reference

Interface for an encoder which consumes input data via explicit call. More...

Inherits IEncoder.

Public Member Functions

void | Input (B buf)
Consumes the given raw data. More...
- Public Member Functions inherited from IEncoder
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
Returns next encoded data frame (if such output supported). More...
void | EndOfStream ()
Forces an encoder to flush and produce frame with EndOfStream flag (in output queue). More...
I | GetPlatformAPI< I > ()
Returns an platform-specific interface. More...

Additional Inherited Members

- Properties inherited from IEncoder
string | Error [get]
If not null, the object is in invalid state. More...
Action< ArraySegment< byte >, FrameFlags > | Output [set]
Set callback encoder calls on each encoded data frame (if such output supported). More...

Detailed Description

Interface for an encoder which consumes input data via explicit call.

Member Function Documentation

◆ Input()

void Input ( B buf )

Consumes the given raw data.

Parameters
buf Array containing raw data (e.g. audio samples).


Photon Voice: Member List

Photon Voice v2.30

  • IEncoderDirect
IEncoderDirect< B > Member List

This is the complete list of members for IEncoderDirect< B >, including all inherited members.

DequeueOutput(out FrameFlags flags) | IEncoder
EndOfStream() | IEncoder
Error | IEncoder
GetPlatformAPI< I >() | IEncoder
Input(B buf) | IEncoderDirect< B >
Output | IEncoder


Photon Voice: IEncoderDirectImage Interface Reference

Photon Voice v2.30

  • IEncoderDirectImage
Properties | List of all members
IEncoderDirectImage Interface Reference

Interface for an encoder which consumes images via explicit call. More...

Inherits IEncoderDirect< ImageBufferNative >.

Properties

ImageFormat ImageFormat [get]
Recommended encoder input image format. Encoder may support other formats. More...

Additional Inherited Members

- Public Member Functions inherited from IEncoderDirect< ImageBufferNative >
void Input (B buf)
Consumes the given raw data. More...

Detailed Description

Interface for an encoder which consumes images via explicit call.

Property Documentation

◆ ImageFormat

ImageFormat ImageFormat
get

Recommended encoder input image format. Encoder may support other formats.


Photon Voice: Member List

Photon Voice v2.30

  • IEncoderDirectImage
IEncoderDirectImage Member List

This is the complete list of members for IEncoderDirectImage, including all inherited members.

ImageFormat | IEncoderDirectImage
Input(B buf) | IEncoderDirect< ImageBufferNative >


Photon Voice: ILocalVoiceAudio Interface Reference

Photon Voice v2.30

  • ILocalVoiceAudio
Public Member Functions | Properties | List of all members
ILocalVoiceAudio Interface Reference

Interface for an outgoing audio stream. More...

Inherited by LocalVoiceAudio< T >, and LocalVoiceAudioDummy.

Public Member Functions

void VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...

Properties

AudioUtil.IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use. More...
AudioUtil.ILevelMeter | LevelMeter [get]
The LevelMeter utility in use. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...

Detailed Description

Interface for an outgoing audio stream.

A LocalVoice always brings a LevelMeter and a VoiceDetector, which you can access using this interface.

Member Function Documentation

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Trigger voice detector calibration process.

While calibrating, keep silence. Voice detector sets threshold based on measured backgroud noise level.

Parameters
durationMs | Duration of calibration (in milliseconds).
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

Implemented in LocalVoiceAudioDummy, and LocalVoiceAudio< T >.

Property Documentation

◆ LevelMeter

AudioUtil.ILevelMeter LevelMeter
get

The LevelMeter utility in use.

◆ VoiceDetector

AudioUtil.IVoiceDetector VoiceDetector
get

The VoiceDetector in use.

Use it to enable or disable voice detector and set its parameters.

◆ VoiceDetectorCalibrating

bool VoiceDetectorCalibrating
get

If true, voice detector calibration is in progress.


Photon Voice: Member List

Photon Voice v2.30

  • ILocalVoiceAudio
ILocalVoiceAudio Member List

This is the complete list of members for ILocalVoiceAudio, including all inherited members.

LevelMeter | ILocalVoiceAudio
VoiceDetector | ILocalVoiceAudio
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | ILocalVoiceAudio
VoiceDetectorCalibrating | ILocalVoiceAudio


Photon Voice: ILogger Interface Reference

Photon Voice v2.30

  • ILogger
Public Member Functions | List of all members
ILogger Interface Reference

Inherited by LoadBalancingTransport, Logger, and VoiceLogger.

Public Member Functions

void | LogError (string fmt, params object[] args)
void | LogWarning (string fmt, params object[] args)
void | LogInfo (string fmt, params object[] args)
void | LogDebug (string fmt, params object[] args)


Photon Voice: Member List

Photon Voice v2.30

  • ILogger
ILogger Member List

This is the complete list of members for ILogger, including all inherited members.

LogDebug(string fmt, params object[] args) (defined in ILogger) | ILogger
LogError(string fmt, params object[] args) (defined in ILogger) | ILogger
LogInfo(string fmt, params object[] args) (defined in ILogger) | ILogger
LogWarning(string fmt, params object[] args) (defined in ILogger) | ILogger


Photon Voice: ImageBufferInfo Struct Reference

Photon Voice v2.30

  • ImageBufferInfo
Classes | Public Member Functions | Properties | List of all members
ImageBufferInfo Struct Reference

Classes

struct StrideSet

Public Member Functions

ImageBufferInfo (int width, int height, StrideSet stride, ImageFormat format)

Properties

int | Width [get]
int | Height [get]
StrideSet | Stride [get]
ImageFormat | Format [get]
Rotation | Rotation [get, set]
Flip | Flip [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • ImageBufferInfo
ImageBufferInfo Member List

This is the complete list of members for ImageBufferInfo, including all inherited members.

Flip (defined in ImageBufferInfo) | ImageBufferInfo
Format (defined in ImageBufferInfo) | ImageBufferInfo
Height (defined in ImageBufferInfo) | ImageBufferInfo
ImageBufferInfo(int width, int height, StrideSet stride, ImageFormat format) (defined in ImageBufferInfo) | ImageBufferInfo
Rotation (defined in ImageBufferInfo) | ImageBufferInfo
Stride (defined in ImageBufferInfo) | ImageBufferInfo
Width (defined in ImageBufferInfo) | ImageBufferInfo


Photon Voice: ImageBufferInfo.StrideSet Struct Reference

Photon Voice v2.30

  • ImageBufferInfo
  • StrideSet
Public Member Functions | Properties | List of all members
ImageBufferInfo.StrideSet Struct Reference

Public Member Functions

StrideSet (int length, int s0=0, int s1=0, int s2=0, int s3=0)

Properties

int | this[int key] [get, set]
int | Length [get]


Photon Voice: Member List

Photon Voice v2.30

  • ImageBufferInfo
  • StrideSet
ImageBufferInfo.StrideSet Member List

This is the complete list of members for ImageBufferInfo.StrideSet, including all inherited members.

Length (defined in ImageBufferInfo.StrideSet) | ImageBufferInfo.StrideSet
StrideSet(int length, int s0=0, int s1=0, int s2=0, int s3=0) (defined in ImageBufferInfo.StrideSet) | ImageBufferInfo.StrideSet
this[int key] (defined in ImageBufferInfo.StrideSet) | ImageBufferInfo.StrideSet


Photon Voice: ImageBufferNative Class Reference

Photon Voice v2.30

  • ImageBufferNative
Classes | Public Member Functions | Public Attributes | List of all members
ImageBufferNative Class Reference

Inherited by ImageBufferNativeAlloc, and ImageBufferNativeGCHandleSinglePlane.

Classes

struct PlaneSet

Public Member Functions

ImageBufferNative (ImageBufferInfo info)
ImageBufferNative (IntPtr buf, int width, int height, int stride, ImageFormat imageFormat)
virtual void | Release ()
virtual void | Dispose ()

Public Attributes

ImageBufferInfo | Info
PlaneSet | Planes


Photon Voice: Member List

Photon Voice v2.30

  • ImageBufferNative
ImageBufferNative Member List

This is the complete list of members for ImageBufferNative, including all inherited members.

Dispose() (defined in ImageBufferNative) | ImageBufferNative | virtual
ImageBufferNative(ImageBufferInfo info) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNative(IntPtr buf, int width, int height, int stride, ImageFormat imageFormat) (defined in ImageBufferNative) | ImageBufferNative |
Info (defined in ImageBufferNative) | ImageBufferNative |
Planes (defined in ImageBufferNative) | ImageBufferNative |
Release() (defined in ImageBufferNative) | ImageBufferNative | virtual


Photon Voice: ImageBufferNative.PlaneSet Struct Reference

Photon Voice v2.30

  • ImageBufferNative
  • PlaneSet
Public Member Functions | Properties | List of all members
ImageBufferNative.PlaneSet Struct Reference

Public Member Functions

PlaneSet (int length, IntPtr p0=default(IntPtr), IntPtr p1=default(IntPtr), IntPtr p2=default(IntPtr), IntPtr p3=default(IntPtr))

Properties

IntPtr | this[int key] [get, set]
int | Length [get]


Photon Voice: Member List

Photon Voice v2.30

  • ImageBufferNative
  • PlaneSet
ImageBufferNative.PlaneSet Member List

This is the complete list of members for ImageBufferNative.PlaneSet, including all inherited members.

Length (defined in ImageBufferNative.PlaneSet) | ImageBufferNative.PlaneSet
PlaneSet(int length, IntPtr p0=default(IntPtr), IntPtr p1=default(IntPtr), IntPtr p2=default(IntPtr), IntPtr p3=default(IntPtr)) (defined in ImageBufferNative.PlaneSet) | ImageBufferNative.PlaneSet
this[int key] (defined in ImageBufferNative.PlaneSet) | ImageBufferNative.PlaneSet


Photon Voice: ImageBufferNativeAlloc Class Reference

Photon Voice v2.30

  • ImageBufferNativeAlloc
Public Member Functions | List of all members
ImageBufferNativeAlloc Class Reference

Inherits ImageBufferNative, and IDisposable.

Public Member Functions

ImageBufferNativeAlloc (ImageBufferNativePool< ImageBufferNativeAlloc > pool, ImageBufferInfo info)
override void | Release ()
override void | Dispose ()
- Public Member Functions inherited from ImageBufferNative
ImageBufferNative (ImageBufferInfo info)
ImageBufferNative (IntPtr buf, int width, int height, int stride, ImageFormat imageFormat)

Additional Inherited Members

- Public Attributes inherited from ImageBufferNative
ImageBufferInfo | Info
PlaneSet | Planes


Photon Voice: Member List

Photon Voice v2.30

  • ImageBufferNativeAlloc
ImageBufferNativeAlloc Member List

This is the complete list of members for ImageBufferNativeAlloc, including all inherited members.

Dispose() (defined in ImageBufferNativeAlloc) | ImageBufferNativeAlloc | virtual
ImageBufferNative(ImageBufferInfo info) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNative(IntPtr buf, int width, int height, int stride, ImageFormat imageFormat) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNativeAlloc(ImageBufferNativePool< ImageBufferNativeAlloc > pool, ImageBufferInfo info) (defined in ImageBufferNativeAlloc) | ImageBufferNativeAlloc |
Info (defined in ImageBufferNative) | ImageBufferNative |
Planes (defined in ImageBufferNative) | ImageBufferNative |
Release() (defined in ImageBufferNativeAlloc) | ImageBufferNativeAlloc | virtual


Photon Voice: ImageBufferNativeGCHandleSinglePlane Class Reference

Photon Voice v2.30

  • ImageBufferNativeGCHandleSinglePlane
Public Member Functions | List of all members
ImageBufferNativeGCHandleSinglePlane Class Reference

Inherits ImageBufferNative, and IDisposable.

Public Member Functions

ImageBufferNativeGCHandleSinglePlane (ImageBufferNativePool< ImageBufferNativeGCHandleSinglePlane > pool, ImageBufferInfo info)
void | PinPlane (byte[] plane)
override void | Release ()
override void | Dispose ()
- Public Member Functions inherited from ImageBufferNative
ImageBufferNative (ImageBufferInfo info)
ImageBufferNative (IntPtr buf, int width, int height, int stride, ImageFormat imageFormat)

Additional Inherited Members

- Public Attributes inherited from ImageBufferNative
ImageBufferInfo | Info
PlaneSet | Planes


Photon Voice: Member List

Photon Voice v2.30

  • ImageBufferNativeGCHandleSinglePlane
ImageBufferNativeGCHandleSinglePlane Member List

This is the complete list of members for ImageBufferNativeGCHandleSinglePlane, including all inherited members.

Dispose() (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane | virtual
ImageBufferNative(ImageBufferInfo info) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNative(IntPtr buf, int width, int height, int stride, ImageFormat imageFormat) (defined in ImageBufferNative) | ImageBufferNative |
ImageBufferNativeGCHandleSinglePlane(ImageBufferNativePool< ImageBufferNativeGCHandleSinglePlane > pool, ImageBufferInfo info) (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane |
Info (defined in ImageBufferNative) | ImageBufferNative |
PinPlane(byte[] plane) (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane |
Planes (defined in ImageBufferNative) | ImageBufferNative |
Release() (defined in ImageBufferNativeGCHandleSinglePlane) | ImageBufferNativeGCHandleSinglePlane | virtual


Photon Voice: ImageBufferNativePool< T > Class Template Reference

Photon Voice v2.30

  • ImageBufferNativePool
Public Member Functions | Protected Member Functions | List of all members
ImageBufferNativePool< T > Class Template Reference

Inherits ObjectPool< T, ImageBufferInfo >.

Public Member Functions

delegate T | Factory (ImageBufferNativePool< T > pool, ImageBufferInfo info)
ImageBufferNativePool (int capacity, Factory factory, string name)
ImageBufferNativePool (int capacity, Factory factory, string name, ImageBufferInfo info)
- Public Member Functions inherited from ObjectPool< T, ImageBufferInfo >
ObjectPool (int capacity, string name)
Create a new ObjectPool instance. Does not call Init(). More...
ObjectPool (int capacity, string name, TInfo info)
Create a new ObjectPool instance with the given info structure. Calls Init(). More...
void | Init (TInfo info)
(Re-)Initializes this ObjectPool. More...
TType | AcquireOrCreate ()
Acquire an existing object, or create a new one if none are available. More...
TType | AcquireOrCreate (TInfo info)
Acquire an existing object (if info matches), or create a new one from the passed info. More...
virtual bool | Release (TType obj, TInfo objInfo)
Returns object to pool. More...
virtual bool | Release (TType obj)
Returns object to pool, or destroys it if the pool is full. More...
void | Dispose ()
Free resources assoicated with this ObjectPool More...

Protected Member Functions

override T | createObject (ImageBufferInfo info)
override void | destroyObject (T obj)
override bool | infosMatch (ImageBufferInfo i0, ImageBufferInfo i1)
- Protected Member Functions inherited from ObjectPool< T, ImageBufferInfo >
abstract TType | createObject (TInfo info)
abstract void | destroyObject (TType obj)
abstract bool | infosMatch (TInfo i0, TInfo i1)

Additional Inherited Members

- Protected Attributes inherited from ObjectPool< T, ImageBufferInfo >
int | capacity
TInfo | info
int | pos
string | name
- Properties inherited from ObjectPool< T, ImageBufferInfo >
TInfo | Info [get]
The property (info) that objects in this Pool must match. More...


Photon Voice: Member List

Photon Voice v2.30

  • ImageBufferNativePool
ImageBufferNativePool< T > Member List

This is the complete list of members for ImageBufferNativePool< T >, including all inherited members.

AcquireOrCreate() | ObjectPool< T, ImageBufferInfo > |
AcquireOrCreate(TInfo info) | ObjectPool< T, ImageBufferInfo > |
capacity (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
createObject(ImageBufferInfo info) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > | protected
createObject(TInfo info) (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protectedpure virtual
destroyObject(T obj) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > | protected
destroyObject(TType obj) (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protectedpure virtual
Dispose() | ObjectPool< T, ImageBufferInfo > |
Factory(ImageBufferNativePool< T > pool, ImageBufferInfo info) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > |
ImageBufferNativePool(int capacity, Factory factory, string name) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > |
ImageBufferNativePool(int capacity, Factory factory, string name, ImageBufferInfo info) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > |
info (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
Info | ObjectPool< T, ImageBufferInfo > |
infosMatch(ImageBufferInfo i0, ImageBufferInfo i1) (defined in ImageBufferNativePool< T >) | ImageBufferNativePool< T > | protected
infosMatch(TInfo i0, TInfo i1) (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protectedpure virtual
Init(TInfo info) | ObjectPool< T, ImageBufferInfo > |
name (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
ObjectPool(int capacity, string name) | ObjectPool< T, ImageBufferInfo > |
ObjectPool(int capacity, string name, TInfo info) | ObjectPool< T, ImageBufferInfo > |
pos (defined in ObjectPool< T, ImageBufferInfo >) | ObjectPool< T, ImageBufferInfo > | protected
Release(TType obj, TInfo objInfo) | ObjectPool< T, ImageBufferInfo > | virtual
Release(TType obj) | ObjectPool< T, ImageBufferInfo > | virtual


Photon Voice: IProcessor< T > Interface Template Reference

Photon Voice v2.30

  • IProcessor
Public Member Functions | List of all members
IProcessor< T > Interface Template Reference

Audio Processor interface. More...

Inherits IDisposable.

Inherited by AudioUtil.LevelMeter< T >, AudioUtil.Resampler< T >, AudioUtil.VoiceDetector< T >, AudioUtil.VoiceDetectorCalibration< T >, and AudioUtil.VoiceLevelDetectCalibrate< T >.

Public Member Functions

T[] Process (T[] buf)
Process a frame of audio data. More...

Detailed Description

Audio Processor interface.

Member Function Documentation

◆ Process()

T [] Process ( T[] buf )

Process a frame of audio data.

Parameters
buf Buffer containing input audio data
Returns
Buffer containing output audio data or null if frame has been discarded (VAD)

Implemented in AudioUtil.VoiceLevelDetectCalibrate< T >, AudioUtil.VoiceDetector< T >, AudioUtil.VoiceDetectorCalibration< T >, AudioUtil.LevelMeter< T >, and AudioUtil.Resampler< T >.


Photon Voice: Member List

Photon Voice v2.30

  • IProcessor
IProcessor< T > Member List

This is the complete list of members for IProcessor< T >, including all inherited members.

Process(T[] buf) IProcessor< T >


Photon Voice: IResettable Interface Reference

Photon Voice v2.30

  • IResettable
Public Member Functions | List of all members
IResettable Interface Reference

Inherited by AndroidAudioInAEC.

Public Member Functions

void Reset ()


Photon Voice: Member List

Photon Voice v2.30

  • IResettable
IResettable Member List

This is the complete list of members for IResettable, including all inherited members.

Reset() (defined in IResettable) IResettable


Photon Voice: IServiceable Interface Reference

Photon Voice v2.30

  • IServiceable
Public Member Functions | List of all members
IServiceable Interface Reference

Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice. More...

Inherited by BufferReaderPushAdapterBase< T >.

Public Member Functions

void Service (LocalVoice localVoice)
Service function that should be called regularly. More...

Detailed Description

Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice.

Member Function Documentation

◆ Service()

void Service ( LocalVoice localVoice )

Service function that should be called regularly.

Implemented in BufferReaderPushAdapterAsyncPoolCopy< T >, BufferReaderPushAdapterAsyncPool< T >, BufferReaderPushAdapter< T >, and BufferReaderPushAdapterBase< T >.


Photon Voice: Member List

Photon Voice v2.30

  • IServiceable
IServiceable Member List

This is the complete list of members for IServiceable, including all inherited members.

Service(LocalVoice localVoice) IServiceable


Photon Voice: IVoiceTransport Interface Reference

Photon Voice v2.30

  • IVoiceTransport
Public Member Functions | List of all members
IVoiceTransport Interface Reference

Inherited by LoadBalancingTransport.

Public Member Functions

bool | IsChannelJoined (int channelId)
void | SendVoicesInfo (IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId)
void | SendVoiceRemove (LocalVoice voice, int channelId, int targetPlayerId)
void | SendFrame (ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice)
string | ChannelIdStr (int channelId)
string | PlayerIdStr (int playerId)


Photon Voice: Member List

Photon Voice v2.30

  • IVoiceTransport
IVoiceTransport Member List

This is the complete list of members for IVoiceTransport, including all inherited members.

ChannelIdStr(int channelId) (defined in IVoiceTransport) | IVoiceTransport
IsChannelJoined(int channelId) (defined in IVoiceTransport) | IVoiceTransport
PlayerIdStr(int playerId) (defined in IVoiceTransport) | IVoiceTransport
SendFrame(ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice) (defined in IVoiceTransport) | IVoiceTransport
SendVoiceRemove(LocalVoice voice, int channelId, int targetPlayerId) (defined in IVoiceTransport) | IVoiceTransport
SendVoicesInfo(IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId) (defined in IVoiceTransport) | IVoiceTransport


Photon Voice: LoadBalancingFrontend Class Reference

Photon Voice v2.30

  • LoadBalancingFrontend
List of all members
LoadBalancingFrontend Class Reference

Inherits LoadBalancingTransport.

Additional Inherited Members

- Public Member Functions inherited from LoadBalancingTransport
void | LogError (string fmt, params object[] args)
void | LogWarning (string fmt, params object[] args)
void | LogInfo (string fmt, params object[] args)
void | LogDebug (string fmt, params object[] args)
bool | IsChannelJoined (int channelId)
LoadBalancingTransport (ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp)
Initializes a new LoadBalancingTransport. More...
new void | Service ()
This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2 to 20 times a second). More...
virtual bool | ChangeAudioGroups (byte[] groupsToRemove, byte[] groupsToAdd)
void | SendVoicesInfo (IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId)
void | SendVoiceRemove (LocalVoice voice, int channelId, int targetPlayerId)
virtual void | SendFrame (ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice)
string | ChannelIdStr (int channelId)
string | PlayerIdStr (int playerId)
void | Dispose ()
Releases all resources used by the LoadBalancingTransport instance. More...
- Protected Member Functions inherited from LoadBalancingTransport
virtual void | onEventActionVoiceClient (EventData ev)
- Protected Attributes inherited from LoadBalancingTransport
VoiceClient | voiceClient
- Properties inherited from LoadBalancingTransport
VoiceClient | VoiceClient [get]
The VoiceClient implementation associated with this LoadBalancingTransport. More...
byte | GlobalAudioGroup [get, set]
byte | GlobalInterestGroup [get, set]
Set global interest group for this client. This call sets InterestGroup for existing local voices and for created later to given value. Client set as listening to this group only until LoadBalancingPeer.OpChangeGroups() called. This method can be called any time. More...


Photon Voice: Member List

Photon Voice v2.30

  • LoadBalancingFrontend
LoadBalancingFrontend Member List

This is the complete list of members for LoadBalancingFrontend, including all inherited members.

ChangeAudioGroups(byte[] groupsToRemove, byte[] groupsToAdd) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
ChannelIdStr(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Dispose() | LoadBalancingTransport |
GlobalAudioGroup (defined in LoadBalancingTransport) | LoadBalancingTransport |
GlobalInterestGroup | LoadBalancingTransport |
IsChannelJoined(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LoadBalancingTransport(ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp) | LoadBalancingTransport |
LogDebug(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogError(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogInfo(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogWarning(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
onEventActionVoiceClient(EventData ev) (defined in LoadBalancingTransport) | LoadBalancingTransport | protectedvirtual
PlayerIdStr(int playerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendFrame(ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
SendVoiceRemove(LocalVoice voice, int channelId, int targetPlayerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendVoicesInfo(IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Service() | LoadBalancingTransport |
voiceClient (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
VoiceClient | LoadBalancingTransport |


Photon Voice: LoadBalancingTransport Class Reference

Photon Voice v2.30

  • LoadBalancingTransport
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
LoadBalancingTransport Class Reference

Extends LoadBalancingClient with media streaming functionality. More...

Inherits LoadBalancingClient, IVoiceTransport, ILogger, and IDisposable.

Inherited by LoadBalancingFrontend, and LoadBalancingTransport2.

Public Member Functions

void | LogError (string fmt, params object[] args)
void | LogWarning (string fmt, params object[] args)
void | LogInfo (string fmt, params object[] args)
void | LogDebug (string fmt, params object[] args)
bool | IsChannelJoined (int channelId)
LoadBalancingTransport (ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp)
Initializes a new LoadBalancingTransport. More...
new void | Service ()
This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2 to 20 times a second). More...
virtual bool | ChangeAudioGroups (byte[] groupsToRemove, byte[] groupsToAdd)
void | SendVoicesInfo (IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId)
void | SendVoiceRemove (LocalVoice voice, int channelId, int targetPlayerId)
virtual void | SendFrame (ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice)
string | ChannelIdStr (int channelId)
string | PlayerIdStr (int playerId)
void | Dispose ()
Releases all resources used by the LoadBalancingTransport instance. More...

Protected Member Functions

virtual void onEventActionVoiceClient (EventData ev)

Protected Attributes

VoiceClient voiceClient

Properties

VoiceClient | VoiceClient [get]
The VoiceClient implementation associated with this LoadBalancingTransport. More...
byte | GlobalAudioGroup [get, set]
byte | GlobalInterestGroup [get, set]
Set global interest group for this client. This call sets InterestGroup for existing local voices and for created later to given value. Client set as listening to this group only until LoadBalancingPeer.OpChangeGroups() called. This method can be called any time. More...

Detailed Description

Extends LoadBalancingClient with media streaming functionality.

Use your normal LoadBalancing workflow to join a Voice room. All standard LoadBalancing features are available. Use VoiceClient to work with media streams.

Constructor & Destructor Documentation

◆ LoadBalancingTransport()

LoadBalancingTransport | ( | ILogger | logger = null,
 |  | ConnectionProtocol | connectionProtocol = ConnectionProtocol.Udp
 | ) |  |

Initializes a new LoadBalancingTransport.

Parameters
logger | ILogger instance. If null, this instance LoadBalancingClient.DebugReturn implementation is used.ConnectionProtocol
connectionProtocol | Connection protocol (UDP or TCP). ConnectionProtocol

Member Function Documentation

◆ Dispose()

void Dispose ( )

Releases all resources used by the LoadBalancingTransport instance.

◆ Service()

new void Service ( )

This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2 to 20 times a second).

Property Documentation

◆ GlobalInterestGroup

byte GlobalInterestGroup
getset

Set global interest group for this client. This call sets InterestGroup for existing local voices and for created later to given value. Client set as listening to this group only until LoadBalancingPeer.OpChangeGroups() called. This method can be called any time.

LocalVoice.InterestGroup LoadBalancingPeer.OpChangeGroups(byte[], byte[])

◆ VoiceClient

VoiceClient VoiceClient
get

The VoiceClient implementation associated with this LoadBalancingTransport.


Photon Voice: LoadBalancingTransport2 Class Reference

Photon Voice v2.30

  • LoadBalancingTransport2
Public Member Functions | Protected Member Functions | List of all members
LoadBalancingTransport2 Class Reference

Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients. More...

Inherits LoadBalancingTransport.

Public Member Functions

LoadBalancingTransport2 (ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp)
override void | SendFrame (ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice)
- Public Member Functions inherited from LoadBalancingTransport
void | LogError (string fmt, params object[] args)
void | LogWarning (string fmt, params object[] args)
void | LogInfo (string fmt, params object[] args)
void | LogDebug (string fmt, params object[] args)
bool | IsChannelJoined (int channelId)
LoadBalancingTransport (ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp)
Initializes a new LoadBalancingTransport. More...
new void | Service ()
This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2 to 20 times a second). More...
virtual bool | ChangeAudioGroups (byte[] groupsToRemove, byte[] groupsToAdd)
void | SendVoicesInfo (IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId)
void | SendVoiceRemove (LocalVoice voice, int channelId, int targetPlayerId)
string | ChannelIdStr (int channelId)
string | PlayerIdStr (int playerId)
void | Dispose ()
Releases all resources used by the LoadBalancingTransport instance. More...

Protected Member Functions

override void onEventActionVoiceClient (EventData ev)

Additional Inherited Members

- Protected Attributes inherited from LoadBalancingTransport
VoiceClient | voiceClient
- Properties inherited from LoadBalancingTransport
VoiceClient | VoiceClient [get]
The VoiceClient implementation associated with this LoadBalancingTransport. More...
byte | GlobalAudioGroup [get, set]
byte | GlobalInterestGroup [get, set]
Set global interest group for this client. This call sets InterestGroup for existing local voices and for created later to given value. Client set as listening to this group only until LoadBalancingPeer.OpChangeGroups() called. This method can be called any time. More...

Detailed Description

Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients.


Photon Voice: Member List

Photon Voice v2.30

  • LoadBalancingTransport2
LoadBalancingTransport2 Member List

This is the complete list of members for LoadBalancingTransport2, including all inherited members.

ChangeAudioGroups(byte[] groupsToRemove, byte[] groupsToAdd) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
ChannelIdStr(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Dispose() | LoadBalancingTransport |
GlobalAudioGroup (defined in LoadBalancingTransport) | LoadBalancingTransport |
GlobalInterestGroup | LoadBalancingTransport |
IsChannelJoined(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LoadBalancingTransport(ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp) | LoadBalancingTransport |
LoadBalancingTransport2(ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp) (defined in LoadBalancingTransport2) | LoadBalancingTransport2 |
LogDebug(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogError(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogInfo(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogWarning(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
onEventActionVoiceClient(EventData ev) (defined in LoadBalancingTransport2) | LoadBalancingTransport2 | protectedvirtual
PlayerIdStr(int playerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendFrame(ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice) (defined in LoadBalancingTransport2) | LoadBalancingTransport2 | virtual
SendVoiceRemove(LocalVoice voice, int channelId, int targetPlayerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendVoicesInfo(IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Service() | LoadBalancingTransport |
voiceClient (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
VoiceClient | LoadBalancingTransport |


Photon Voice: LocalVoice Class Reference

Photon Voice v2.30

  • LocalVoice
Public Member Functions | Static Public Attributes | Protected Attributes | Properties | List of all members
LocalVoice Class Reference

Represents outgoing data stream. More...

Inherits IDisposable.

Inherited by LocalVoiceAudioDummy, and LocalVoiceFramedBase.

Public Member Functions

void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...
virtual void | Dispose ()

Static Public Attributes

const int DATA_POOL_CAPACITY = 50

Protected Attributes

VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()

Properties

byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, voice's data is sent only to clients listening to this group (if supported by transport). More...
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. More...
bool | Encrypt [get, set]
Send data encrypted. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. Can be swithed any time. OnRemoteVoiceInfoAction and OnRemoteVoiceRemoveAction are triggered if required. This functionality availability depends on transport. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]

Detailed Description

Represents outgoing data stream.

Member Function Documentation

◆ RemoveSelf()

void RemoveSelf ( )

Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice

Property Documentation

◆ DebugEchoMode

bool DebugEchoMode
getset

If true, outgoing stream routed back to client via server same way as for remote client's streams. Can be swithed any time. OnRemoteVoiceInfoAction and OnRemoteVoiceRemoveAction are triggered if required. This functionality availability depends on transport.

◆ Encrypt

bool Encrypt
getset

Send data encrypted.

◆ FramesSent

int FramesSent
get

Sent frames counter.

◆ FramesSentBytes

int FramesSentBytes
get

Sent frames bytes counter.

◆ Info

VoiceInfo Info
get

Returns Info structure assigned on local voice cration.

◆ InterestGroup

byte InterestGroup
getset

If InterestGroup != 0, voice's data is sent only to clients listening to this group (if supported by transport).

◆ IsCurrentlyTransmitting

bool IsCurrentlyTransmitting
get

Returns true if stream broadcasts.

◆ LocalUserServiceable

IServiceable LocalUserServiceable
getset

Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call.

◆ Reliable

bool Reliable
getset

Send data reliable.

◆ SendSpacingProfileMax

int SendSpacingProfileMax
get

Logs input frames time spacing profiling results. Do not call frequently.

◆ TransmitEnabled

bool TransmitEnabled
getset

If true, stream data broadcasted.


Photon Voice: Member List

Photon Voice v2.30

  • LocalVoice
LocalVoice Member List

This is the complete list of members for LocalVoice, including all inherited members.

configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() (defined in LocalVoice) | LocalVoice | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
Info | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
LocalUserServiceable | LocalVoice |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
Reliable | LocalVoice |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
shortName (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected


Photon Voice: LocalVoiceAudio< T > Class Template Reference

Photon Voice v2.30

  • LocalVoiceAudio
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
LocalVoiceAudio< T > Class Template Reference

Outgoing audio stream. More...

Inherits LocalVoiceFramed< T >, and ILocalVoiceAudio.

Public Member Functions

void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Public Member Functions inherited from LocalVoiceFramed< T >
void | AddPostProcessor (params IProcessor< T >[] processors)
Adds processors after any built-in processors and everything added with AddPreProcessor. More...
void | AddPreProcessor (params IProcessor< T >[] processors)
Adds processors before built-in processors and everything added with AddPostProcessor. More...
void | ClearProcessors ()
Clears all processors in pipeline including built-in resampling. User should add at least resampler processor after call. More...
void | PushDataAsync (T[] buf)
Asynchronously push data into this stream. More...
void | PushData (T[] buf)
Synchronously push data into this stream. More...
override void | Dispose ()
Releases resources used by the LocalVoiceFramed<T> instance. Buffers used for asynchronous push will be disposed in encoder thread's 'finally'. More...
- Public Member Functions inherited from LocalVoice
void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...

Static Public Member Functions

static LocalVoiceAudio< T > Create (VoiceClient voiceClient, byte voiceId, IEncoder encoder, VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId)
Create a new LocalVoiceAudio{T} instance. More...

Protected Member Functions

void | initBuiltinProcessors ()
- Protected Member Functions inherited from LocalVoiceFramed< T >
T[] | processFrame (T[] buf)

Protected Attributes

AudioUtil.VoiceDetector< T > | voiceDetector
AudioUtil.VoiceDetectorCalibration< T > | voiceDetectorCalibration
AudioUtil.LevelMeter< T > | levelMeter
int | channels
bool | resampleSource
- Protected Attributes inherited from LocalVoice
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()

Properties

virtual AudioUtil.IVoiceDetector | VoiceDetector [get]
virtual AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
True if the VoiceDetector is currently calibrating. More...
- Properties inherited from LocalVoiceFramed< T >
FactoryPrimitiveArrayPool< T > | BufferFactory [get]
bool | PushDataAsyncReady [get]
Wether this LocalVoiceFramed has capacity for more data buffers to be pushed asynchronously. More...
- Properties inherited from LocalVoiceFramedBase
int | FrameSize [get]
Data flow will be repacked to frames of this size. May differ from input voiceInfo.FrameSize. Processors should resample in this case. More...
- Properties inherited from LocalVoice
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, voice's data is sent only to clients listening to this group (if supported by transport). More...
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. More...
bool | Encrypt [get, set]
Send data encrypted. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. Can be swithed any time. OnRemoteVoiceInfoAction and OnRemoteVoiceRemoveAction are triggered if required. This functionality availability depends on transport. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]
- Properties inherited from ILocalVoiceAudio
AudioUtil.IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use. More...
AudioUtil.ILevelMeter | LevelMeter [get]
The LevelMeter utility in use. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...

Additional Inherited Members

- Static Public Attributes inherited from LocalVoice
const int DATA_POOL_CAPACITY = 50

Detailed Description

Outgoing audio stream.

Member Function Documentation

◆ Create()

static LocalVoiceAudio<T> Create | ( | VoiceClient | voiceClient,
 |  | byte | voiceId,
 |  | IEncoder | encoder,
 |  | VoiceInfo | voiceInfo,
 |  | IAudioDesc | audioSourceDesc,
 |  | int | channelId
 | ) |  |
static

Create a new LocalVoiceAudio{T} instance.

Parameters
voiceClient | The VoiceClient to use for this outgoing stream.
voiceId | Numeric ID for this voice.
encoder | Encoder to use for this voice.
voiceInfo | Outgoing stream parameters.
audioSourceDesc | Audio source parameters.
channelId | Voice transport channel ID to use for this voice.
Returns
The new LocalVoiceAudio{T} instance.

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Trigger voice detector calibration process.

While calibrating, keep silence. Voice detector sets threshold basing on measured backgroud noise level.

Parameters
durationMs | Duration of calibration in milliseconds.
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

Implements ILocalVoiceAudio.

Property Documentation

◆ VoiceDetectorCalibrating

bool VoiceDetectorCalibrating
get

True if the VoiceDetector is currently calibrating.


Photon Voice: Member List

Photon Voice v2.30

  • LocalVoiceAudio
LocalVoiceAudio< T > Member List

This is the complete list of members for LocalVoiceAudio< T >, including all inherited members.

AddPostProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
AddPreProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
BufferFactory (defined in LocalVoiceFramed< T >) | LocalVoiceFramed< T > |
channels (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
ClearProcessors() | LocalVoiceFramed< T > |
configFrame (defined in LocalVoice) | LocalVoice | protected
Create(VoiceClient voiceClient, byte voiceId, IEncoder encoder, VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId) | LocalVoiceAudio< T > | static
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() | LocalVoiceFramed< T > | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FrameSize | LocalVoiceFramedBase |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
Info | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
initBuiltinProcessors() (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
levelMeter (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
LevelMeter (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > |
LocalUserServiceable | LocalVoice |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
processFrame(T[] buf) (defined in LocalVoiceFramed< T >) | LocalVoiceFramed< T > | protected
PushData(T[] buf) | LocalVoiceFramed< T > |
PushDataAsync(T[] buf) | LocalVoiceFramed< T > |
PushDataAsyncReady | LocalVoiceFramed< T > |
Reliable | LocalVoice |
RemoveSelf() | LocalVoice |
resampleSource (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
shortName (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected
VoiceDetector (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > |
voiceDetector (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudio< T > |
VoiceDetectorCalibrating | LocalVoiceAudio< T > |
voiceDetectorCalibration (defined in LocalVoiceAudio< T >) | LocalVoiceAudio< T > | protected


Photon Voice: LocalVoiceAudioDummy Class Reference

Photon Voice v2.30

  • LocalVoiceAudioDummy
Public Member Functions | Static Public Attributes | Properties | List of all members
LocalVoiceAudioDummy Class Reference

Dummy LocalVoiceAudio More...

Inherits LocalVoice, and ILocalVoiceAudio.

Public Member Functions

void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Public Member Functions inherited from LocalVoice
void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...
virtual void | Dispose ()

Static Public Attributes

static LocalVoiceAudioDummy | Dummy = new LocalVoiceAudioDummy()
A Dummy LocalVoiceAudio instance. More...
- Static Public Attributes inherited from LocalVoice
const int | DATA_POOL_CAPACITY = 50

Properties

AudioUtil.IVoiceDetector | VoiceDetector [get]
AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
- Properties inherited from LocalVoice
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, voice's data is sent only to clients listening to this group (if supported by transport). More...
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. More...
bool | Encrypt [get, set]
Send data encrypted. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. Can be swithed any time. OnRemoteVoiceInfoAction and OnRemoteVoiceRemoveAction are triggered if required. This functionality availability depends on transport. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]
- Properties inherited from ILocalVoiceAudio
AudioUtil.IVoiceDetector | VoiceDetector [get]
The VoiceDetector in use. More...
AudioUtil.ILevelMeter | LevelMeter [get]
The LevelMeter utility in use. More...
bool | VoiceDetectorCalibrating [get]
If true, voice detector calibration is in progress. More...

Additional Inherited Members

- Protected Attributes inherited from LocalVoice
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()

Detailed Description

Dummy LocalVoiceAudio

For testing, this LocalVoiceAudio implementation features a AudioUtil.VoiceDetectorDummy and a AudioUtil.LevelMeterDummy

Member Function Documentation

◆ VoiceDetectorCalibrate()

void VoiceDetectorCalibrate | ( | int | durationMs,
 |  | Action< float > | onCalibrated = null
 | ) |  |

Trigger voice detector calibration process.

While calibrating, keep silence. Voice detector sets threshold based on measured backgroud noise level.

Parameters
durationMs | Duration of calibration (in milliseconds).
onCalibrated | Called when calibration is complete. Parameter is new threshold value.

Implements ILocalVoiceAudio.

Member Data Documentation

◆ Dummy

LocalVoiceAudioDummy Dummy = new LocalVoiceAudioDummy()
static

A Dummy LocalVoiceAudio instance.


Photon Voice: Member List

Photon Voice v2.30

  • LocalVoiceAudioDummy
LocalVoiceAudioDummy Member List

This is the complete list of members for LocalVoiceAudioDummy, including all inherited members.

configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() (defined in LocalVoice) | LocalVoice | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
Dummy | LocalVoiceAudioDummy | static
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
Info | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
LevelMeter (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |
LocalUserServiceable | LocalVoice |
LocalVoiceAudioDummy() (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
Reliable | LocalVoice |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
shortName (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected
VoiceDetector (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudioDummy |
VoiceDetectorCalibrating (defined in LocalVoiceAudioDummy) | LocalVoiceAudioDummy |


Photon Voice: LocalVoiceAudioFloat Class Reference

Photon Voice v2.30

  • LocalVoiceAudioFloat
List of all members
LocalVoiceAudioFloat Class Reference

Specialization of LocalVoiceAudio<T> for float audio More...

Inherits LocalVoiceAudio< float >.

Additional Inherited Members

- Public Member Functions inherited from LocalVoiceAudio< float >
void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Static Public Member Functions inherited from LocalVoiceAudio< float >
static LocalVoiceAudio< T > | Create (VoiceClient voiceClient, byte voiceId, IEncoder encoder, VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId)
Create a new LocalVoiceAudio{T} instance. More...
- Protected Member Functions inherited from LocalVoiceAudio< float >
void | initBuiltinProcessors ()
- Protected Attributes inherited from LocalVoiceAudio< float >
AudioUtil.VoiceDetector< T > | voiceDetector
AudioUtil.VoiceDetectorCalibration< T > | voiceDetectorCalibration
AudioUtil.LevelMeter< T > | levelMeter
int | channels
bool | resampleSource
- Properties inherited from LocalVoiceAudio< float >
virtual AudioUtil.IVoiceDetector | VoiceDetector [get]
virtual AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
True if the VoiceDetector is currently calibrating. More...

Detailed Description

Specialization of LocalVoiceAudio<T> for float audio


Photon Voice: Member List

Photon Voice v2.30

  • LocalVoiceAudioFloat
LocalVoiceAudioFloat Member List

This is the complete list of members for LocalVoiceAudioFloat, including all inherited members.

channels (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
Create(VoiceClient voiceClient, byte voiceId, IEncoder encoder, VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId) | LocalVoiceAudio< float > | static
initBuiltinProcessors() (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
LevelMeter (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > |
levelMeter (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
resampleSource (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
VoiceDetector (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > |
voiceDetector (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudio< float > |
VoiceDetectorCalibrating | LocalVoiceAudio< float > |
voiceDetectorCalibration (defined in LocalVoiceAudio< float >) | LocalVoiceAudio< float > | protected


Photon Voice: LocalVoiceAudioShort Class Reference

Photon Voice v2.30

  • LocalVoiceAudioShort
List of all members
LocalVoiceAudioShort Class Reference

Specialization of LocalVoiceAudio<T> for short audio More...

Inherits LocalVoiceAudio< short >.

Additional Inherited Members

- Public Member Functions inherited from LocalVoiceAudio< short >
void | VoiceDetectorCalibrate (int durationMs, Action< float > onCalibrated=null)
Trigger voice detector calibration process. More...
- Static Public Member Functions inherited from LocalVoiceAudio< short >
static LocalVoiceAudio< T > | Create (VoiceClient voiceClient, byte voiceId, IEncoder encoder, VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId)
Create a new LocalVoiceAudio{T} instance. More...
- Protected Member Functions inherited from LocalVoiceAudio< short >
void | initBuiltinProcessors ()
- Protected Attributes inherited from LocalVoiceAudio< short >
AudioUtil.VoiceDetector< T > | voiceDetector
AudioUtil.VoiceDetectorCalibration< T > | voiceDetectorCalibration
AudioUtil.LevelMeter< T > | levelMeter
int | channels
bool | resampleSource
- Properties inherited from LocalVoiceAudio< short >
virtual AudioUtil.IVoiceDetector | VoiceDetector [get]
virtual AudioUtil.ILevelMeter | LevelMeter [get]
bool | VoiceDetectorCalibrating [get]
True if the VoiceDetector is currently calibrating. More...

Detailed Description

Specialization of LocalVoiceAudio<T> for short audio


Photon Voice: Member List

Photon Voice v2.30

  • LocalVoiceAudioShort
LocalVoiceAudioShort Member List

This is the complete list of members for LocalVoiceAudioShort, including all inherited members.

channels (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
Create(VoiceClient voiceClient, byte voiceId, IEncoder encoder, VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, int channelId) | LocalVoiceAudio< short > | static
initBuiltinProcessors() (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
LevelMeter (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > |
levelMeter (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
resampleSource (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
VoiceDetector (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > |
voiceDetector (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected
VoiceDetectorCalibrate(int durationMs, Action< float > onCalibrated=null) | LocalVoiceAudio< short > |
VoiceDetectorCalibrating | LocalVoiceAudio< short > |
voiceDetectorCalibration (defined in LocalVoiceAudio< short >) | LocalVoiceAudio< short > | protected


Photon Voice: LocalVoiceFramed< T > Class Template Reference

Photon Voice v2.30

  • LocalVoiceFramed
Public Member Functions | Protected Member Functions | Properties | List of all members
LocalVoiceFramed< T > Class Template Reference

Typed re-framing LocalVoice More...

Inherits LocalVoiceFramedBase.

Inherited by LocalVoiceAudio< T >.

Public Member Functions

void | AddPostProcessor (params IProcessor< T >[] processors)
Adds processors after any built-in processors and everything added with AddPreProcessor. More...
void | AddPreProcessor (params IProcessor< T >[] processors)
Adds processors before built-in processors and everything added with AddPostProcessor. More...
void | ClearProcessors ()
Clears all processors in pipeline including built-in resampling. User should add at least resampler processor after call. More...
void | PushDataAsync (T[] buf)
Asynchronously push data into this stream. More...
void | PushData (T[] buf)
Synchronously push data into this stream. More...
override void | Dispose ()
Releases resources used by the LocalVoiceFramed<T> instance. Buffers used for asynchronous push will be disposed in encoder thread's 'finally'. More...
- Public Member Functions inherited from LocalVoice
void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...

Protected Member Functions

T[] processFrame (T[] buf)

Properties

FactoryPrimitiveArrayPool< T > | BufferFactory [get]
bool | PushDataAsyncReady [get]
Wether this LocalVoiceFramed has capacity for more data buffers to be pushed asynchronously. More...
- Properties inherited from LocalVoiceFramedBase
int | FrameSize [get]
Data flow will be repacked to frames of this size. May differ from input voiceInfo.FrameSize. Processors should resample in this case. More...
- Properties inherited from LocalVoice
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, voice's data is sent only to clients listening to this group (if supported by transport). More...
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. More...
bool | Encrypt [get, set]
Send data encrypted. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. Can be swithed any time. OnRemoteVoiceInfoAction and OnRemoteVoiceRemoveAction are triggered if required. This functionality availability depends on transport. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]

Additional Inherited Members

- Static Public Attributes inherited from LocalVoice
const int | DATA_POOL_CAPACITY = 50
- Protected Attributes inherited from LocalVoice
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()

Detailed Description

Typed re-framing LocalVoice

Consumes data in array buffers of arbitrary length. Repacks them in frames of constant length for further processing and encoding.

Member Function Documentation

◆ AddPostProcessor()

void AddPostProcessor ( params IProcessor< T >[] processors )

Adds processors after any built-in processors and everything added with AddPreProcessor.

Parameters
processors

◆ AddPreProcessor()

void AddPreProcessor ( params IProcessor< T >[] processors )

Adds processors before built-in processors and everything added with AddPostProcessor.

Parameters
processors

◆ ClearProcessors()

void ClearProcessors ( )

Clears all processors in pipeline including built-in resampling. User should add at least resampler processor after call.

◆ Dispose()

override void Dispose ( )
virtual

Releases resources used by the LocalVoiceFramed<T> instance. Buffers used for asynchronous push will be disposed in encoder thread's 'finally'.

Reimplemented from LocalVoice.

◆ PushData()

void PushData ( T[] buf )

Synchronously push data into this stream.

◆ PushDataAsync()

void PushDataAsync ( T[] buf )

Asynchronously push data into this stream.

Property Documentation

◆ PushDataAsyncReady

bool PushDataAsyncReady
get

Wether this LocalVoiceFramed has capacity for more data buffers to be pushed asynchronously.


Photon Voice: Member List

Photon Voice v2.30

  • LocalVoiceFramed
LocalVoiceFramed< T > Member List

This is the complete list of members for LocalVoiceFramed< T >, including all inherited members.

AddPostProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
AddPreProcessor(params IProcessor< T >[] processors) | LocalVoiceFramed< T > |
BufferFactory (defined in LocalVoiceFramed< T >) | LocalVoiceFramed< T > |
ClearProcessors() | LocalVoiceFramed< T > |
configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() | LocalVoiceFramed< T > | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FrameSize | LocalVoiceFramedBase |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
Info | LocalVoice |
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
LocalUserServiceable | LocalVoice |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
processFrame(T[] buf) (defined in LocalVoiceFramed< T >) | LocalVoiceFramed< T > | protected
PushData(T[] buf) | LocalVoiceFramed< T > |
PushDataAsync(T[] buf) | LocalVoiceFramed< T > |
PushDataAsyncReady | LocalVoiceFramed< T > |
Reliable | LocalVoice |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
shortName (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected


Photon Voice: LocalVoiceFramedBase Class Reference

Photon Voice v2.30

  • LocalVoiceFramedBase
Properties | List of all members
LocalVoiceFramedBase Class Reference

Typed re-framing LocalVoice More...

Inherits LocalVoice.

Inherited by LocalVoiceFramed< T >.

Properties

int | FrameSize [get]
Data flow will be repacked to frames of this size. May differ from input voiceInfo.FrameSize. Processors should resample in this case. More...
- Properties inherited from LocalVoice
byte | Group [get, set]
byte | InterestGroup [get, set]
If InterestGroup != 0, voice's data is sent only to clients listening to this group (if supported by transport). More...
VoiceInfo | Info [get]
Returns Info structure assigned on local voice cration. More...
bool | TransmitEnabled [get, set]
If true, stream data broadcasted. More...
bool | IsCurrentlyTransmitting [get]
Returns true if stream broadcasts. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
bool | Reliable [get, set]
Send data reliable. More...
bool | Encrypt [get, set]
Send data encrypted. More...
IServiceable | LocalUserServiceable [get, set]
Optional user object attached to LocalVoice. its Service() will be called at each VoiceClient.Service() call. More...
bool | DebugEchoMode [get, set]
If true, outgoing stream routed back to client via server same way as for remote client's streams. Can be swithed any time. OnRemoteVoiceInfoAction and OnRemoteVoiceRemoveAction are triggered if required. This functionality availability depends on transport. More...
string | SendSpacingProfileDump [get]
int | SendSpacingProfileMax [get]
Logs input frames time spacing profiling results. Do not call frequently. More...
byte | ID [get]
byte | EvNumber [get]
string | shortName [get]
string | Name [get]
string | LogPrefix [get]

Additional Inherited Members

- Public Member Functions inherited from LocalVoice
void | SendSpacingProfileStart ()
void | RemoveSelf ()
Remove this voice from it's VoiceClient (using VoiceClient.RemoveLocalVoice More...
virtual void | Dispose ()
- Static Public Attributes inherited from LocalVoice
const int | DATA_POOL_CAPACITY = 50
- Protected Attributes inherited from LocalVoice
VoiceInfo | info
IEncoder | encoder
VoiceClient | voiceClient
ArraySegment< byte > | configFrame
volatile bool | disposed
object | disposeLock = new object()

Detailed Description

Typed re-framing LocalVoice

Base class for typed re-framing LocalVoice implementation (LocalVoiceFramed<T>)

Property Documentation

◆ FrameSize

int FrameSize
get

Data flow will be repacked to frames of this size. May differ from input voiceInfo.FrameSize. Processors should resample in this case.


Photon Voice: Member List

Photon Voice v2.30

  • LocalVoiceFramedBase
LocalVoiceFramedBase Member List

This is the complete list of members for LocalVoiceFramedBase, including all inherited members.

configFrame (defined in LocalVoice) | LocalVoice | protected
DATA_POOL_CAPACITY (defined in LocalVoice) | LocalVoice | static
DebugEchoMode | LocalVoice |
Dispose() (defined in LocalVoice) | LocalVoice | virtual
disposed (defined in LocalVoice) | LocalVoice | protected
disposeLock (defined in LocalVoice) | LocalVoice | protected
encoder (defined in LocalVoice) | LocalVoice | protected
Encrypt | LocalVoice |
EvNumber (defined in LocalVoice) | LocalVoice |
FrameSize | LocalVoiceFramedBase |
FramesSent | LocalVoice |
FramesSentBytes | LocalVoice |
Group (defined in LocalVoice) | LocalVoice |
ID (defined in LocalVoice) | LocalVoice |
info (defined in LocalVoice) | LocalVoice | protected
Info | LocalVoice |
InterestGroup | LocalVoice |
IsCurrentlyTransmitting | LocalVoice |
LocalUserServiceable | LocalVoice |
LogPrefix (defined in LocalVoice) | LocalVoice |
Name (defined in LocalVoice) | LocalVoice |
Reliable | LocalVoice |
RemoveSelf() | LocalVoice |
SendSpacingProfileDump (defined in LocalVoice) | LocalVoice |
SendSpacingProfileMax | LocalVoice |
SendSpacingProfileStart() (defined in LocalVoice) | LocalVoice |
shortName (defined in LocalVoice) | LocalVoice | protected
TransmitEnabled | LocalVoice |
voiceClient (defined in LocalVoice) | LocalVoice | protected


Photon Voice: ObjectFactory< TType, TInfo > Interface Template Reference

Photon Voice v2.30

  • ObjectFactory
Public Member Functions | Properties | List of all members
ObjectFactory< TType, TInfo > Interface Template Reference

Uniform interface to ObjectPool<TType, TInfo> and single reusable object. More...

Inherits IDisposable.

Public Member Functions

TType | New ()
TType | New (TInfo info)
void | Free (TType obj)
void | Free (TType obj, TInfo info)

Properties

TInfo Info [get]

Detailed Description

Uniform interface to ObjectPool<TType, TInfo> and single reusable object.

Template Parameters
TType | Object type.
TInfo | Type of property used to check 2 objects identity (like integral length of array).


Photon Voice: Member List

Photon Voice v2.30

  • ObjectFactory
ObjectFactory< TType, TInfo > Member List

This is the complete list of members for ObjectFactory< TType, TInfo >, including all inherited members.

Free(TType obj) (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
Free(TType obj, TInfo info) (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
Info (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
New() (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >
New(TInfo info) (defined in ObjectFactory< TType, TInfo >) | ObjectFactory< TType, TInfo >


Photon Voice: ObjectPool< TType, TInfo > Class Template Reference

Photon Voice v2.30

  • ObjectPool
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
ObjectPool< TType, TInfo > Class Template Referenceabstract

Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo). More...

Inherits IDisposable.

Public Member Functions

ObjectPool (int capacity, string name)
Create a new ObjectPool instance. Does not call Init(). More...
ObjectPool (int capacity, string name, TInfo info)
Create a new ObjectPool instance with the given info structure. Calls Init(). More...
void | Init (TInfo info)
(Re-)Initializes this ObjectPool. More...
TType | AcquireOrCreate ()
Acquire an existing object, or create a new one if none are available. More...
TType | AcquireOrCreate (TInfo info)
Acquire an existing object (if info matches), or create a new one from the passed info. More...
virtual bool | Release (TType obj, TInfo objInfo)
Returns object to pool. More...
virtual bool | Release (TType obj)
Returns object to pool, or destroys it if the pool is full. More...
void | Dispose ()
Free resources assoicated with this ObjectPool More...

Protected Member Functions

abstract TType | createObject (TInfo info)
abstract void | destroyObject (TType obj)
abstract bool | infosMatch (TInfo i0, TInfo i1)

Protected Attributes

int | capacity
TInfo | info
int | pos
string | name

Properties

TInfo Info [get]
The property (info) that objects in this Pool must match. More...

Detailed Description

Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo).

Template Parameters
TType | Object type.
TInfo | Type of parameter used to check 2 objects identity (like integral length of array).

Constructor & Destructor Documentation

◆ ObjectPool() [1/2]

ObjectPool | ( | int | capacity,
 |  | string | name
 | ) |  |

Create a new ObjectPool instance. Does not call Init().

Parameters
capacity | Capacity (size) of the object pool.
name | Name of the object pool.

◆ ObjectPool() [2/2]

ObjectPool | ( | int | capacity,
 |  | string | name,
 |  | TInfo | info
 | ) |  |

Create a new ObjectPool instance with the given info structure. Calls Init().

Parameters
capacity | Capacity (size) of the object pool.
name | Name of the object pool.
info | Info about this Pool's objects.

Member Function Documentation

◆ AcquireOrCreate() [1/2]

TType AcquireOrCreate ( )

Acquire an existing object, or create a new one if none are available.

If it fails to get one from the pool, this will create from the info given in this pool's constructor.

◆ AcquireOrCreate() [2/2]

TType AcquireOrCreate ( TInfo info )

Acquire an existing object (if info matches), or create a new one from the passed info.

Parameters
info Info structure to match, or create a new object with.

◆ Dispose()

void Dispose ( )

Free resources assoicated with this ObjectPool

◆ Init()

void Init ( TInfo info )

(Re-)Initializes this ObjectPool.

If there are objects available in this Pool, they will be destroyed. Allocates (Capacity) new Objects.

Parameters
info Info about this Pool's objects.

◆ Release() [1/2]

virtual bool Release ( TType obj )
virtual

Returns object to pool, or destroys it if the pool is full.

Parameters
obj The object to return to the pool.

◆ Release() [2/2]

virtual bool Release | ( | TType | obj,
 |  | TInfo | objInfo
 | ) |  |
virtual

Returns object to pool.

Parameters
obj | The object to return to the pool.
objInfo | The info structure about obj.

obj is returned to the pool only if objInfo matches this pool's info. Else, it is destroyed.

Property Documentation

◆ Info

TInfo Info
get

The property (info) that objects in this Pool must match.


Photon Voice: Member List

Photon Voice v2.30

  • ObjectPool
ObjectPool< TType, TInfo > Member List

This is the complete list of members for ObjectPool< TType, TInfo >, including all inherited members.

AcquireOrCreate() | ObjectPool< TType, TInfo > |
AcquireOrCreate(TInfo info) | ObjectPool< TType, TInfo > |
capacity (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
createObject(TInfo info) (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protectedpure virtual
destroyObject(TType obj) (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protectedpure virtual
Dispose() | ObjectPool< TType, TInfo > |
info (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
Info | ObjectPool< TType, TInfo > |
infosMatch(TInfo i0, TInfo i1) (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protectedpure virtual
Init(TInfo info) | ObjectPool< TType, TInfo > |
name (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
ObjectPool(int capacity, string name) | ObjectPool< TType, TInfo > |
ObjectPool(int capacity, string name, TInfo info) | ObjectPool< TType, TInfo > |
pos (defined in ObjectPool< TType, TInfo >) | ObjectPool< TType, TInfo > | protected
Release(TType obj, TInfo objInfo) | ObjectPool< TType, TInfo > | virtual
Release(TType obj) | ObjectPool< TType, TInfo > | virtual


Photon Voice: OpusCodec Class Reference

Photon Voice v2.30

  • OpusCodec
Classes | Public Types | Properties | List of all members
OpusCodec Class Reference

Classes

class | Decoder
class | DecoderFactory
class | Encoder
class | EncoderFloat
class | EncoderShort
class | Factory
class | Util

Public Types

enum FrameDuration

Properties

static string Version [get]


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
OpusCodec Member List

This is the complete list of members for OpusCodec, including all inherited members.

FrameDuration enum name (defined in OpusCodec) | OpusCodec |
Version (defined in OpusCodec) | OpusCodec | static


Photon Voice: OpusCodec.Decoder< T > Class Template Reference

Photon Voice v2.30

  • OpusCodec
  • Decoder
Public Member Functions | Protected Attributes | Properties | List of all members
OpusCodec.Decoder< T > Class Template Reference

Inherits IDecoder.

Public Member Functions

Decoder (Action< FrameOut< T >> output, ILogger logger)
void | Open (VoiceInfo i)
Open (initialize) the decoder. More...
void | Dispose ()
void | Input (ref FrameBuffer buf)
Consumes the given encoded data. More...

Protected Attributes

OpusDecoder< T > decoder

Properties

string | Error [get]
- Properties inherited from IDecoder
string | Error [get]
If not null, the object is in invalid state. More...

Member Function Documentation

◆ Input()

void Input ( ref FrameBuffer buf )

Consumes the given encoded data.

The callee can call buf.Retain() to prevent the caller from disposing the buffer. In this case, the callee should call buf.Release() when buffer is no longer needed.

Implements IDecoder.

◆ Open()

void Open ( VoiceInfo info )

Open (initialize) the decoder.

Parameters
info Properties of the data stream to decode.

Implements IDecoder.


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
  • Decoder
OpusCodec.Decoder< T > Member List

This is the complete list of members for OpusCodec.Decoder< T >, including all inherited members.

decoder (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > | protected
Decoder(Action< FrameOut< T >> output, ILogger logger) (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > |
Dispose() (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > |
Error (defined in OpusCodec.Decoder< T >) | OpusCodec.Decoder< T > |
Input(ref FrameBuffer buf) | OpusCodec.Decoder< T > |
Open(VoiceInfo i) | OpusCodec.Decoder< T > |


Photon Voice: OpusCodec.DecoderFactory Class Reference

Photon Voice v2.30

  • OpusCodec
  • DecoderFactory
Static Public Member Functions | List of all members
OpusCodec.DecoderFactory Class Reference

Static Public Member Functions

static IEncoder Create< T > (VoiceInfo i, ILogger logger)


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
  • DecoderFactory
OpusCodec.DecoderFactory Member List

This is the complete list of members for OpusCodec.DecoderFactory, including all inherited members.

Create< T >(VoiceInfo i, ILogger logger) (defined in OpusCodec.DecoderFactory) OpusCodec.DecoderFactory static


Photon Voice: OpusCodec.Encoder< T > Class Template Reference

Photon Voice v2.30

  • OpusCodec
  • Encoder
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
OpusCodec.Encoder< T > Class Template Referenceabstract

Inherits IEncoderDirect< T[]>.

Public Member Functions

void | Input (T[] buf)
void | EndOfStream ()
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
I | GetPlatformAPI< I > ()
void | Dispose ()
- Public Member Functions inherited from IEncoderDirect< T[]>
void | Input (B buf)
Consumes the given raw data. More...

Protected Member Functions

Encoder (VoiceInfo i, ILogger logger)
abstract ArraySegment< byte > encodeTyped (T[] buf)

Protected Attributes

OpusEncoder | encoder
bool | disposed

Properties

string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
  • Encoder
OpusCodec.Encoder< T > Member List

This is the complete list of members for OpusCodec.Encoder< T >, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
Dispose() (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
disposed (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protected
encoder (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protected
Encoder(VoiceInfo i, ILogger logger) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protected
encodeTyped(T[] buf) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > | protectedpure virtual
EndOfStream() (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
Error (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
GetPlatformAPI< I >() (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
Input(T[] buf) (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |
IEncoderDirect< T[]>.Input(B buf) | IEncoderDirect< T[]> |
Output (defined in OpusCodec.Encoder< T >) | OpusCodec.Encoder< T > |


Photon Voice: OpusCodec.EncoderFloat Class Reference

Photon Voice v2.30

  • OpusCodec
  • EncoderFloat
Protected Member Functions | List of all members
OpusCodec.EncoderFloat Class Reference

Inherits OpusCodec.Encoder< float >.

Protected Member Functions

override ArraySegment< byte > | encodeTyped (float[] buf)
- Protected Member Functions inherited from OpusCodec.Encoder< float >
Encoder (VoiceInfo i, ILogger logger)
abstract ArraySegment< byte > | encodeTyped (T[] buf)

Additional Inherited Members

- Public Member Functions inherited from OpusCodec.Encoder< float >
void | Input (T[] buf)
void | EndOfStream ()
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
I | GetPlatformAPI< I > ()
void | Dispose ()
- Protected Attributes inherited from OpusCodec.Encoder< float >
OpusEncoder | encoder
bool | disposed
- Properties inherited from OpusCodec.Encoder< float >
string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
  • EncoderFloat
OpusCodec.EncoderFloat Member List

This is the complete list of members for OpusCodec.EncoderFloat, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Dispose() (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
disposed (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protected
Encoder(VoiceInfo i, ILogger logger) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protected
encoder (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protected
encodeTyped(float[] buf) (defined in OpusCodec.EncoderFloat) | OpusCodec.EncoderFloat | protected
encodeTyped(T[] buf) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > | protectedpure virtual
EndOfStream() (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Error (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
GetPlatformAPI< I >() (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Input(T[] buf) (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |
Output (defined in OpusCodec.Encoder< float >) | OpusCodec.Encoder< float > |


Photon Voice: OpusCodec.EncoderShort Class Reference

Photon Voice v2.30

  • OpusCodec
  • EncoderShort
Protected Member Functions | List of all members
OpusCodec.EncoderShort Class Reference

Inherits OpusCodec.Encoder< short >.

Protected Member Functions

override ArraySegment< byte > | encodeTyped (short[] buf)
- Protected Member Functions inherited from OpusCodec.Encoder< short >
Encoder (VoiceInfo i, ILogger logger)
abstract ArraySegment< byte > | encodeTyped (T[] buf)

Additional Inherited Members

- Public Member Functions inherited from OpusCodec.Encoder< short >
void | Input (T[] buf)
void | EndOfStream ()
ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
I | GetPlatformAPI< I > ()
void | Dispose ()
- Protected Attributes inherited from OpusCodec.Encoder< short >
OpusEncoder | encoder
bool | disposed
- Properties inherited from OpusCodec.Encoder< short >
string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
  • EncoderShort
OpusCodec.EncoderShort Member List

This is the complete list of members for OpusCodec.EncoderShort, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Dispose() (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
disposed (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protected
Encoder(VoiceInfo i, ILogger logger) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protected
encoder (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protected
encodeTyped(short[] buf) (defined in OpusCodec.EncoderShort) | OpusCodec.EncoderShort | protected
encodeTyped(T[] buf) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > | protectedpure virtual
EndOfStream() (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Error (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
GetPlatformAPI< I >() (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Input(T[] buf) (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |
Output (defined in OpusCodec.Encoder< short >) | OpusCodec.Encoder< short > |


Photon Voice: OpusCodec.Factory Class Reference

Photon Voice v2.30

  • OpusCodec
  • Factory
Static Public Member Functions | List of all members
OpusCodec.Factory Class Reference

Static Public Member Functions

static IEncoder CreateEncoder< B > (VoiceInfo i, ILogger logger)


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
  • Factory
OpusCodec.Factory Member List

This is the complete list of members for OpusCodec.Factory, including all inherited members.

CreateEncoder< B >(VoiceInfo i, ILogger logger) (defined in OpusCodec.Factory) OpusCodec.Factory static


Photon Voice: OpusCodec.Util Class Reference

Photon Voice v2.30

  • OpusCodec
  • Util
List of all members
OpusCodec.Util Class Reference


Photon Voice: Member List

Photon Voice v2.30

  • OpusCodec
  • Util
OpusCodec.Util Member List

This is the complete list of members for OpusCodec.Util, including all inherited members.


Photon Voice: Platform Class Reference

Photon Voice v2.30

  • Platform
Static Public Member Functions | List of all members
Platform Class Reference

Static Public Member Functions

static IDeviceEnumerator | CreateAudioInEnumerator (ILogger logger)
static IAudioInChangeNotifier | CreateAudioInChangeNotifier (Action callback, ILogger logger)
static IEncoder | CreateDefaultAudioEncoder< T > (ILogger logger, VoiceInfo info)
static IAudioDesc | CreateDefaultAudioSource (ILogger logger, DeviceInfo dev, int samplingRate, int channels, object otherParams=null)


Photon Voice: Member List

Photon Voice v2.30

  • Platform
Platform Member List

This is the complete list of members for Platform, including all inherited members.

CreateAudioInChangeNotifier(Action callback, ILogger logger) (defined in Platform) | Platform | static
CreateAudioInEnumerator(ILogger logger) (defined in Platform) | Platform | static
CreateDefaultAudioEncoder< T >(ILogger logger, VoiceInfo info) (defined in Platform) | Platform | static
CreateDefaultAudioSource(ILogger logger, DeviceInfo dev, int samplingRate, int channels, object otherParams=null) (defined in Platform) | Platform | static


Photon Voice: PrimitiveArrayPool< T > Class Template Reference

Photon Voice v2.30

  • PrimitiveArrayPool
Public Member Functions | Protected Member Functions | List of all members
PrimitiveArrayPool< T > Class Template Reference

Pool of Arrays with components of type T, with ObjectPool info being the array's size. More...

Inherits ObjectPool< T[], int >.

Public Member Functions

PrimitiveArrayPool (int capacity, string name)
PrimitiveArrayPool (int capacity, string name, int info)
- Public Member Functions inherited from ObjectPool< T[], int >
ObjectPool (int capacity, string name)
Create a new ObjectPool instance. Does not call Init(). More...
ObjectPool (int capacity, string name, TInfo info)
Create a new ObjectPool instance with the given info structure. Calls Init(). More...
void | Init (TInfo info)
(Re-)Initializes this ObjectPool. More...
TType | AcquireOrCreate ()
Acquire an existing object, or create a new one if none are available. More...
TType | AcquireOrCreate (TInfo info)
Acquire an existing object (if info matches), or create a new one from the passed info. More...
virtual bool | Release (TType obj, TInfo objInfo)
Returns object to pool. More...
virtual bool | Release (TType obj)
Returns object to pool, or destroys it if the pool is full. More...
void | Dispose ()
Free resources assoicated with this ObjectPool More...

Protected Member Functions

override T[] | createObject (int info)
override void | destroyObject (T[] obj)
override bool | infosMatch (int i0, int i1)
- Protected Member Functions inherited from ObjectPool< T[], int >
abstract TType | createObject (TInfo info)
abstract void | destroyObject (TType obj)
abstract bool | infosMatch (TInfo i0, TInfo i1)

Additional Inherited Members

- Protected Attributes inherited from ObjectPool< T[], int >
int | capacity
TInfo | info
int | pos
string | name
- Properties inherited from ObjectPool< T[], int >
TInfo | Info [get]
The property (info) that objects in this Pool must match. More...

Detailed Description

Pool of Arrays with components of type T, with ObjectPool info being the array's size.

Template Parameters
T Array element type.


Photon Voice: Member List

Photon Voice v2.30

  • PrimitiveArrayPool
PrimitiveArrayPool< T > Member List

This is the complete list of members for PrimitiveArrayPool< T >, including all inherited members.

AcquireOrCreate() | ObjectPool< T[], int > |
AcquireOrCreate(TInfo info) | ObjectPool< T[], int > |
capacity (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
createObject(int info) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > | protected
createObject(TInfo info) (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protectedpure virtual
destroyObject(T[] obj) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > | protected
destroyObject(TType obj) (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protectedpure virtual
Dispose() | ObjectPool< T[], int > |
info (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
Info | ObjectPool< T[], int > |
infosMatch(int i0, int i1) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > | protected
infosMatch(TInfo i0, TInfo i1) (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protectedpure virtual
Init(TInfo info) | ObjectPool< T[], int > |
name (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
ObjectPool(int capacity, string name) | ObjectPool< T[], int > |
ObjectPool(int capacity, string name, TInfo info) | ObjectPool< T[], int > |
pos (defined in ObjectPool< T[], int >) | ObjectPool< T[], int > | protected
PrimitiveArrayPool(int capacity, string name) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > |
PrimitiveArrayPool(int capacity, string name, int info) (defined in PrimitiveArrayPool< T >) | PrimitiveArrayPool< T > |
Release(TType obj, TInfo objInfo) | ObjectPool< T[], int > | virtual
Release(TType obj) | ObjectPool< T[], int > | virtual


Photon Voice: RawCodec Class Reference

Photon Voice v2.30

  • RawCodec
Classes
RawCodec Class Reference

Classes

class | Decoder
class | Encoder
class | ShortToFloat


Photon Voice: RawCodec.Decoder< T > Class Template Reference

Photon Voice v2.30

  • RawCodec
  • Decoder
Public Member Functions | Properties | List of all members
RawCodec.Decoder< T > Class Template Reference

Inherits IDecoder.

Public Member Functions

Decoder (Action< FrameOut< T >> output)
void | Open (VoiceInfo info)
Open (initialize) the decoder. More...
void | Input (ref FrameBuffer byteBuf)
Consumes the given encoded data. More...
void | Dispose ()

Properties

string | Error [get]
- Properties inherited from IDecoder
string | Error [get]
If not null, the object is in invalid state. More...

Member Function Documentation

◆ Input()

void Input ( ref FrameBuffer buf )

Consumes the given encoded data.

The callee can call buf.Retain() to prevent the caller from disposing the buffer. In this case, the callee should call buf.Release() when buffer is no longer needed.

Implements IDecoder.

◆ Open()

void Open ( VoiceInfo info )

Open (initialize) the decoder.

Parameters
info Properties of the data stream to decode.

Implements IDecoder.


Photon Voice: Member List

Photon Voice v2.30

  • RawCodec
  • Decoder
RawCodec.Decoder< T > Member List

This is the complete list of members for RawCodec.Decoder< T >, including all inherited members.

Decoder(Action< FrameOut< T >> output) (defined in RawCodec.Decoder< T >) | RawCodec.Decoder< T >
Dispose() (defined in RawCodec.Decoder< T >) | RawCodec.Decoder< T >
Error (defined in RawCodec.Decoder< T >) | RawCodec.Decoder< T >
Input(ref FrameBuffer byteBuf) | RawCodec.Decoder< T >
Open(VoiceInfo info) | RawCodec.Decoder< T >


Photon Voice: RawCodec.Encoder< T > Class Template Reference

Photon Voice v2.30

  • RawCodec
  • Encoder
Public Member Functions | Properties | List of all members
RawCodec.Encoder< T > Class Template Reference

Inherits IEncoderDirect< T[]>.

Public Member Functions

ArraySegment< byte > | DequeueOutput (out FrameFlags flags)
void | EndOfStream ()
I | GetPlatformAPI< I > ()
void | Dispose ()
void | Input (T[] buf)
- Public Member Functions inherited from IEncoderDirect< T[]>
void | Input (B buf)
Consumes the given raw data. More...

Properties

string | Error [get]
Action< ArraySegment< byte >, FrameFlags > | Output [get, set]


Photon Voice: Member List

Photon Voice v2.30

  • RawCodec
  • Encoder
RawCodec.Encoder< T > Member List

This is the complete list of members for RawCodec.Encoder< T >, including all inherited members.

DequeueOutput(out FrameFlags flags) (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
Dispose() (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
EndOfStream() (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
Error (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
GetPlatformAPI< I >() (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
Input(T[] buf) (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >
IEncoderDirect< T[]>.Input(B buf) | IEncoderDirect< T[]>
Output (defined in RawCodec.Encoder< T >) | RawCodec.Encoder< T >


Photon Voice: RawCodec.ShortToFloat Class Reference

Photon Voice v2.30

  • RawCodec
  • ShortToFloat
Public Member Functions | List of all members
RawCodec.ShortToFloat Class Reference

Public Member Functions

ShortToFloat (Action< FrameOut< float >> output)
void Output (FrameOut< short > shortBuf)


Photon Voice: Member List

Photon Voice v2.30

  • RawCodec
  • ShortToFloat
RawCodec.ShortToFloat Member List

This is the complete list of members for RawCodec.ShortToFloat, including all inherited members.

Output(FrameOut< short > shortBuf) (defined in RawCodec.ShortToFloat) | RawCodec.ShortToFloat
ShortToFloat(Action< FrameOut< float >> output) (defined in RawCodec.ShortToFloat) | RawCodec.ShortToFloat


Photon Voice: RemoteVoiceInfo Class Reference

Photon Voice v2.30

  • RemoteVoiceInfo
Properties | List of all members
RemoteVoiceInfo Class Reference

Information about a remote voice (incoming stream). More...

Properties

VoiceInfo | Info [get]
Remote voice info. More...
int | ChannelId [get]
ID of channel used for transmission. More...
int | PlayerId [get]
Player ID of voice owner. More...
byte | VoiceId [get]
Voice ID (unique in the room). More...

Detailed Description

Information about a remote voice (incoming stream).

Property Documentation

◆ ChannelId

int ChannelId
get

ID of channel used for transmission.

◆ Info

VoiceInfo Info
get

Remote voice info.

◆ PlayerId

int PlayerId
get

Player ID of voice owner.

◆ VoiceId

byte VoiceId
get

Voice ID (unique in the room).


Photon Voice: Member List

Photon Voice v2.30

  • RemoteVoiceInfo
RemoteVoiceInfo Member List

This is the complete list of members for RemoteVoiceInfo, including all inherited members.

ChannelId | RemoteVoiceInfo
Info | RemoteVoiceInfo
PlayerId | RemoteVoiceInfo
VoiceId | RemoteVoiceInfo


Photon Voice: RemoteVoiceOptions Struct Reference

Photon Voice v2.30

  • RemoteVoiceOptions
Public Member Functions | Properties | List of all members
RemoteVoiceOptions Struct Reference

Event Actions and other options for a remote voice (incoming stream). More...

Public Member Functions

RemoteVoiceOptions (ILogger logger, string logPrefix, VoiceInfo voiceInfo)
void | SetOutput (Action< FrameOut< float >> output)
Create default audio decoder and register a method to be called when a data frame is decoded. More...
void | SetOutput (Action< FrameOut< short >> output)
Create default audio decoder and register a method to be called when a data frame is decoded. More...

Properties

Action | OnRemoteVoiceRemoveAction [get, set]
Register a method to be called when the remote voice is removed. More...
IDecoder | Decoder [get, set]
Remote voice data decoder. Use to set decoder options or override it with user decoder. More...

Detailed Description

Event Actions and other options for a remote voice (incoming stream).

Member Function Documentation

◆ SetOutput() [1/2]

void SetOutput ( Action< FrameOut< float >> output )

Create default audio decoder and register a method to be called when a data frame is decoded.

◆ SetOutput() [2/2]

void SetOutput ( Action< FrameOut< short >> output )

Create default audio decoder and register a method to be called when a data frame is decoded.

Property Documentation

◆ Decoder

IDecoder Decoder
getset

Remote voice data decoder. Use to set decoder options or override it with user decoder.

◆ OnRemoteVoiceRemoveAction

Action OnRemoteVoiceRemoveAction
getset

Register a method to be called when the remote voice is removed.


Photon Voice: Member List

Photon Voice v2.30

  • RemoteVoiceOptions
RemoteVoiceOptions Member List

This is the complete list of members for RemoteVoiceOptions, including all inherited members.

Decoder | RemoteVoiceOptions
OnRemoteVoiceRemoveAction | RemoteVoiceOptions
RemoteVoiceOptions(ILogger logger, string logPrefix, VoiceInfo voiceInfo) (defined in RemoteVoiceOptions) | RemoteVoiceOptions
SetOutput(Action< FrameOut< float >> output) | RemoteVoiceOptions
SetOutput(Action< FrameOut< short >> output) | RemoteVoiceOptions


Photon Voice: UnsupportedCodecException Class Reference

Photon Voice v2.30

  • UnsupportedCodecException
Public Member Functions | List of all members
UnsupportedCodecException Class Reference

Exception thrown if an unsupported codec is encountered. More...

Inherits Exception.

Public Member Functions

UnsupportedCodecException (string info, Codec codec)
Create a new UnsupportedCodecException. More...

Detailed Description

Exception thrown if an unsupported codec is encountered.

Constructor & Destructor Documentation

◆ UnsupportedCodecException()

UnsupportedCodecException | ( | string | info,
 |  | Codec | codec
 | ) |  |

Create a new UnsupportedCodecException.

Parameters
info | The info prepending standard message.
codec | The codec actually encountered.


Photon Voice: Member List

Photon Voice v2.30

  • UnsupportedCodecException
UnsupportedCodecException Member List

This is the complete list of members for UnsupportedCodecException, including all inherited members.

UnsupportedCodecException(string info, Codec codec) UnsupportedCodecException


Photon Voice: UnsupportedPlatformException Class Reference

Photon Voice v2.30

  • UnsupportedPlatformException
Public Member Functions | List of all members
UnsupportedPlatformException Class Reference

Exception thrown if an unsupported platform is encountered. More...

Inherits Exception.

Public Member Functions

UnsupportedPlatformException (string subject, string platform=null)
Create a new UnsupportedPlatformException. More...

Detailed Description

Exception thrown if an unsupported platform is encountered.

Constructor & Destructor Documentation

◆ UnsupportedPlatformException()

UnsupportedPlatformException | ( | string | subject,
 |  | string | platform = null
 | ) |  |

Create a new UnsupportedPlatformException.

Parameters
subject The info prepending standard message.

///

Parameters
platform Optional platform name.


Photon Voice: Member List

Photon Voice v2.30

  • UnsupportedPlatformException
UnsupportedPlatformException Member List

This is the complete list of members for UnsupportedPlatformException, including all inherited members.

UnsupportedPlatformException(string subject, string platform=null) UnsupportedPlatformException


Photon Voice: UnsupportedSampleTypeException Class Reference

Photon Voice v2.30

  • UnsupportedSampleTypeException
Public Member Functions | List of all members
UnsupportedSampleTypeException Class Reference

Exception thrown if an unsupported audio sample type is encountered. More...

Inherits Exception.

Public Member Functions

UnsupportedSampleTypeException (Type t)
Create a new UnsupportedSampleTypeException. More...

Detailed Description

Exception thrown if an unsupported audio sample type is encountered.

PhotonVoice generally supports 32-bit floating point ("float") or 16-bit signed integer ("short") audio, but it usually won't be converted automatically due to the high CPU overhead (and potential loss of precision) involved.

Constructor & Destructor Documentation

◆ UnsupportedSampleTypeException()

UnsupportedSampleTypeException ( Type t )

Create a new UnsupportedSampleTypeException.

Parameters
t The sample type actually encountered.


Photon Voice: Member List

Photon Voice v2.30

  • UnsupportedSampleTypeException
UnsupportedSampleTypeException Member List

This is the complete list of members for UnsupportedSampleTypeException, including all inherited members.

UnsupportedSampleTypeException(Type t) UnsupportedSampleTypeException


Photon Voice: VoiceClient Class Reference

Photon Voice v2.30

  • VoiceClient
Classes | Public Member Functions | Properties | List of all members
VoiceClient Class Reference

Voice client interact with other clients on network via IVoiceTransport. More...

Inherits IDisposable.

Classes

struct CreateOptions

Public Member Functions

delegate void | RemoteVoiceInfoDelegate (int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options)
Remote voice info event delegate. More...
IEnumerable< LocalVoice > | LocalVoicesInChannel (int channelId)
Iterates through copy of all local voices list of given channel. More...
void | LogSpacingProfiles ()
void | LogStats ()
void | SetRemoteVoiceDelayFrames (Codec codec, int delayFrames)
VoiceClient (IVoiceTransport transport, ILogger logger, CreateOptions opt=default(CreateOptions))
Creates VoiceClient instance More...
void | Service ()
This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2..20 times a second). More...
LocalVoice | CreateLocalVoice (VoiceInfo voiceInfo, int channelId=0, IEncoder encoder=null)
Creates basic outgoing stream w/o data processing support. Provided encoder should generate output data stream. More...
LocalVoiceFramed< T > | CreateLocalVoiceFramed< T > (VoiceInfo voiceInfo, int frameSize, int channelId=0, IEncoder encoder=null)
Creates outgoing stream consuming sequence of values passed in array buffers of arbitrary length which repacked in frames of constant length for further processing and encoding. More...
LocalVoiceAudio< T > | CreateLocalVoiceAudio< T > (VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, IEncoder encoder, int channelId)
LocalVoice | CreateLocalVoiceAudioFromSource (VoiceInfo voiceInfo, IAudioDesc source, AudioSampleType sampleType, IEncoder encoder=null, int channelId=0)
Creates outgoing audio stream of type automatically assigned and adds procedures (callback or serviceable) for consuming given audio source data. Adds audio specific features (e.g. resampling, level meter) to processing pipeline and to returning stream handler. More...
void | RemoveLocalVoice (LocalVoice voice)
Removes local voice (outgoing data stream).

Parameters
voice Handler of outgoing stream to be removed.
More...
void | onJoinChannel (int channel)
void | onLeaveChannel (int channel)
void | onLeaveAllChannels ()
void | onPlayerJoin (int channelId, int playerId)
void | onPlayerLeave (int channelId, int playerId)
void | onVoiceInfo (int channelId, int playerId, byte voiceId, byte eventNumber, VoiceInfo info)
void | onVoiceRemove (int channelId, int playerId, byte[] voiceIds)
void | onFrame (int channelId, int playerId, byte voiceId, byte evNumber, ref FrameBuffer receivedBytes, bool isLocalPlayer)
void | Dispose ()

Properties

int | FramesLost [get, set]
Lost frames counter. More...
int | FramesReceived [get]
Received frames counter. More...
int | FramesSent [get]
Sent frames counter. More...
int | FramesSentBytes [get]
Sent frames bytes counter. More...
int | RoundTripTime [get]
Average time required voice packet to return to sender. More...
int | RoundTripTimeVariance [get]
Average round trip time variation. More...
bool | SuppressInfoDuplicateWarning [get, set]
Do not log warning when duplicate info received. More...
RemoteVoiceInfoDelegate | OnRemoteVoiceInfoAction [get, set]
Register a method to be called when remote voice info arrived (after join or new new remote voice creation). Metod parameters: (int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options); More...
int | DebugLostPercent [get, set]
Lost frames simulation ratio. More...
IEnumerable< LocalVoice > | LocalVoices [get]
Iterates through copy of all local voices list. More...
IEnumerable< RemoteVoiceInfo > | RemoteVoiceInfos [get]
Iterates through all remote voices infos. More...

Detailed Description

Voice client interact with other clients on network via IVoiceTransport.

Constructor & Destructor Documentation

◆ VoiceClient()

VoiceClient | ( | IVoiceTransport | transport,
 |  | ILogger | logger,
 |  | CreateOptions | opt = default(CreateOptions)
 | ) |  |

Creates VoiceClient instance

Member Function Documentation

◆ CreateLocalVoice()

LocalVoice CreateLocalVoice | ( | VoiceInfo | voiceInfo,
 |  | int | channelId = 0,
 |  | IEncoder | encoder = null
 | ) |  |

Creates basic outgoing stream w/o data processing support. Provided encoder should generate output data stream.

Parameters
voiceInfo | Outgoing stream parameters.
channelId | Transport channel specific to transport.
encoder | Encoder producing the stream.
Returns
Outgoing stream handler.

◆ CreateLocalVoiceAudioFromSource()

LocalVoice CreateLocalVoiceAudioFromSource | ( | VoiceInfo | voiceInfo,
 |  | IAudioDesc | source,
 |  | AudioSampleType | sampleType,
 |  | IEncoder | encoder = null,
 |  | int | channelId = 0
 | ) |  |

Creates outgoing audio stream of type automatically assigned and adds procedures (callback or serviceable) for consuming given audio source data. Adds audio specific features (e.g. resampling, level meter) to processing pipeline and to returning stream handler.

Parameters
voiceInfo | Outgoing stream parameters.
source | Streaming audio source.
sampleType | Voice's audio sample type. If does not match source audio sample type, conversion will occur.
channelId | Transport channel specific to transport.
encoder | Audio encoder. Set to null to use default Opus encoder.
Returns
Outgoing stream handler.

audioSourceDesc.SamplingRate and voiceInfo.SamplingRate may do not match. Automatic resampling will occur in this case.

◆ CreateLocalVoiceFramed< T >()

LocalVoiceFramed<T> CreateLocalVoiceFramed< T > | ( | VoiceInfo | voiceInfo,
 |  | int | frameSize,
 |  | int | channelId = 0,
 |  | IEncoder | encoder = null
 | ) |  |

Creates outgoing stream consuming sequence of values passed in array buffers of arbitrary length which repacked in frames of constant length for further processing and encoding.

Template Parameters
T Type of data consumed by outgoing stream (element type of array buffers).
Parameters
voiceInfo | Outgoing stream parameters.
frameSize | Size of buffer LocalVoiceFramed repacks input data stream to.
channelId | Transport channel specific to transport.
encoder | Encoder compressing data stream in pipeline.
Returns
Outgoing stream handler.

◆ LocalVoicesInChannel()

IEnumerable<LocalVoice> LocalVoicesInChannel ( int channelId )

Iterates through copy of all local voices list of given channel.

◆ RemoteVoiceInfoDelegate()

delegate void RemoteVoiceInfoDelegate | ( | int | channelId,
 |  | int | playerId,
 |  | byte | voiceId,
 |  | VoiceInfo | voiceInfo,
 |  | ref RemoteVoiceOptions | options
 | ) |  |

Remote voice info event delegate.

◆ RemoveLocalVoice()

void RemoveLocalVoice ( LocalVoice voice )

Removes local voice (outgoing data stream).

Parameters
voice Handler of outgoing stream to be removed.

◆ Service()

void Service ( )

This method dispatches all available incoming commands and then sends this client's outgoing commands. Call this method regularly (2..20 times a second).

Property Documentation

◆ DebugLostPercent

int DebugLostPercent
getset

Lost frames simulation ratio.

◆ FramesLost

int FramesLost
getset

Lost frames counter.

◆ FramesReceived

int FramesReceived
get

Received frames counter.

◆ FramesSent

int FramesSent
get

Sent frames counter.

◆ FramesSentBytes

int FramesSentBytes
get

Sent frames bytes counter.

◆ LocalVoices

IEnumerable<LocalVoice> LocalVoices
get

Iterates through copy of all local voices list.

◆ OnRemoteVoiceInfoAction

RemoteVoiceInfoDelegate OnRemoteVoiceInfoAction
getset

Register a method to be called when remote voice info arrived (after join or new new remote voice creation). Metod parameters: (int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options);

◆ RemoteVoiceInfos

IEnumerable<RemoteVoiceInfo> RemoteVoiceInfos
get

Iterates through all remote voices infos.

◆ RoundTripTime

int RoundTripTime
get

Average time required voice packet to return to sender.

◆ RoundTripTimeVariance

int RoundTripTimeVariance
get

Average round trip time variation.

◆ SuppressInfoDuplicateWarning

bool SuppressInfoDuplicateWarning
getset

Do not log warning when duplicate info received.


Photon Voice: Member List

Photon Voice v2.30

  • VoiceClient
VoiceClient Member List

This is the complete list of members for VoiceClient, including all inherited members.

CreateLocalVoice(VoiceInfo voiceInfo, int channelId=0, IEncoder encoder=null) | VoiceClient
CreateLocalVoiceAudio< T >(VoiceInfo voiceInfo, IAudioDesc audioSourceDesc, IEncoder encoder, int channelId) (defined in VoiceClient) | VoiceClient
CreateLocalVoiceAudioFromSource(VoiceInfo voiceInfo, IAudioDesc source, AudioSampleType sampleType, IEncoder encoder=null, int channelId=0) | VoiceClient
CreateLocalVoiceFramed< T >(VoiceInfo voiceInfo, int frameSize, int channelId=0, IEncoder encoder=null) | VoiceClient
DebugLostPercent | VoiceClient
Dispose() (defined in VoiceClient) | VoiceClient
FramesLost | VoiceClient
FramesReceived | VoiceClient
FramesSent | VoiceClient
FramesSentBytes | VoiceClient
LocalVoices | VoiceClient
LocalVoicesInChannel(int channelId) | VoiceClient
LogSpacingProfiles() (defined in VoiceClient) | VoiceClient
LogStats() (defined in VoiceClient) | VoiceClient
onFrame(int channelId, int playerId, byte voiceId, byte evNumber, ref FrameBuffer receivedBytes, bool isLocalPlayer) (defined in VoiceClient) | VoiceClient
onJoinChannel(int channel) (defined in VoiceClient) | VoiceClient
onLeaveAllChannels() (defined in VoiceClient) | VoiceClient
onLeaveChannel(int channel) (defined in VoiceClient) | VoiceClient
onPlayerJoin(int channelId, int playerId) (defined in VoiceClient) | VoiceClient
onPlayerLeave(int channelId, int playerId) (defined in VoiceClient) | VoiceClient
OnRemoteVoiceInfoAction | VoiceClient
onVoiceInfo(int channelId, int playerId, byte voiceId, byte eventNumber, VoiceInfo info) (defined in VoiceClient) | VoiceClient
onVoiceRemove(int channelId, int playerId, byte[] voiceIds) (defined in VoiceClient) | VoiceClient
RemoteVoiceInfoDelegate(int channelId, int playerId, byte voiceId, VoiceInfo voiceInfo, ref RemoteVoiceOptions options) | VoiceClient
RemoteVoiceInfos | VoiceClient
RemoveLocalVoice(LocalVoice voice) | VoiceClient
RoundTripTime | VoiceClient
RoundTripTimeVariance | VoiceClient
Service() | VoiceClient
SetRemoteVoiceDelayFrames(Codec codec, int delayFrames) (defined in VoiceClient) | VoiceClient
SuppressInfoDuplicateWarning | VoiceClient
VoiceClient(IVoiceTransport transport, ILogger logger, CreateOptions opt=default(CreateOptions)) | VoiceClient


Photon Voice: VoiceClient.CreateOptions Struct Reference

Photon Voice v2.30

  • VoiceClient
  • CreateOptions
Public Attributes | Static Public Attributes | List of all members
VoiceClient.CreateOptions Struct Reference

Public Attributes

byte | VoiceIDMin
byte | VoiceIDMax

Static Public Attributes

static CreateOptions Default

Member Data Documentation

◆ Default

CreateOptions Default
static
Initial value:
= new CreateOptions()
{
VoiceIDMin = 1,
VoiceIDMax = 15
}


Photon Voice: Member List

Photon Voice v2.30

  • VoiceClient
  • CreateOptions
VoiceClient.CreateOptions Member List

This is the complete list of members for VoiceClient.CreateOptions, including all inherited members.

Default (defined in VoiceClient.CreateOptions) | VoiceClient.CreateOptions | static
VoiceIDMax (defined in VoiceClient.CreateOptions) | VoiceClient.CreateOptions |
VoiceIDMin (defined in VoiceClient.CreateOptions) | VoiceClient.CreateOptions |


Photon Voice: VoiceEvent Class Reference

Photon Voice v2.30

  • VoiceEvent
Static Public Attributes | List of all members
VoiceEvent Class Reference

Static Public Attributes

const byte | Code = 202
Single event used for voice communications. More...
const byte | FrameCode = 203

Member Data Documentation

◆ Code

const byte Code = 202
static

Single event used for voice communications.

Change if it conflicts with other event codes used in the same Photon room.


Photon Voice: Member List

Photon Voice v2.30

  • VoiceEvent
VoiceEvent Member List

This is the complete list of members for VoiceEvent, including all inherited members.

Code | VoiceEvent | static
FrameCode (defined in VoiceEvent) | VoiceEvent | static


Photon Voice: VoiceInfo Struct Reference

Photon Voice v2.30

  • VoiceInfo
Public Member Functions | Static Public Member Functions | Properties | List of all members
VoiceInfo Struct Reference

Describes stream properties. More...

Public Member Functions

override string ToString ()

Static Public Member Functions

static VoiceInfo | CreateAudioOpus (POpusCodec.Enums.SamplingRate samplingRate, int channels, OpusCodec.FrameDuration frameDurationUs, int bitrate, object userdata=null)
Create stream info for an Opus audio stream. More...
static VoiceInfo | CreateAudio (Codec codec, int samplingRate, int channels, int frameDurationUs, object userdata=null)
Create stream info for an audio stream. More...

Properties

Codec | Codec [get, set]
int | SamplingRate [get, set]
Audio sampling rate (frequency, in Hz). More...
int | Channels [get, set]
Number of channels. More...
int | FrameDurationUs [get, set]
Uncompressed frame (audio packet) size in microseconds. More...
int | Bitrate [get, set]
Target bitrate (in bits/second). More...
int | Width [get, set]
Video width. More...
int | Height [get, set]
Video height More...
int | FPS [get, set]
Video frames per second More...
int | KeyFrameInt [get, set]
Video keyframe interval in frames More...
object | UserData [get, set]
Optional user data. Should be serializable by Photon. More...
int | FrameDurationSamples [get]
Uncompressed frame (data packet) size in samples. More...
int | FrameSize [get]
Uncompressed frame (data packet) array size. More...

Detailed Description

Describes stream properties.

Member Function Documentation

◆ CreateAudio()

static VoiceInfo CreateAudio | ( | Codec | codec,
 |  | int | samplingRate,
 |  | int | channels,
 |  | int | frameDurationUs,
 |  | object | userdata = null
 | ) |  |
static

Create stream info for an audio stream.

Parameters
codec | Audio codec.
samplingRate | Audio sampling rate.
channels | Number of channels.
frameDurationUs | Uncompressed frame (audio packet) size in microseconds.
userdata | Optional user data. Should be serializable by Photon.
Returns
VoiceInfo instance.

◆ CreateAudioOpus()

static VoiceInfo CreateAudioOpus | ( | POpusCodec.Enums.SamplingRate | samplingRate,
 |  | int | channels,
 |  | OpusCodec.FrameDuration | frameDurationUs,
 |  | int | bitrate,
 |  | object | userdata = null
 | ) |  |
static

Create stream info for an Opus audio stream.

Parameters
samplingRate | Audio sampling rate.
channels | Number of channels.
frameDurationUs | Uncompressed frame (audio packet) size in microseconds.
bitrate | Stream bitrate (in bits/second).
userdata | Optional user data. Should be serializable by Photon.
Returns
VoiceInfo instance.

Property Documentation

◆ Bitrate

int Bitrate
getset

Target bitrate (in bits/second).

◆ Channels

int Channels
getset

Number of channels.

◆ FPS

int FPS
getset

Video frames per second

◆ FrameDurationSamples

int FrameDurationSamples
get

Uncompressed frame (data packet) size in samples.

◆ FrameDurationUs

int FrameDurationUs
getset

Uncompressed frame (audio packet) size in microseconds.

◆ FrameSize

int FrameSize
get

Uncompressed frame (data packet) array size.

◆ Height

int Height
getset

Video height

◆ KeyFrameInt

int KeyFrameInt
getset

Video keyframe interval in frames

◆ SamplingRate

int SamplingRate
getset

Audio sampling rate (frequency, in Hz).

◆ UserData

object UserData
getset

Optional user data. Should be serializable by Photon.

◆ Width

int Width
getset

Video width.


Photon Voice: Member List

Photon Voice v2.30

  • VoiceInfo
VoiceInfo Member List

This is the complete list of members for VoiceInfo, including all inherited members.

Bitrate | VoiceInfo |
Channels | VoiceInfo |
Codec (defined in VoiceInfo) | VoiceInfo |
CreateAudio(Codec codec, int samplingRate, int channels, int frameDurationUs, object userdata=null) | VoiceInfo | static
CreateAudioOpus(POpusCodec.Enums.SamplingRate samplingRate, int channels, OpusCodec.FrameDuration frameDurationUs, int bitrate, object userdata=null) | VoiceInfo | static
FPS | VoiceInfo |
FrameDurationSamples | VoiceInfo |
FrameDurationUs | VoiceInfo |
FrameSize | VoiceInfo |
Height | VoiceInfo |
KeyFrameInt | VoiceInfo |
SamplingRate | VoiceInfo |
ToString() (defined in VoiceInfo) | VoiceInfo |
UserData | VoiceInfo |
Width | VoiceInfo |


Photon Voice: WebRTCAudioLib Class Reference

Photon Voice v2.30

  • WebRTCAudioLib
Public Types | Public Member Functions | List of all members
WebRTCAudioLib Class Reference

Inherited by WebRTCAudioProcessor.

Public Types

enum | Error
enum | Param

Public Member Functions

static IntPtr | webrtc_audio_processor_create (int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels)
static int | webrtc_audio_processor_init (IntPtr proc)
static int | webrtc_audio_processor_set_param (IntPtr proc, int param, int v)
static int | webrtc_audio_processor_process (IntPtr proc, short[] buffer, int offset, out bool voiceDetected)
static int | webrtc_audio_processor_process_reverse (IntPtr proc, short[] buffer, int bufferSize)
static void | webrtc_audio_processor_destroy (IntPtr proc)


Photon Voice: Member List

Photon Voice v2.30

  • WebRTCAudioLib
WebRTCAudioLib Member List

This is the complete list of members for WebRTCAudioLib, including all inherited members.

Error enum name (defined in WebRTCAudioLib) | WebRTCAudioLib
Param enum name (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_create(int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_destroy(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_init(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_process(IntPtr proc, short[] buffer, int offset, out bool voiceDetected) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_process_reverse(IntPtr proc, short[] buffer, int bufferSize) (defined in WebRTCAudioLib) | WebRTCAudioLib
webrtc_audio_processor_set_param(IntPtr proc, int param, int v) (defined in WebRTCAudioLib) | WebRTCAudioLib


Photon Voice: WebRTCAudioProcessor Class Reference

Photon Voice v2.30

  • WebRTCAudioProcessor
Public Member Functions | Static Public Attributes | Properties | List of all members
WebRTCAudioProcessor Class Reference

Inherits WebRTCAudioLib, and IProcessor< short >.

Public Member Functions

WebRTCAudioProcessor (ILogger logger, int frameSize, int samplingRate, int channels, int reverseSamplingRate, int reverseChannels)
short[] | Process (short[] buf)
void | OnAudioOutFrameFloat (float[] data)
void | Dispose ()
- Public Member Functions inherited from WebRTCAudioLib
static IntPtr | webrtc_audio_processor_create (int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels)
static int | webrtc_audio_processor_init (IntPtr proc)
static int | webrtc_audio_processor_set_param (IntPtr proc, int param, int v)
static int | webrtc_audio_processor_process (IntPtr proc, short[] buffer, int offset, out bool voiceDetected)
static int | webrtc_audio_processor_process_reverse (IntPtr proc, short[] buffer, int bufferSize)
static void | webrtc_audio_processor_destroy (IntPtr proc)
- Public Member Functions inherited from IProcessor< short >
T[] | Process (T[] buf)
Process a frame of audio data. More...

Static Public Attributes

static readonly int[] SupportedSamplingRates = { 8000, 16000, 32000, 48000 }

Properties

int | AECStreamDelayMs [set]
bool?? | AEC [set]
bool? | AECHighPass [set]
bool?? | AECMobile [set]
bool? | HighPass [set]
bool? | NoiseSuppression [set]
bool? | AGC [set]
int | AGCCompressionGain [set]
int | AGCTargetLevel [set]
bool? | AGC2 [set]
bool? | VAD [set]
bool | Bypass [set]

Additional Inherited Members

- Public Types inherited from WebRTCAudioLib
enum | Error
enum | Param


Photon Voice: Member List

Photon Voice v2.30

  • WebRTCAudioProcessor
WebRTCAudioProcessor Member List

This is the complete list of members for WebRTCAudioProcessor, including all inherited members.

AEC (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AECHighPass (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AECMobile (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AECStreamDelayMs (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGC (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGC2 (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGCCompressionGain (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
AGCTargetLevel (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Bypass (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Dispose() (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Error enum name (defined in WebRTCAudioLib) | WebRTCAudioLib |
HighPass (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
NoiseSuppression (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
OnAudioOutFrameFloat(float[] data) (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
Param enum name (defined in WebRTCAudioLib) | WebRTCAudioLib |
Process(short[] buf) (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
IProcessor< short >.Process(T[] buf) | IProcessor< short > |
SupportedSamplingRates (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor | static
VAD (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |
webrtc_audio_processor_create(int samplingRate, int channels, int frameSize, int revSamplingRate, int revChannels) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_destroy(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_init(IntPtr proc) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_process(IntPtr proc, short[] buffer, int offset, out bool voiceDetected) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_process_reverse(IntPtr proc, short[] buffer, int bufferSize) (defined in WebRTCAudioLib) | WebRTCAudioLib |
webrtc_audio_processor_set_param(IntPtr proc, int param, int v) (defined in WebRTCAudioLib) | WebRTCAudioLib |
WebRTCAudioProcessor(ILogger logger, int frameSize, int samplingRate, int channels, int reverseSamplingRate, int reverseChannels) (defined in WebRTCAudioProcessor) | WebRTCAudioProcessor |


Photon Voice: POpusCodec Namespace Reference

Photon Voice v2.30

Namespaces | Classes
POpusCodec Namespace Reference

Classes

class | OpusDecoder
class | OpusEncoder
class | OpusException
class | OpusLib
class | Wrapper


Photon Voice: POpusCodec.Enums Namespace Reference

Photon Voice v2.30

  • POpusCodec
  • Enums
Enumerations
POpusCodec.Enums Namespace Reference

Enumerations

enum | Bandwidth : int
enum | Channels : int
enum | Complexity : int
enum | Delay
Using a duration of less than 10 ms will prevent the encoder from using the LPC or hybrid modes. More...
enum | ForceChannels : int
enum | OpusApplicationType : int
enum | OpusStatusCode : int
enum | SamplingRate : int
enum | SignalHint : int

Enumeration Type Documentation

◆ Bandwidth

enum Bandwidth : int
strong
Enumerator
Narrowband | Up to 4Khz
Mediumband | Up to 6Khz
Wideband | Up to 8Khz
SuperWideband | Up to 12Khz
Fullband | Up to 20Khz (High Definition)

◆ Channels

enum Channels : int
strong
Enumerator
Mono | 1 Channel
Stereo | 2 Channels

◆ Delay

enum Delay
strong

Using a duration of less than 10 ms will prevent the encoder from using the LPC or hybrid modes.

Enumerator
Delay2dot5ms | 2.5ms
Delay5ms | 5ms
Delay10ms | 10ms
Delay20ms | 20ms
Delay40ms | 40ms
Delay60ms | 60ms

◆ OpusApplicationType

enum OpusApplicationType : int
strong
Enumerator
Voip | Gives best quality at a given bitrate for voice signals. It enhances the input signal by high-pass filtering and emphasizing formants and harmonics. Optionally it includes in-band forward error correction to protect against packet loss. Use this mode for typical VoIP applications. Because of the enhancement, even at high bitrates the output may sound different from the input.
Audio | Gives best quality at a given bitrate for most non-voice signals like music. Use this mode for music and mixed (music/voice) content, broadcast, and applications requiring less than 15 ms of coding delay.
RestrictedLowDelay | Configures low-delay mode that disables the speech-optimized mode in exchange for slightly reduced delay.

◆ SignalHint

enum SignalHint : int
strong
Enumerator
Auto | (default)
Voice | Bias thresholds towards choosing LPC or Hybrid modes
Music | Bias thresholds towards choosing MDCT modes.


Photon Voice: OpusDecoder< T > Class Template Reference

Photon Voice v2.30

  • POpusCodec
  • OpusDecoder
Public Member Functions | Properties | List of all members
OpusDecoder< T > Class Template Reference

Inherits IDisposable.

Public Member Functions

OpusDecoder (SamplingRate outputSamplingRateHz, Channels numChannels)
T[] | DecodePacket (ref FrameBuffer packetData)
T[] | DecodeEndOfStream ()
void | Dispose ()

Properties

Bandwidth? PreviousPacketBandwidth [get]


Photon Voice: Member List

Photon Voice v2.30

  • POpusCodec
  • OpusDecoder
OpusDecoder< T > Member List

This is the complete list of members for OpusDecoder< T >, including all inherited members.

DecodeEndOfStream() (defined in OpusDecoder< T >) | OpusDecoder< T >
DecodePacket(ref FrameBuffer packetData) (defined in OpusDecoder< T >) | OpusDecoder< T >
Dispose() (defined in OpusDecoder< T >) | OpusDecoder< T >
OpusDecoder(SamplingRate outputSamplingRateHz, Channels numChannels) (defined in OpusDecoder< T >) | OpusDecoder< T >
PreviousPacketBandwidth (defined in OpusDecoder< T >) | OpusDecoder< T >


Photon Voice: OpusEncoder Class Reference

Photon Voice v2.30

  • POpusCodec
  • OpusEncoder
Public Member Functions | Static Public Attributes | Properties | List of all members
OpusEncoder Class Reference

Inherits IDisposable.

Public Member Functions

OpusEncoder (SamplingRate inputSamplingRateHz, Channels numChannels, int bitrate, OpusApplicationType applicationType, Delay encoderDelay)
ArraySegment< byte > | Encode (float[] pcmSamples)
ArraySegment< byte > | Encode (short[] pcmSamples)
void | Dispose ()

Static Public Attributes

const int BitrateMax = -1

Properties

SamplingRate | InputSamplingRate [get]
Channels | InputChannels [get]
Delay | EncoderDelay [get, set]
Using a duration of less than 10 ms will prevent the encoder from using the LPC or hybrid modes. More...
int | FrameSizePerChannel [get]
int | Bitrate [get, set]
Bandwidth | MaxBandwidth [get, set]
Complexity | Complexity [get, set]
int | ExpectedPacketLossPercentage [get, set]
SignalHint | SignalHint [get, set]
ForceChannels | ForceChannels [get, set]
bool? | UseInbandFEC [get, set]
int | PacketLossPercentage [get, set]
bool? | UseUnconstrainedVBR [get, set]
bool? | DtxEnabled [get, set]

Property Documentation

◆ EncoderDelay

Delay EncoderDelay
getset

Using a duration of less than 10 ms will prevent the encoder from using the LPC or hybrid modes.


Photon Voice: Member List

Photon Voice v2.30

  • POpusCodec
  • OpusEncoder
OpusEncoder Member List

This is the complete list of members for OpusEncoder, including all inherited members.

Bitrate (defined in OpusEncoder) | OpusEncoder |
BitrateMax (defined in OpusEncoder) | OpusEncoder | static
Complexity (defined in OpusEncoder) | OpusEncoder |
Dispose() (defined in OpusEncoder) | OpusEncoder |
DtxEnabled (defined in OpusEncoder) | OpusEncoder |
Encode(float[] pcmSamples) (defined in OpusEncoder) | OpusEncoder |
Encode(short[] pcmSamples) (defined in OpusEncoder) | OpusEncoder |
EncoderDelay | OpusEncoder |
ExpectedPacketLossPercentage (defined in OpusEncoder) | OpusEncoder |
ForceChannels (defined in OpusEncoder) | OpusEncoder |
FrameSizePerChannel (defined in OpusEncoder) | OpusEncoder |
InputChannels (defined in OpusEncoder) | OpusEncoder |
InputSamplingRate (defined in OpusEncoder) | OpusEncoder |
MaxBandwidth (defined in OpusEncoder) | OpusEncoder |
OpusEncoder(SamplingRate inputSamplingRateHz, Channels numChannels, int bitrate, OpusApplicationType applicationType, Delay encoderDelay) (defined in OpusEncoder) | OpusEncoder |
PacketLossPercentage (defined in OpusEncoder) | OpusEncoder |
SignalHint (defined in OpusEncoder) | OpusEncoder |
UseInbandFEC (defined in OpusEncoder) | OpusEncoder |
UseUnconstrainedVBR (defined in OpusEncoder) | OpusEncoder |


Photon Voice: OpusException Class Reference

Photon Voice v2.30

  • POpusCodec
  • OpusException
Public Member Functions | Properties | List of all members
OpusException Class Reference

Inherits Exception.

Public Member Functions

OpusException (OpusStatusCode statusCode, string message)

Properties

OpusStatusCode StatusCode [get]


Photon Voice: Member List

Photon Voice v2.30

  • POpusCodec
  • OpusException
OpusException Member List

This is the complete list of members for OpusException, including all inherited members.

OpusException(OpusStatusCode statusCode, string message) (defined in OpusException) | OpusException
StatusCode (defined in OpusException) | OpusException


Photon Voice: OpusLib Class Reference

Photon Voice v2.30

  • POpusCodec
  • OpusLib
Properties | List of all members
OpusLib Class Reference

Properties

static string Version [get]


Photon Voice: Member List

Photon Voice v2.30

  • POpusCodec
  • OpusLib
OpusLib Member List

This is the complete list of members for OpusLib, including all inherited members.

Version (defined in OpusLib) OpusLib static


Photon Voice: Class Index

Photon Voice v2.30

Class Index
a | b | c | d | e | f | i | l | m | n | o | p | r | s | t | u | v | w
a
e
ImageBufferNativeAlloc (Photon.Voice)
o
ImageBufferInfo.StrideSet (Photon.Voice)
ImageBufferNativeGCHandleSinglePlane (Photon.Voice)
t
AndroidAudioInAEC (Photon.Voice.Unity) OpusCodec.Encoder (Photon.Voice) ImageBufferNativePool (Photon.Voice) ObjectFactory (Photon.Voice)
AndroidAudioInParameters (Photon.Voice.Unity) RawCodec.Encoder (Photon.Voice) IProcessor (Photon.Voice) ObjectPool (Photon.Voice) AudioUtil.TempoUp (Photon.Voice)
AudioChangesHandler (Photon.Voice.Unity) OpusCodec.EncoderFloat (Photon.Voice) IResettable (Photon.Voice) OpusCodec (Photon.Voice) TestTone (Photon.Voice.Unity.UtilityScripts)
AudioClipWrapper (Photon.Voice.Unity) OpusCodec.EncoderShort (Photon.Voice) IServiceable (Photon.Voice) OpusDecoder (POpusCodec) AudioUtil.ToneAudioPusher (Photon.Voice)
AudioDesc (Photon.Voice)
f
AudioUtil.IVoiceDetector (Photon.Voice) OpusEncoder (POpusCodec) ToneAudioReader (Photon.Voice.Unity.UtilityScripts)
AudioInChangeNotifierNotSupported (Photon.Voice) IVoiceTransport (Photon.Voice) OpusException (POpusCodec) AudioUtil.ToneAudioReader (Photon.Voice)
AudioInEnumerator (Photon.Voice.Unity) OpusCodec.Factory (Photon.Voice)
l
OpusLib (POpusCodec)
u
AudioInEnumeratorEx (Photon.Voice.Unity) FactoryPrimitiveArrayPool (Photon.Voice)
p
AudioOutCapture (Photon.Voice.Unity) FactoryReusableArray (Photon.Voice) AudioUtil.LevelMeter (Photon.Voice) UnityAudioOut (Photon.Voice.Unity)
AudioOutDelayControl (Photon.Voice) Flip (Photon.Voice) AudioUtil.LevelMeterDummy (Photon.Voice) PhotonVoiceCreatedParams (Photon.Voice.Unity) UnityMicrophone (Photon.Voice.Unity)
AudioOutDelayControl (Photon.Voice) FrameBuffer (Photon.Voice) AudioUtil.LevelMeterFloat (Photon.Voice) Recorder.PhotonVoiceCreatedParams (Photon.Voice.Unity) UnsupportedCodecException (Photon.Voice)
AudioSessionParameters (Photon.Voice.IOS) FrameOut (Photon.Voice) AudioUtil.LevelMeterShort (Photon.Voice) PhotonVoiceLagSimulationGui (Photon.Voice.Unity.UtilityScripts) UnsupportedPlatformException (Photon.Voice)
AudioSessionParametersPresets (Photon.Voice.IOS) Framer (Photon.Voice) LoadBalancingFrontend (Photon.Voice) PhotonVoiceNetwork (Photon.Voice.PUN) UnsupportedSampleTypeException (Photon.Voice)
AudioSyncBuffer (Photon.Voice)
i
LoadBalancingTransport (Photon.Voice) PhotonVoiceStatsGui (Photon.Voice.Unity.UtilityScripts) OpusCodec.Util (Photon.Voice)
AudioUtil (Photon.Voice) LoadBalancingTransport2 (Photon.Voice) PhotonVoiceView (Photon.Voice.PUN)
v
b
IAudioDesc (Photon.Voice) LocalVoice (Photon.Voice) ImageBufferNative.PlaneSet (Photon.Voice)
IAudioInChangeNotifier (Photon.Voice) LocalVoiceAudio (Photon.Voice) Platform (Photon.Voice) VoiceClient (Photon.Voice)
BufferReaderPushAdapter (Photon.Voice) IAudioOut (Photon.Voice) LocalVoiceAudioDummy (Photon.Voice) PlaybackDelaySettings (Photon.Voice.Unity) VoiceComponent (Photon.Voice.Unity)
BufferReaderPushAdapterAsyncPool (Photon.Voice) IAudioPusher (Photon.Voice) LocalVoiceAudioFloat (Photon.Voice) AudioOutDelayControl.PlayDelayConfig (Photon.Voice) VoiceConnection (Photon.Voice.Unity)
BufferReaderPushAdapterAsyncPoolCopy (Photon.Voice) IAudioReader (Photon.Voice) LocalVoiceAudioShort (Photon.Voice) PrimitiveArrayPool (Photon.Voice) VoiceDebugScript (Photon.Voice.PUN.UtilityScripts)
BufferReaderPushAdapterAsyncPoolFloatToShort (Photon.Voice) IDataReader (Photon.Voice) LocalVoiceFramed (Photon.Voice)
r
AudioUtil.VoiceDetector (Photon.Voice)
BufferReaderPushAdapterAsyncPoolShortToFloat (Photon.Voice) IDecoder (Photon.Voice) LocalVoiceFramedBase (Photon.Voice) AudioUtil.VoiceDetectorCalibration (Photon.Voice)
BufferReaderPushAdapterBase (Photon.Voice) IDecoderDirect (Photon.Voice) Logger (Photon.Voice.Unity) RawCodec (Photon.Voice) AudioUtil.VoiceDetectorDummy (Photon.Voice)
c
IDeviceEnumerator (Photon.Voice)
m
Recorder (Photon.Voice.Unity) AudioUtil.VoiceDetectorFloat (Photon.Voice)
IEncoder (Photon.Voice) RemoteVoiceInfo (Photon.Voice) AudioUtil.VoiceDetectorShort (Photon.Voice)
ConnectAndJoin (Photon.Voice.Unity.UtilityScripts) IEncoderDirect (Photon.Voice) MicAmplifier (Photon.Voice.Unity.UtilityScripts) RemoteVoiceLink (Photon.Voice.Unity) VoiceEvent (Photon.Voice)
VoiceClient.CreateOptions (Photon.Voice) IEncoderDirectImage (Photon.Voice) MicAmplifierFloat (Photon.Voice.Unity.UtilityScripts) RemoteVoiceOptions (Photon.Voice) VoiceInfo (Photon.Voice)
d
AudioUtil.ILevelMeter (Photon.Voice) MicAmplifierShort (Photon.Voice.Unity.UtilityScripts) AudioUtil.Resampler (Photon.Voice) AudioUtil.VoiceLevelDetectCalibrate (Photon.Voice)
ILocalVoiceAudio (Photon.Voice) MicrophonePermission (Photon.Voice.Unity.UtilityScripts)
s
VoiceLogger (Photon.Voice.Unity)
OpusCodec.Decoder (Photon.Voice) ILoggable (Photon.Voice.Unity) MicWrapper (Photon.Voice.Unity)
w
RawCodec.Decoder (Photon.Voice) ILoggableDependent (Photon.Voice.Unity) MicWrapperPusher (Photon.Voice.Unity) SaveIncomingStreamToFile (Photon.Voice.Unity.UtilityScripts)
OpusCodec.DecoderFactory (Photon.Voice) ILogger (Photon.Voice)
n
SaveOutgoingStreamToFile (Photon.Voice.Unity.UtilityScripts) WebRtcAudioDsp (Photon.Voice.Unity)
DeviceEnumeratorBase (Photon.Voice) ImageBufferInfo (Photon.Voice) RawCodec.ShortToFloat (Photon.Voice) WebRTCAudioLib (Photon.Voice)
DeviceInfo (Photon.Voice) ImageBufferNative (Photon.Voice) NativeAndroidMicrophoneSettings (Photon.Voice.Unity) Speaker (Photon.Voice.Unity) WebRTCAudioProcessor (Photon.Voice)
a | b | c | d | e | f | i | l | m | n | o | p | r | s | t | u | v | w


Photon Voice: Class Hierarchy

Photon Voice v2.30

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12345]
C AndroidAudioInParameters |
C AudioInEnumeratorEx |
►C AudioOutDelayControl |
C AudioOutDelayControl< T > |
►C AudioOutDelayControl< float > |
C UnityAudioOut |
C AudioSessionParameters |
C AudioSessionParametersPresets |
C AudioUtil | Collection of Audio Utility functions and classes
►C BufferReaderPushAdapterBase< float > |
C BufferReaderPushAdapterAsyncPoolFloatToShort | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting float samples to short
►C BufferReaderPushAdapterBase< short > |
C BufferReaderPushAdapterAsyncPoolShortToFloat | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync, converting short samples to float
►C ConnectionHandler |
►C VoiceConnection | Component that represents a client voice connection to Photon Servers
C PhotonVoiceNetwork | This class can be used to automatically sync client states between PUN and Voice. It also sets a custom PUN Speaker factory to find the Speaker component for a character's voice. For this to work attach a PhotonVoiceView next to the PhotonView of your player's prefab
C VoiceClient.CreateOptions |
C OpusCodec.DecoderFactory |
C DeviceInfo |
►C OpusCodec.Encoder< float > |
C OpusCodec.EncoderFloat |
►C OpusCodec.Encoder< short > |
C OpusCodec.EncoderShort |
►C Exception |
C UnsupportedCodecException | Exception thrown if an unsupported codec is encountered
C UnsupportedPlatformException | Exception thrown if an unsupported platform is encountered
C UnsupportedSampleTypeException | Exception thrown if an unsupported audio sample type is encountered
C OpusException |
C OpusCodec.Factory |
C FactoryPrimitiveArrayPool< short > |
C Flip |
C FrameBuffer |
C FrameOut< T > |
C Framer< T > | Utility class to re-frame audio packets
C Framer< float > |
►C IAudioOut< T > |
C AudioOutDelayControl< T > |
C AudioSyncBuffer< T > |
C IAudioOut< float > |
►C IAudioPusher< float > |
C MicWrapperPusher |
►C IAudioPusher< short > |
C AndroidAudioInAEC |
►C IAudioReader< float > |
C AudioClipWrapper |
C MicWrapper |
C ToneAudioReader |
►C IConnectionCallbacks |
C ConnectAndJoin |
►C IDisposable |
►C IAudioDesc | Audio Source interface
C AudioDesc |
►C IAudioPusher< T > | Audio Pusher interface
C AudioUtil.ToneAudioPusher< T > | IAudioPusher that provides a constant tone signal
►C IAudioReader< T > | Audio Reader interface
C AudioUtil.ToneAudioReader< T > | IAudioReader that provides a constant tone signal
►C IAudioInChangeNotifier |
C AudioInChangeNotifierNotSupported |
►C IDataReader< T > | Interface for pulling data, in case this is more appropriate than pushing it
C IAudioReader< T > | Audio Reader interface
►C IDecoder | Generic decoder interface
C IDecoderDirect< B > | Interface for an decoder which outputs data via explicit call
C OpusCodec.Decoder< T > |
C RawCodec.Decoder< T > |
►C IDeviceEnumerator |
►C DeviceEnumeratorBase |
C AudioInEnumerator |
►C IEncoder | Generic encoder interface
C IEncoderDirect< B > | Interface for an encoder which consumes input data via explicit call
C ImageBufferNativeAlloc |
C ImageBufferNativeGCHandleSinglePlane |
►C IProcessor< T > | Audio Processor interface
C AudioUtil.LevelMeter< T > | Audio Level Meter
C AudioUtil.Resampler< T > | Sample-rate conversion Audio Processor
C AudioUtil.VoiceDetector< T > | Simple voice activity detector triggered by signal level
C AudioUtil.VoiceDetectorCalibration< T > | Calibration Utility for Voice Detector
C AudioUtil.VoiceLevelDetectCalibrate< T > | Utility Audio Processor Voice Detection Calibration
►C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
C LoadBalancingFrontend |
C LoadBalancingTransport2 | Variant of LoadBalancingTransport. Aims to be non-alloc at the cost of breaking compatibility with older clients
►C LocalVoice | Represents outgoing data stream
C LocalVoiceAudioDummy | Dummy LocalVoiceAudio
►C LocalVoiceFramedBase | Typed re-framing LocalVoice
►C LocalVoiceFramed< T > | Typed re-framing LocalVoice
C LocalVoiceAudio< T > | Outgoing audio stream
C ObjectFactory< TType, TInfo > | Uniform interface to ObjectPool<TType, TInfo> and single reusable object
C ObjectPool< TType, TInfo > | Generic Pool to re-use objects of a certain type (TType) that optionally match a certain property or set of properties (TInfo)
C VoiceClient | Voice client interact with other clients on network via IVoiceTransport
C OpusDecoder< T > |
C OpusEncoder |
►C IEncoderDirect< ImageBufferNative > |
C IEncoderDirectImage | Interface for an encoder which consumes images via explicit call
►C IEncoderDirect< T[]> |
C OpusCodec.Encoder< T > |
C RawCodec.Encoder< T > |
►C IEnumerable |
C IDeviceEnumerator |
►C IEquatable |
C RemoteVoiceLink |
►C AudioUtil.ILevelMeter | Audio Level Metering interface
C AudioUtil.LevelMeter< T > | Audio Level Meter
C AudioUtil.LevelMeterDummy | Dummy Audio Level Meter that doesn't actually do anything
►C ILocalVoiceAudio | Interface for an outgoing audio stream
C LocalVoiceAudio< T > | Outgoing audio stream
C LocalVoiceAudioDummy | Dummy LocalVoiceAudio
►C ILoggable |
►C ILoggableDependent |
►C VoiceComponent |
C PhotonVoiceView | Component that should be attached to a networked PUN prefab that has PhotonView. It will bind remote Recorder with local Speaker of the same networked prefab. This component makes automatic voice stream routing easy for players' characters/avatars
C AudioChangesHandler | This component is useful to handle audio device and config changes
C Recorder | Component representing outgoing audio stream in scene
C Speaker | Component representing remote audio stream in local scene
C MicAmplifier |
C MicrophonePermission | Helper to request Microphone permission on Android or iOS
C SaveIncomingStreamToFile |
C SaveOutgoingStreamToFile |
C WebRtcAudioDsp |
C VoiceConnection | Component that represents a client voice connection to Photon Servers
►C ILogger |
C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
C Logger |
C VoiceLogger |
C ImageBufferInfo |
►C ImageBufferNative |
C ImageBufferNativeAlloc |
C ImageBufferNativeGCHandleSinglePlane |
C ImageBufferNativePool< Photon.Voice.ImageBufferNativeAlloc > |
C ImageBufferNativePool< Photon.Voice.ImageBufferNativeGCHandleSinglePlane > |
►C IMatchmakingCallbacks |
C ConnectAndJoin |
►C IProcessor< float > |
C MicAmplifierFloat |
►C IProcessor< short > |
C MicAmplifierShort |
C WebRTCAudioProcessor |
►C IResettable |
C AndroidAudioInAEC |
►C IServiceable | Interface for classes that want their Service() function to be called regularly in the context of a LocalVoice
►C BufferReaderPushAdapterBase< T > | Adapter base reading data from IDataReader<T>.Read and pushing it to LocalVoice
C BufferReaderPushAdapter< T > | Simple BufferReaderPushAdapterBase<T> implementation using a single buffer and synchronous LocalVoiceFramed<T>.PushData
C BufferReaderPushAdapterAsyncPool< T > | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync
C BufferReaderPushAdapterAsyncPoolCopy< T > | BufferReaderPushAdapter<T> implementation using asynchronous LocalVoiceFramed<T>.PushDataAsync(T[]) and data copy
►C AudioUtil.IVoiceDetector | Voice Activity Detector interface
C AudioUtil.VoiceDetector< T > | Simple voice activity detector triggered by signal level
C AudioUtil.VoiceDetectorDummy | Dummy VoiceDetector that doesn't actually do anything
►C IVoiceTransport |
C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
►C AudioUtil.LevelMeter< float > |
C AudioUtil.LevelMeterFloat | LevelMeter specialization for float audio
►C AudioUtil.LevelMeter< short > |
C AudioUtil.LevelMeterShort | LevelMeter specialization for short audio
►C LoadBalancingClient |
C LoadBalancingTransport | Extends LoadBalancingClient with media streaming functionality
►C LocalVoiceAudio< float > |
C LocalVoiceAudioFloat | Specialization of LocalVoiceAudio<T> for float audio
►C LocalVoiceAudio< short > |
C LocalVoiceAudioShort | Specialization of LocalVoiceAudio<T> for short audio
►C MonoBehaviour |
C AudioOutCapture |
C ConnectAndJoin |
C PhotonVoiceLagSimulationGui |
C PhotonVoiceStatsGui | Basic GUI to show traffic and health statistics of the connection to Photon, toggled by shift+tab
C TestTone |
C VoiceComponent |
►C MonoBehaviourPun |
C VoiceDebugScript | Utility script to be attached next to PhotonVoiceView & PhotonView on the player prefab to be network instantiated. Call voiceDebugScript.CantHearYou() on the networked object of the remote (or local) player if you can't hear the corresponding player
C NativeAndroidMicrophoneSettings |
►C ObjectFactory< T[], int > |
C FactoryPrimitiveArrayPool< T > | PrimitiveArrayPool<T> as wrapped in object factory interface
C FactoryReusableArray< T > | Array factory returnig the same array instance as long as it requested with the same array length. If length changes, new array instance created
►C ObjectPool< T, ImageBufferInfo > |
C ImageBufferNativePool< T > |
►C ObjectPool< T[], int > |
C PrimitiveArrayPool< T > | Pool of Arrays with components of type T, with ObjectPool info being the array's size
C OpusCodec |
C OpusLib |
►C PhotonVoiceCreatedParams |
C Recorder.PhotonVoiceCreatedParams |
C ImageBufferNative.PlaneSet |
C Platform |
C PlaybackDelaySettings | Playback delay configuration container
C AudioOutDelayControl.PlayDelayConfig |
C RawCodec |
C RemoteVoiceInfo | Information about a remote voice (incoming stream)
C RemoteVoiceOptions | Event Actions and other options for a remote voice (incoming stream)
C RawCodec.ShortToFloat |
C ImageBufferInfo.StrideSet |
C AudioUtil.TempoUp< T > |
C UnityMicrophone | A wrapper around UnityEngine.Microphone to be able to safely use Microphone and compile for WebGL
C OpusCodec.Util |
►C AudioUtil.VoiceDetector< float > |
C AudioUtil.VoiceDetectorFloat | VoiceDetector specialization for float audio
►C AudioUtil.VoiceDetector< short > |
C AudioUtil.VoiceDetectorShort | VoiceDetector specialization for float audio
C VoiceEvent |
C VoiceInfo | Describes stream properties
►C WebRTCAudioLib |
C WebRTCAudioProcessor |


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AccumAvgPeakAmp : AudioUtil.ILevelMeter
  • AcquireOrCreate() : ObjectPool< TType, TInfo >
  • ActivityDelayMs : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • Actor : Speaker
  • AddPostProcessor() : LocalVoiceFramed< T >
  • AddPreProcessor() : LocalVoiceFramed< T >
  • AudioClip : Recorder
  • AudioGroup : Recorder
  • AutoConnectAndJoin : PhotonVoiceNetwork
  • AutoCreateRecorderIfNotFound : PhotonVoiceView
  • AutoCreateSpeakerIfNotFound : VoiceConnection
  • AutoLeaveAndDisconnect : PhotonVoiceNetwork
  • AutoStart : Recorder


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BestRegionSummaryInPreferences : VoiceConnection
  • Bitrate : Recorder , VoiceInfo
  • BufferReaderPushAdapter() : BufferReaderPushAdapter< T >
  • BufferReaderPushAdapterAsyncPool() : BufferReaderPushAdapterAsyncPool< T >
  • BufferReaderPushAdapterAsyncPoolCopy() : BufferReaderPushAdapterAsyncPoolCopy< T >
  • BufferReaderPushAdapterAsyncPoolFloatToShort() : BufferReaderPushAdapterAsyncPoolFloatToShort
  • BufferReaderPushAdapterAsyncPoolShortToFloat() : BufferReaderPushAdapterAsyncPoolShortToFloat
  • BufferReaderPushAdapterBase() : BufferReaderPushAdapterBase< T >


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • Calibrate() : AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T >
  • ChannelId : RemoteVoiceInfo
  • Channels : AudioUtil.ToneAudioReader< T > , IAudioDesc , VoiceInfo
  • ClearProcessors() : LocalVoiceFramed< T >
  • ClientState : VoiceConnection
  • Code : VoiceEvent
  • ConnectAndJoinRoom() : PhotonVoiceNetwork
  • ConnectUsingSettings() : VoiceConnection
  • Convert() : AudioUtil
  • Count() : Framer< T >
  • Create() : LocalVoiceAudio< T >
  • CreateAudio() : VoiceInfo
  • CreateAudioOpus() : VoiceInfo
  • CreateLocalVoice() : VoiceClient
  • CreateLocalVoiceAudioFromSource() : VoiceClient
  • CreateLocalVoiceFramed< T >() : VoiceClient
  • CurrentAvgAmp : AudioUtil.ILevelMeter
  • CurrentPeakAmp : AudioUtil.ILevelMeter
  • CustomAudioOutFactory : Speaker


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DebugEchoMode : LocalVoice , Recorder
  • DebugLostPercent : VoiceClient
  • Decoder : RemoteVoiceOptions
  • DequeueOutput() : IEncoder
  • Detected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • DetectedTime : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • DisableVad : VoiceDebugScript
  • Disconnect() : PhotonVoiceNetwork
  • Dispatch() : VoiceConnection
  • Dispose() : BufferReaderPushAdapterBase< T > , LoadBalancingTransport , LocalVoiceFramed< T > , ObjectPool< TType, TInfo >
  • Dummy : LocalVoiceAudioDummy


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EncoderDelay : OpusEncoder
  • Encrypt : LocalVoice , Recorder
  • EndOfStream() : IEncoder
  • Error : AudioUtil.ToneAudioReader< T > , IAudioDesc , IDecoder , IEncoder


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • ForceRecordingAndTransmission : VoiceDebugScript
  • ForceToStereo< T >() : AudioUtil
  • FPS : VoiceInfo
  • Frame() : Framer< T >
  • FrameDuration : Recorder
  • FrameDurationSamples : VoiceInfo
  • FrameDurationUs : VoiceInfo
  • Framer() : Framer< T >
  • FrameSize : LocalVoiceFramedBase , VoiceInfo
  • FramesLost : VoiceClient
  • FramesLostPercent : VoiceConnection
  • FramesLostPerSecond : VoiceConnection
  • FramesReceived : VoiceClient
  • FramesReceivedPerSecond : VoiceConnection
  • FramesSent : LocalVoice , VoiceClient
  • FramesSentBytes : LocalVoice , VoiceClient


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GetPlatformAPI< I >() : IEncoder
  • GlobalInterestGroup : LoadBalancingTransport
  • GlobalPlaybackDelayMaxHard : VoiceConnection
  • GlobalPlaybackDelayMaxSoft : VoiceConnection
  • GlobalPlaybackDelayMinSoft : VoiceConnection


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HandleConfigChange : AudioChangesHandler
  • HandleDeviceChange : AudioChangesHandler
  • Height : VoiceInfo


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • ImageFormat : IEncoderDirectImage
  • IncreaseLogLevels : VoiceDebugScript
  • Info : LocalVoice , ObjectPool< TType, TInfo > , RemoteVoiceInfo
  • Init() : ObjectPool< TType, TInfo > , PhotonVoiceView , Recorder
  • InitRecorder() : VoiceConnection
  • Input() : IDecoder , IEncoderDirect< B > , OpusCodec.Decoder< T > , RawCodec.Decoder< T >
  • InputFactory : Recorder
  • Instance : PhotonVoiceNetwork
  • InterestGroup : LocalVoice , Recorder
  • IsCurrentlyTransmitting : LocalVoice , Recorder
  • IsInitialized : Recorder
  • IsLinked : Speaker
  • IsPhotonViewReady : PhotonVoiceView
  • IsPlaying : Speaker
  • IsRecorder : PhotonVoiceView
  • IsRecording : PhotonVoiceView , Recorder
  • IsSetup : PhotonVoiceView
  • IsSpeaker : PhotonVoiceView
  • IsSpeakerLinked : PhotonVoiceView
  • IsSpeaking : PhotonVoiceView


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KeyFrameInt : VoiceInfo


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Lag : Speaker
  • LevelMeter : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • LevelMeterFloat() : AudioUtil.LevelMeterFloat
  • LevelMeterShort() : AudioUtil.LevelMeterShort
  • LoadBalancingTransport() : LoadBalancingTransport
  • LocalDebug : VoiceDebugScript
  • LocalUserServiceable : LocalVoice
  • LocalVoices : VoiceClient
  • LocalVoicesInChannel() : VoiceClient
  • Logger : VoiceConnection
  • LogLevel : VoiceConnection
  • LoopAudioClip : Recorder


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MaxDatagrams : VoiceConnection
  • MaxDelayHard : PlaybackDelaySettings
  • MaxDelaySoft : PlaybackDelaySettings
  • MicrophoneType : Recorder
  • MinDelaySoft : PlaybackDelaySettings
  • MinimalTimeScaleToDispatchInFixedUpdate : VoiceConnection


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • ObjectPool() : ObjectPool< TType, TInfo >
  • On : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • OnDetected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • OnRemoteVoiceInfoAction : VoiceClient
  • OnRemoteVoiceRemoveAction : RemoteVoiceOptions , Speaker
  • Open() : IDecoder , OpusCodec.Decoder< T > , RawCodec.Decoder< T >
  • Output : IDecoderDirect< B > , IEncoder


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PhotonMicrophoneDeviceId : Recorder
  • PhotonMicrophoneEnumerator : Recorder
  • PlaybackDelayMaxHard : Speaker
  • PlaybackDelayMaxSoft : Speaker
  • PlaybackDelayMinSoft : Speaker
  • PlaybackOnlyWhenEnabled : Speaker
  • PlaybackStarted : Speaker
  • PlayerId : RemoteVoiceInfo
  • PrimaryRecorder : VoiceConnection
  • Process() : AudioUtil.LevelMeter< T > , AudioUtil.Resampler< T > , AudioUtil.VoiceDetector< T > , AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T > , IProcessor< T >
  • PushData() : LocalVoiceFramed< T >
  • PushDataAsync() : LocalVoiceFramed< T >
  • PushDataAsyncReady : LocalVoiceFramed< T >


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • ReactOnSystemChanges : Recorder
  • Read() : AudioUtil.ToneAudioReader< T > , IDataReader< T >
  • RecorderInUse : PhotonVoiceView
  • RecordOnlyWhenEnabled : Recorder
  • RecordOnlyWhenJoined : Recorder
  • Release() : ObjectPool< TType, TInfo >
  • Reliable : LocalVoice
  • ReliableMode : Recorder
  • RemoteVoiceAdded : VoiceConnection
  • RemoteVoiceInfoDelegate() : VoiceClient
  • RemoteVoiceInfos : VoiceClient
  • RemoveLocalVoice() : VoiceClient
  • RemoveSelf() : LocalVoice
  • RequiresRestart : Recorder
  • Resample< T >() : AudioUtil
  • ResampleAndConvert() : AudioUtil
  • Resampler() : AudioUtil.Resampler< T >
  • ResetAccumAvgPeakAmp() : AudioUtil.ILevelMeter , AudioUtil.LevelMeter< T > , AudioUtil.LevelMeterDummy
  • ResetLocalAudio() : Recorder
  • RestartPlayback() : Speaker
  • RestartRecording() : Recorder
  • RoundTripTime : VoiceClient
  • RoundTripTimeVariance : VoiceClient


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SamplingRate : AudioUtil.ToneAudioReader< T > , IAudioDesc , Recorder , VoiceInfo
  • SendAsap : VoiceConnection
  • SendSpacingProfileMax : LocalVoice
  • Service() : BufferReaderPushAdapter< T > , BufferReaderPushAdapterAsyncPool< T > , BufferReaderPushAdapterAsyncPoolCopy< T > , BufferReaderPushAdapterAsyncPoolFloatToShort , BufferReaderPushAdapterAsyncPoolShortToFloat , BufferReaderPushAdapterBase< T > , IServiceable , LoadBalancingTransport , VoiceClient
  • SetCallback() : AudioUtil.ToneAudioPusher< T > , IAudioPusher< T >
  • SetGlobalPlaybackDelaySettings() : VoiceConnection
  • SetOrSwitchAudioListener() : WebRtcAudioDsp
  • SetOrSwitchAudioOutCapture() : WebRtcAudioDsp
  • SetOutput() : RemoteVoiceOptions
  • SetPlaybackDelaySettings() : Speaker , VoiceConnection
  • Settings : VoiceConnection
  • SetupDebugSpeaker : PhotonVoiceView
  • SkipDeviceChangeChecks : Recorder
  • SourceType : Recorder
  • SpeakerFactory : VoiceConnection
  • SpeakerInUse : PhotonVoiceView
  • SpeakerLinked : VoiceConnection
  • SpeakerPrefab : VoiceConnection
  • StartPlayback() : Speaker
  • StartRecording() : Recorder
  • StartWhenDeviceChange : AudioChangesHandler
  • StopPlayback() : Speaker
  • StopRecording() : Recorder
  • StopRecordingWhenPaused : Recorder
  • SuppressInfoDuplicateWarning : VoiceClient


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TestAudioClip : VoiceDebugScript
  • TestUsingAudioClip : VoiceDebugScript
  • Threshold : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • ToneAudioPusher() : AudioUtil.ToneAudioPusher< T >
  • ToneAudioReader() : AudioUtil.ToneAudioReader< T >
  • TransmitEnabled : LocalVoice , Recorder
  • TryLateLinkingUsingUserData() : VoiceConnection
  • TrySamplingRateMatch : Recorder
  • TypeConvert : Recorder


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UnityMicrophoneDevice : Recorder
  • UnsupportedCodecException() : UnsupportedCodecException
  • UnsupportedPlatformException() : UnsupportedPlatformException
  • UnsupportedSampleTypeException() : UnsupportedSampleTypeException
  • UseMicrophoneTypeFallback : Recorder
  • UseNativePluginChangeNotifier : AudioChangesHandler
  • UseOnAudioConfigurationChanged : AudioChangesHandler
  • UseOnAudioFilterRead : Recorder
  • UsePrimaryRecorder : PhotonVoiceView
  • UsePunAuthValues : PhotonVoiceNetwork
  • UserData : Recorder , VoiceInfo


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • VoiceClient : LoadBalancingTransport , VoiceConnection , VoiceClient
  • VoiceDetection : Recorder
  • VoiceDetectionDelayMs : Recorder
  • VoiceDetectionThreshold : Recorder
  • VoiceDetector : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • VoiceDetectorCalibrate() : ILocalVoiceAudio , LocalVoiceAudio< T > , LocalVoiceAudioDummy , Recorder
  • VoiceDetectorCalibrating : ILocalVoiceAudio , LocalVoiceAudio< T > , Recorder
  • VoiceDetectorCalibration() : AudioUtil.VoiceDetectorCalibration< T >
  • VoiceDetectorFloat() : AudioUtil.VoiceDetectorFloat
  • VoiceDetectorShort() : AudioUtil.VoiceDetectorShort
  • VoiceId : RemoteVoiceInfo
  • VoiceLevelDetectCalibrate() : AudioUtil.VoiceLevelDetectCalibrate< T >
  • VoiceRoomNameSuffix : PhotonVoiceNetwork


Photon Voice: Class Members

Photon Voice v2.30

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • Width : VoiceInfo
  • WorkInOfflineMode : PhotonVoiceNetwork


Photon Voice: Class Members - Functions

Photon Voice v2.30

- a -

  • AcquireOrCreate() : ObjectPool< TType, TInfo >
  • AddPostProcessor() : LocalVoiceFramed< T >
  • AddPreProcessor() : LocalVoiceFramed< T >

- b -

  • BufferReaderPushAdapter() : BufferReaderPushAdapter< T >
  • BufferReaderPushAdapterAsyncPool() : BufferReaderPushAdapterAsyncPool< T >
  • BufferReaderPushAdapterAsyncPoolCopy() : BufferReaderPushAdapterAsyncPoolCopy< T >
  • BufferReaderPushAdapterAsyncPoolFloatToShort() : BufferReaderPushAdapterAsyncPoolFloatToShort
  • BufferReaderPushAdapterAsyncPoolShortToFloat() : BufferReaderPushAdapterAsyncPoolShortToFloat
  • BufferReaderPushAdapterBase() : BufferReaderPushAdapterBase< T >

- c -

  • Calibrate() : AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T >
  • ClearProcessors() : LocalVoiceFramed< T >
  • ConnectAndJoinRoom() : PhotonVoiceNetwork
  • ConnectUsingSettings() : VoiceConnection
  • Convert() : AudioUtil
  • Count() : Framer< T >
  • Create() : LocalVoiceAudio< T >
  • CreateAudio() : VoiceInfo
  • CreateAudioOpus() : VoiceInfo
  • CreateLocalVoice() : VoiceClient
  • CreateLocalVoiceAudioFromSource() : VoiceClient
  • CreateLocalVoiceFramed< T >() : VoiceClient

- d -

  • DequeueOutput() : IEncoder
  • Disconnect() : PhotonVoiceNetwork
  • Dispatch() : VoiceConnection
  • Dispose() : BufferReaderPushAdapterBase< T > , LoadBalancingTransport , LocalVoiceFramed< T > , ObjectPool< TType, TInfo >

- e -

  • EndOfStream() : IEncoder

- f -

  • ForceToStereo< T >() : AudioUtil
  • Frame() : Framer< T >
  • Framer() : Framer< T >

- g -

  • GetPlatformAPI< I >() : IEncoder

- i -

  • Init() : ObjectPool< TType, TInfo > , PhotonVoiceView , Recorder
  • InitRecorder() : VoiceConnection
  • Input() : IDecoder , IEncoderDirect< B > , OpusCodec.Decoder< T > , RawCodec.Decoder< T >

- l -

  • LevelMeterFloat() : AudioUtil.LevelMeterFloat
  • LevelMeterShort() : AudioUtil.LevelMeterShort
  • LoadBalancingTransport() : LoadBalancingTransport
  • LocalVoicesInChannel() : VoiceClient

- o -

  • ObjectPool() : ObjectPool< TType, TInfo >
  • Open() : IDecoder , OpusCodec.Decoder< T > , RawCodec.Decoder< T >

- p -

  • Process() : AudioUtil.LevelMeter< T > , AudioUtil.Resampler< T > , AudioUtil.VoiceDetector< T > , AudioUtil.VoiceDetectorCalibration< T > , AudioUtil.VoiceLevelDetectCalibrate< T > , IProcessor< T >
  • PushData() : LocalVoiceFramed< T >
  • PushDataAsync() : LocalVoiceFramed< T >

- r -

  • Read() : AudioUtil.ToneAudioReader< T > , IDataReader< T >
  • Release() : ObjectPool< TType, TInfo >
  • RemoteVoiceInfoDelegate() : VoiceClient
  • RemoveLocalVoice() : VoiceClient
  • RemoveSelf() : LocalVoice
  • Resample< T >() : AudioUtil
  • ResampleAndConvert() : AudioUtil
  • Resampler() : AudioUtil.Resampler< T >
  • ResetAccumAvgPeakAmp() : AudioUtil.ILevelMeter , AudioUtil.LevelMeter< T > , AudioUtil.LevelMeterDummy
  • ResetLocalAudio() : Recorder
  • RestartPlayback() : Speaker
  • RestartRecording() : Recorder

- s -

  • Service() : BufferReaderPushAdapter< T > , BufferReaderPushAdapterAsyncPool< T > , BufferReaderPushAdapterAsyncPoolCopy< T > , BufferReaderPushAdapterAsyncPoolFloatToShort , BufferReaderPushAdapterAsyncPoolShortToFloat , BufferReaderPushAdapterBase< T > , IServiceable , LoadBalancingTransport , VoiceClient
  • SetCallback() : AudioUtil.ToneAudioPusher< T > , IAudioPusher< T >
  • SetGlobalPlaybackDelaySettings() : VoiceConnection
  • SetOrSwitchAudioListener() : WebRtcAudioDsp
  • SetOrSwitchAudioOutCapture() : WebRtcAudioDsp
  • SetOutput() : RemoteVoiceOptions
  • SetPlaybackDelaySettings() : Speaker , VoiceConnection
  • StartPlayback() : Speaker
  • StartRecording() : Recorder
  • StopPlayback() : Speaker
  • StopRecording() : Recorder

- t -

  • ToneAudioPusher() : AudioUtil.ToneAudioPusher< T >
  • ToneAudioReader() : AudioUtil.ToneAudioReader< T >
  • TryLateLinkingUsingUserData() : VoiceConnection

- u -

  • UnsupportedCodecException() : UnsupportedCodecException
  • UnsupportedPlatformException() : UnsupportedPlatformException
  • UnsupportedSampleTypeException() : UnsupportedSampleTypeException

- v -

  • VoiceClient() : VoiceClient
  • VoiceDetectorCalibrate() : ILocalVoiceAudio , LocalVoiceAudio< T > , LocalVoiceAudioDummy , Recorder
  • VoiceDetectorCalibration() : AudioUtil.VoiceDetectorCalibration< T >
  • VoiceDetectorFloat() : AudioUtil.VoiceDetectorFloat
  • VoiceDetectorShort() : AudioUtil.VoiceDetectorShort
  • VoiceLevelDetectCalibrate() : AudioUtil.VoiceLevelDetectCalibrate< T >


Photon Voice: Class Members - Variables

Photon Voice v2.30

  • AutoConnectAndJoin : PhotonVoiceNetwork
  • AutoCreateRecorderIfNotFound : PhotonVoiceView
  • AutoCreateSpeakerIfNotFound : VoiceConnection
  • AutoLeaveAndDisconnect : PhotonVoiceNetwork
  • Code : VoiceEvent
  • CustomAudioOutFactory : Speaker
  • DisableVad : VoiceDebugScript
  • Dummy : LocalVoiceAudioDummy
  • ForceRecordingAndTransmission : VoiceDebugScript
  • HandleConfigChange : AudioChangesHandler
  • HandleDeviceChange : AudioChangesHandler
  • IncreaseLogLevels : VoiceDebugScript
  • LocalDebug : VoiceDebugScript
  • MaxDatagrams : VoiceConnection
  • MaxDelayHard : PlaybackDelaySettings
  • MaxDelaySoft : PlaybackDelaySettings
  • MinDelaySoft : PlaybackDelaySettings
  • MinimalTimeScaleToDispatchInFixedUpdate : VoiceConnection
  • SendAsap : VoiceConnection
  • Settings : VoiceConnection
  • SetupDebugSpeaker : PhotonVoiceView
  • SpeakerFactory : VoiceConnection
  • StartWhenDeviceChange : AudioChangesHandler
  • TestAudioClip : VoiceDebugScript
  • TestUsingAudioClip : VoiceDebugScript
  • UseNativePluginChangeNotifier : AudioChangesHandler
  • UseOnAudioConfigurationChanged : AudioChangesHandler
  • UsePrimaryRecorder : PhotonVoiceView
  • VoiceRoomNameSuffix : PhotonVoiceNetwork
  • WorkInOfflineMode : PhotonVoiceNetwork


Photon Voice: Class Members - Properties

Photon Voice v2.30

- a -

  • AccumAvgPeakAmp : AudioUtil.ILevelMeter
  • ActivityDelayMs : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • Actor : Speaker
  • AudioClip : Recorder
  • AudioGroup : Recorder
  • AutoStart : Recorder

- b -

  • BestRegionSummaryInPreferences : VoiceConnection
  • Bitrate : Recorder , VoiceInfo

- c -

  • ChannelId : RemoteVoiceInfo
  • Channels : AudioUtil.ToneAudioReader< T > , IAudioDesc , VoiceInfo
  • ClientState : VoiceConnection
  • CurrentAvgAmp : AudioUtil.ILevelMeter
  • CurrentPeakAmp : AudioUtil.ILevelMeter

- d -

  • DebugEchoMode : LocalVoice , Recorder
  • DebugLostPercent : VoiceClient
  • Decoder : RemoteVoiceOptions
  • Detected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • DetectedTime : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >

- e -

  • EncoderDelay : OpusEncoder
  • Encrypt : LocalVoice , Recorder
  • Error : AudioUtil.ToneAudioReader< T > , IAudioDesc , IDecoder , IEncoder

- f -

  • FPS : VoiceInfo
  • FrameDuration : Recorder
  • FrameDurationSamples : VoiceInfo
  • FrameDurationUs : VoiceInfo
  • FrameSize : LocalVoiceFramedBase , VoiceInfo
  • FramesLost : VoiceClient
  • FramesLostPercent : VoiceConnection
  • FramesLostPerSecond : VoiceConnection
  • FramesReceived : VoiceClient
  • FramesReceivedPerSecond : VoiceConnection
  • FramesSent : LocalVoice , VoiceClient
  • FramesSentBytes : LocalVoice , VoiceClient

- g -

  • GlobalInterestGroup : LoadBalancingTransport
  • GlobalPlaybackDelayMaxHard : VoiceConnection
  • GlobalPlaybackDelayMaxSoft : VoiceConnection
  • GlobalPlaybackDelayMinSoft : VoiceConnection

- h -

  • Height : VoiceInfo

- i -

  • ImageFormat : IEncoderDirectImage
  • Info : LocalVoice , ObjectPool< TType, TInfo > , RemoteVoiceInfo
  • InputFactory : Recorder
  • Instance : PhotonVoiceNetwork
  • InterestGroup : LocalVoice , Recorder
  • IsCurrentlyTransmitting : LocalVoice , Recorder
  • IsInitialized : Recorder
  • IsLinked : Speaker
  • IsPhotonViewReady : PhotonVoiceView
  • IsPlaying : Speaker
  • IsRecorder : PhotonVoiceView
  • IsRecording : PhotonVoiceView , Recorder
  • IsSetup : PhotonVoiceView
  • IsSpeaker : PhotonVoiceView
  • IsSpeakerLinked : PhotonVoiceView
  • IsSpeaking : PhotonVoiceView

- k -

  • KeyFrameInt : VoiceInfo

- l -

  • Lag : Speaker
  • LevelMeter : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • LocalUserServiceable : LocalVoice
  • LocalVoices : VoiceClient
  • Logger : VoiceConnection
  • LogLevel : VoiceConnection
  • LoopAudioClip : Recorder

- m -

  • MicrophoneType : Recorder

- o -

  • On : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • OnRemoteVoiceInfoAction : VoiceClient
  • OnRemoteVoiceRemoveAction : RemoteVoiceOptions , Speaker
  • Output : IDecoderDirect< B > , IEncoder

- p -

  • PhotonMicrophoneDeviceId : Recorder
  • PhotonMicrophoneEnumerator : Recorder
  • PlaybackDelayMaxHard : Speaker
  • PlaybackDelayMaxSoft : Speaker
  • PlaybackDelayMinSoft : Speaker
  • PlaybackOnlyWhenEnabled : Speaker
  • PlaybackStarted : Speaker
  • PlayerId : RemoteVoiceInfo
  • PrimaryRecorder : VoiceConnection
  • PushDataAsyncReady : LocalVoiceFramed< T >

- r -

  • ReactOnSystemChanges : Recorder
  • RecorderInUse : PhotonVoiceView
  • RecordOnlyWhenEnabled : Recorder
  • RecordOnlyWhenJoined : Recorder
  • Reliable : LocalVoice
  • ReliableMode : Recorder
  • RemoteVoiceInfos : VoiceClient
  • RequiresRestart : Recorder
  • RoundTripTime : VoiceClient
  • RoundTripTimeVariance : VoiceClient

- s -

  • SamplingRate : AudioUtil.ToneAudioReader< T > , IAudioDesc , Recorder , VoiceInfo
  • SendSpacingProfileMax : LocalVoice
  • SkipDeviceChangeChecks : Recorder
  • SourceType : Recorder
  • SpeakerInUse : PhotonVoiceView
  • SpeakerPrefab : VoiceConnection
  • StopRecordingWhenPaused : Recorder
  • SuppressInfoDuplicateWarning : VoiceClient

- t -

  • Threshold : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • TransmitEnabled : LocalVoice , Recorder
  • TrySamplingRateMatch : Recorder
  • TypeConvert : Recorder

- u -

  • UnityMicrophoneDevice : Recorder
  • UseMicrophoneTypeFallback : Recorder
  • UseOnAudioFilterRead : Recorder
  • UsePunAuthValues : PhotonVoiceNetwork
  • UserData : Recorder , VoiceInfo

- v -

  • VoiceClient : LoadBalancingTransport , VoiceConnection
  • VoiceDetection : Recorder
  • VoiceDetectionDelayMs : Recorder
  • VoiceDetectionThreshold : Recorder
  • VoiceDetector : AudioUtil.VoiceLevelDetectCalibrate< T > , ILocalVoiceAudio , Recorder
  • VoiceDetectorCalibrating : ILocalVoiceAudio , LocalVoiceAudio< T > , Recorder
  • VoiceId : RemoteVoiceInfo

- w -

  • Width : VoiceInfo


Photon Voice: Class Members - Events

Photon Voice v2.30

  • OnDetected : AudioUtil.IVoiceDetector , AudioUtil.VoiceDetector< T >
  • RemoteVoiceAdded : VoiceConnection
  • SpeakerLinked : VoiceConnection


Photon Voice: Member List

Photon Voice v2.30

  • LoadBalancingTransport
LoadBalancingTransport Member List

This is the complete list of members for LoadBalancingTransport, including all inherited members.

ChangeAudioGroups(byte[] groupsToRemove, byte[] groupsToAdd) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
ChannelIdStr(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Dispose() | LoadBalancingTransport |
GlobalAudioGroup (defined in LoadBalancingTransport) | LoadBalancingTransport |
GlobalInterestGroup | LoadBalancingTransport |
IsChannelJoined(int channelId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LoadBalancingTransport(ILogger logger=null, ConnectionProtocol connectionProtocol=ConnectionProtocol.Udp) | LoadBalancingTransport |
LogDebug(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogError(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogInfo(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
LogWarning(string fmt, params object[] args) (defined in LoadBalancingTransport) | LoadBalancingTransport |
onEventActionVoiceClient(EventData ev) (defined in LoadBalancingTransport) | LoadBalancingTransport | protectedvirtual
PlayerIdStr(int playerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendFrame(ArraySegment< byte > data, FrameFlags flags, byte evNumber, byte voiceId, int channelId, int targetPlayerId, bool reliable, LocalVoice localVoice) (defined in LoadBalancingTransport) | LoadBalancingTransport | virtual
SendVoiceRemove(LocalVoice voice, int channelId, int targetPlayerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
SendVoicesInfo(IEnumerable< LocalVoice > voices, int channelId, int targetPlayerId) (defined in LoadBalancingTransport) | LoadBalancingTransport |
Service() | LoadBalancingTransport |
voiceClient (defined in LoadBalancingTransport) | LoadBalancingTransport | protected
VoiceClient | LoadBalancingTransport |


Photon Voice: Enums Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Core
  • POpusCodec
  • Enums
Enums Directory Reference


Photon Voice: Photon Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
Photon Directory Reference


Photon Voice: Unity Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Unity
Unity Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Core Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Core
Core Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: UtilityScripts Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • Code
  • PUN
  • UtilityScripts
UtilityScripts Directory Reference


Photon Voice: PUN Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • Code
  • PUN
PUN Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Apple Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Apple
Apple Directory Reference


Photon Voice: Android Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Unity
  • Android
Android Directory Reference


Photon Voice: img Directory Reference

Photon Voice v2.30

  • img
img Directory Reference


Photon Voice: MicAmplifier Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • Code
  • UtilityScripts
  • MicAmplifier
MicAmplifier Directory Reference


Photon Voice: Assets Directory Reference

Photon Voice v2.30

  • Assets
Assets Directory Reference


Photon Voice: Windows Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • Windows
Windows Directory Reference


Photon Voice: PhotonVoiceApi Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
PhotonVoiceApi Directory Reference

Directories

directory Platforms


Photon Voice: POpusCodec Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Core
  • POpusCodec
POpusCodec Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: UWP Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • UWP
UWP Directory Reference


Photon Voice: PhotonVoice Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
PhotonVoice Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Code Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • Code
Code Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: FMOD Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
  • FMOD
FMOD Directory Reference


Photon Voice: UtilityScripts Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • Code
  • UtilityScripts
UtilityScripts Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Platforms Directory Reference

Photon Voice v2.30

  • Assets
  • Photon
  • PhotonVoice
  • PhotonVoiceApi
  • Platforms
Platforms Directory Reference

Directories

© Exit Games ®, all rights reserved.
Documentation Contact Terms Status


Photon Voice: Main Page

Photon Voice v2.30

Photon Voice Documentation

Photon Voice 2 has three key classes:

  • Photon.Voice.Unity.VoiceConnection (extends Photon.Realtime.ConnectionHandler)
  • Photon.Voice.Unity.Recorder
  • Photon.Voice.Unity.Speaker

If you also use the integration with PUN 2, we added two components for ease-of-use and more convenience:

  • Photon.Voice.PUN.PhotonVoiceNetwork
  • Photon.Voice.PUN.PhotonVoiceView

Photon Voice 2 also comes with a WebRTC based DSP (Photon.Voice.Unity.WebRtcAudioDsp using Photon.Voice.WebRTCAudioProcessor).

Read more in the official documentation here.
You can download Photon Voice 2 here.